Avisos
Vaciar todo

Problemas con cambio a SSL  

Página 1 / 2
 
Pilar
 Pilar
Reputable Member

Buenos días.

Acabo de instalar El certificado SSL en un pack Wordpress 3Gb que tengo contratado con Webempresa.

Y no me funciona la web. Adjunto pantallazo.

He seguido todos los pasos del blog: https://www.webempresa.com/blog/activar-ssl-https-en-wordpress.html
He hecho una revisión con Stephan y me indica lo siguiente:
centralitatelefono.es --> Aparcado --> /home/surtelec/public_html
instalacioncentralitas.com --> Aparcado --> /home/surtelec/public_html
surtelec-cp148.wordpresstemporal.com --> Aparcado --> /home/surtelec/public_html
surtelecommadrid.com --> Principal --> /home/surtelec/public_html
---------------------------
Nameservers de cada dominio:
---------------------------
surtelecommadrid.com apunta según google a:
;; connection timed out; no servers could be reached
Atención !!!! NS del dominio surtelecommadrid.com no apunta al servidor de Webempresa según google
----------------------------------------------------------------------------------------
centralitatelefono.es apunta según google a:
;; connection timed out; no servers could be reached
Atención !!!! NS del dominio centralitatelefono.es no apunta al servidor de Webempresa según google
----------------------------------------------------------------------------------------
instalacioncentralitas.com apunta según google a:
;; connection timed out; no servers could be reached
Atención !!!! NS del dominio instalacioncentralitas.com no apunta al servidor de Webempresa según google
----------------------------------------------------------------------------------------

No entiendo por qué Google dice que estos dominios no apuntan al servidor de Webempresa ¿?

También adjunto esta indicación:
Configuración de los Registros MX de los dominios de la cuenta:
El registro MX de mayor prioridad de tu dominio surtelecommadrid.com ( connection ) apunta a la IP que no es una IP del servidor de Webempresa, por tanto tendrás que consultar con el administrador de connection (el otro proveedor) ya que el mail se gestiona por ese servidor
Vemos que el dominio surtelecommadrid.com lo tienes apuntado a un MX externo, pero en tu cPanel, no tienes marcada la opción de Agente de transporte de correo remoto , deberías de acceder a tu cPanel >> Entrada de MX >> Seleccionar el dominio surtelecommadrid.com >> Seleccionar Agente de transporte de correo remoto, y pulsar en Cambiar
El registro MX de mayor prioridad de tu dominio centralitatelefono.es ( connection ) apunta a la IP que no es una IP del servidor de Webempresa, por tanto tendrás que consultar con el administrador de connection (el otro proveedor) ya que el mail se gestiona por ese servidor
Vemos que el dominio centralitatelefono.es lo tienes apuntado a un MX externo, pero en tu cPanel, no tienes marcada la opción de Agente de transporte de correo remoto , deberías de acceder a tu cPanel >> Entrada de MX >> Seleccionar el dominio centralitatelefono.es >> Seleccionar Agente de transporte de correo remoto, y pulsar en Cambiar
El registro MX de mayor prioridad de tu dominio instalacioncentralitas.com ( connection ) apunta a la IP que no es una IP del servidor de Webempresa, por tanto tendrás que consultar con el administrador de connection (el otro proveedor) ya que el mail se gestiona por ese servidor
Vemos que el dominio instalacioncentralitas.com lo tienes apuntado a un MX externo, pero en tu cPanel, no tienes marcada la opción de Agente de transporte de correo remoto , deberías de acceder a tu cPanel >> Entrada de MX >> Seleccionar el dominio instalacioncentralitas.com >> Seleccionar Agente de transporte de correo remoto, y pulsar en Cambiar.

Por favor preciso de vuestra ayuda.

Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 15/03/2017 12:42 pm
Pilar
 Pilar
Reputable Member

Hola.

He logrado que cargue la página, lo único que ocurre es que sale un triangulito amarillo que indica que la conexión no es segura, partes de esta página no son seguras (como imágenes). ¿?

Agradezco vuestra colaboración.
Un saludo

ResponderCitar
Respondido : 15/03/2017 1:10 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Pilar.

Esto suele ocurrir cuando en tu web se esta cargando contenido mixto.
Por ejemplo cuando un absolute URL path está configurado en el lugar de relative paths para imágenes, CSS, o archivos JavaScript.

Absolute path

Relative path

o tienes URl externas que no están cifradas.

Para solucionar esto puedes utilizar el plugin -> Really Simple SSL, una vez instalado, revisara todss las URl y las modificara para que carguen con https.

Un saludo

Esta publicación ha sido modificada el hace 6 meses por antonio
ResponderCitar
Respondido : 15/03/2017 1:51 pm
Pilar
 Pilar
Reputable Member

Hola.

Gracias por tu respuesta Pepe.

He hecho lo que me indicas, pero me temo que sigo igual.
Activo el plugin y en la configuración ya me salen problemas, para ver si está funcionando el solucionados de contenido mixto me remite al código fuente de la página en el que debo buscar data-rsssl=1, y no lo localizo por ninguna parte.
Mando pantallazos de los ajustes.

Un cordial saludo

ResponderCitar
Respondido : 15/03/2017 4:02 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Lo que he detectado es que las urls de tu menú tienen http en lugar de https
Prueba eliminando y creando nuevamente los ítems de menú.

Si estas usando algún plugin de cache prueba limpiar la cache.

Otra solución es buscar todas las cadenas
Contenido solo visible a usuarios registrados y reemplazaras por https

Puedes revisar:
https://www.webempresa.com/blog/cambiar-wordpress-de-un-dominio-a-otro.html

Saludos.

ResponderCitar
Respondido : 15/03/2017 9:21 pm
Pilar
 Pilar
Reputable Member

Hola.

Lo que me dices de eliminar los item de menús y volverlos a crear, no me da resultado además al entrar en un item de menú la url me sale perfectamente con su https. Mando pantallazos.

Son solo 5 item los que no salen seguros en el navegador. Los demás salen perfectamente con su candidato verde

Ya borré la caché varias veces...

Gracias por tu respuesta.

Un saludo

ResponderCitar
Respondido : 16/03/2017 9:58 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Pilar.

El de inicio es que te sigue cargando con http:

.- Accede Apariencia -> Menú
.- Despliega inicio y modifica la URL cambiando el protocolo por https

Un saludo

ResponderCitar
Respondido : 16/03/2017 10:32 am
Pilar
 Pilar
Reputable Member

Hola Pepe.

Ya lo he hecho, y he borrado caché.

Sigo igual 🙁

Gracias, un saludo

ResponderCitar
Respondido : 16/03/2017 10:41 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pilar
 Pilar
Reputable Member

Hola.

Tengo un grave problema.

Los clientes ya no pueden entrar en la web con http, les da error.

¿Hasta qué punto es beneficioso lo del candidato, si ahora a todos los clientes les va a salir error al entrar en la web?

Estoy por restaurar y olvidarme del candadito, la verdad.

Estoy muy desesperadad a la par que decepcionada.... 🙁

Un saludo.

ResponderCitar
Respondido : 16/03/2017 11:08 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Pilar.

Bien, uno solucionado, Tranquila que los encontramos todos 😉
Tienes el bloque de después del banner con los enlaces de Leer Más con http

.- Accede Apariencia -> Widgets
.- Selecciona Inicio

.- Despliega la posición Feature
En esa posición veras los tres bloques que tienes con un widget de texto
.- Despliega los bloques de texto y modificas las URL

Revisa los enlaces que tienes en la pagina o entrada de ¿Por qué elegirnos? ya que también tienes con http.

Un saludo

ResponderCitar
Respondido : 16/03/2017 11:12 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pilar
 Pilar
Reputable Member

Hola.
Estoy solucionando unos cuantos directamente quitando el logo y después poniéndolo de nuevo. así ya he solucionado 3 item.

Muchas gracias Pepe, voy a ir poco a poco solucionándolo, agradezco tu interés.

Pero, por favor, podrías decirme cómo solucionar el tema de que ahora mis clientes entran en la web y les sale error... Deberé llamar a todos para decirles que borren el historial de su navegador?...

Un saludo

ResponderCitar
Respondido : 16/03/2017 11:17 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Pilar.

Nada, no tienes que llamar a nadie y menos eliminar el certificado si no quieres los navegadores te bloqueen el acceso a tu pagina 😉

Edita el archivo htacces que tienes en tu cuenta de hosting y añade lo siguiente al principio de tu archivo:

# Enviar trafico HTTP a HTTPS
RewriteEngine On
RewriteCond %{ENV:HTTPS} !on [NC]
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$  https://www.surtelecommadrid.com/$1  [R=301,L,NE]

Con esto se re-direcciona todo lo que entre por http a https.

Recuerda que tiene que ser lo primero del archivo.

Un saludo

ResponderCitar
Respondido : 16/03/2017 11:37 am

Cursos Gratuitos WordPress

Pilar
 Pilar
Reputable Member

Hola!!

Si, esta acción la hice una vez instalé el certificado según el blog:
https://www.webempresa.com/blog/activar-ssl-https-en-wordpress.html

Y estando hecho este tema, me llama el cliente y me dice que no puede entrar en su web... 🙁 🙁

Adjunto pantallazos.

Gracias Pepe, un saludo

ResponderCitar
Respondido : 16/03/2017 11:55 am
Pilar
 Pilar
Reputable Member

Hola.

He ido revisando todos los item de los menús uno por uno, he ido solucionando el tema quitando las imágenes y volviéndolas a cargar (absolutamente todas las imágenes). también he ido enlace por enlace cambiando el http por https.

Casi todo está solucionado menos INICIO Y CONTACTO. Que la verdad no sé qué hacer.

En INICIO he realizado los cambios que me indicaste, en los Widgets y en los enlaces, pero sigue igual 🙁

Y en CONTACTO he cambiado también la dirección con el https pero no se ha solucionado....

Un saludo

ResponderCitar
Respondido : 16/03/2017 1:07 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pilar
 Pilar
Reputable Member

Hola.

Bueno pues después de limpiar caches e historiales de navegadores y de irme a comer...

Ya están solucionados los dos item que faltaban 🙂

Por cierto, antes de hacer todo lo que he tenido que hacer en las imágenes de cada página, desactive el plugin Really Simple SSL ya que no servía para nada, lo desinstalare también.

Por otro lado quería decir que está fenomenal la guía que se nos facilita en el blog, gracias a César Maeso, de corazón. https://www.webempresa.com/blog/activar-ssl-https-en-wordpress.html

Pero hay algo que no se indica y creo que es vital para aquellos que somos más bien poco hábiles en estos menesteres.
¡¡Cuidado con el contenido mixto!!, ya que te vas a ver dando vuelta a toda la web quitando las imágenes y enlaces y volviéndolos a poner uno por uno...

Gracias Pepe, por tu paciencia. 🙂

Un saludo

ResponderCitar
Respondido : 16/03/2017 4:46 pm
Página 1 / 2