Avisos
Vaciar todo

Hosting WordPress 70% dto Dominios promo

Al compartir en X con Revive Old Posts no se muestra la imagen  

 
Levantemedia
 Levantemedia
Honorable Member

Hola:

Desde hace unos días he visto que al compartir automáticamente entradas en X con Revive Old Posts, estas publicaciones se muestran sin imagen. Los primeros días el plugin sí que estaba publicando con imagen, pero ahora veo que esta se muestra en blanco. No he tocado nada en la configuración del plugin. En Facebook sí que se están mostrando bien las imágenes de las publicaciones. No sé qué puede haber cambiado, supongo que debe ser algo de la Twitter Card pero no sé dónde mirarlo, antes estaba incluido en el Yoast SEO. A ver si me pueden ayudar. Adjunto capturas de X y de los ajustes del Revive Old Posts.

image
image
image

 Muchas gracias.

Contenido solo visible a usuarios registrados

Citar
Respondido : 09/02/2024 12:29 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

Antes de compartir prueva el validador:

-> https://cards-dev.twitter.com/validator

Si todo es correcto y ves que carga la imagen, prueba a compartir ese artículo:

screenshot cards dev.twitter.com 2024.02.09 14 09 06

 

Un saludo

ResponderCitar
Respondido : 09/02/2024 1:09 pm

Cursos Gratuitos WordPress

Levantemedia
 Levantemedia
Honorable Member

@pepesoler hola:

Si pego la url normal en el validador no muestra ningún error. 

image

 Si lo pego con la url que genera Revive Old Posts, sí:

image

 De este modo, en Twitter, sigue mostrando la publicación sin imagen:

image

 ¿Se puede hacer algo al respecto?

Muchas gracias. 

ResponderCitar
Respondido : 12/02/2024 8:47 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

Prueba lo siguiente:

.- Edita la entrada.

.- En las opciones de Yoast, selecciona la pestaña " Social "

.- Despliega " Apariencia en Twitter "

.- Añade la imagen en " Imagen para Twitter "

screenshot mary52.webempresa.eu 2024.02.12 10 54 04

 

Comprueba si se comparte bien.

 

Un Saludo

ResponderCitar
Respondido : 12/02/2024 9:55 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Levantemedia
 Levantemedia
Honorable Member

@pepesoler hola:

Nada, sigue compartiéndose sin imagen aunque la pongas ahí. 

image
image

 

ResponderCitar
Respondido : 12/02/2024 10:22 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola, 

El error indica que el robots.txt no permite el rastreo de los bots de X (twitter), verifica si al añadir las siguientes líneas en tu archivo robots.txt se soluciona

User-agent: Twitterbot
Allow: /images

Puedes añadir esto editando tu archivo robots.txt con Yoast SEO desde el apartado de Herramientas → Editor de archivos

image
image

Verifícalo y nos comentas como va todo

Un Saludo

ResponderCitar
Respondido : 12/02/2024 2:16 pm

Levantemedia
 Levantemedia
Honorable Member

@karen Hola!

Perfecto. Ahora ya se muestran las imágenes. Vaya, desconocía que estaba impidiendo el rastreo de los bots de X mediante robots.txt. Si ves algo más que no debería estar en el robots.txt te lo agradecería. 

Muchas gracias. 

ResponderCitar
Respondido : 12/02/2024 2:28 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola, 

Enhorabuena se ha solucionado como necesitas, por ahora no veo nada adicional, sin embargo si quieres revisar como optimizar tu archivo robots.txt al máximo puedes revisar las siguientes sugerencias que tenemos en el siguiente articulo → https://www.webempresa.com/blog/robots-txt-en-wordpress-que-problema-tienes-googlebot.html#nbspnbspComo_optimizar_el_Robots_al_maximo

Ten en cuenta mantener la opción de twitter (x), ya que si lo eliminas puede bloquearse nuevamente 

Un Saludo 

ResponderCitar
Respondido : 12/02/2024 3:22 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress