Contact Form 7 Datepicker español  

 
Edurne
 Edurne
Reputable Member

Buenas tardes:

Tengo instalado el plugin Contact Form 7 Datepicker pero está en inglés y necesitaría poder cambiar 2 cosas en los campos Fecha de entrada y Fecha de salida del formulario:

- Traducir al castellano los textos del datepicker (meses, días de la semana etc.)
- Que figure como primer día de la semana el lunes y no el domingo.

Veo que el plugin incluye un archivo en español en la siguiente ruta, pero no sé como activarlo:

/public_html/wp-content/plugins/contact-form-7-datepicker/js/jquery-ui-timepicker/i18n/jquery-ui-timepicker-es.js

También he intentado traducir al castellano el fichero /jquery-ui-timepicker-en-GB.js pensando que es del que tira, pero no me ha servido.

A ver si me podéis ayudar. Saludos,

Edurne.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 05/02/2016 5:46 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

HOla

Entiendo que has usado este plugin :
https://wordpress.org/plugins/contact-form-7-datepicker/

Según lo que veo en la pantalla de configuración del plugin tienes para cambiar el primer día de la semana (first-day) : https://wordpress.org/plugins/contact-form-7-datepicker/screenshots/

Con respecto a las traducciones , no veo ningún formulario, envía la url exacta
Contenido solo visible a usuarios registrados

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/02/2016 8:18 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Edurne
 Edurne
Reputable Member

Buenas tardes,

Ya he solucionado el tema del día de la semana, el problema era que no tenía actualizas las versiones del propio plugin y de wordpress y no salían las opciones de configuración.

Lo que no consigo es poner los meses y días en castellano, a pesar de que en la pestaña Datepicker theme del backend se vean los textos traducidos. Adjunto captura.

He probado traducir con WPML string pero nada.

La url exacta donde está el formulario es esta, (columna derecha):

Contenido solo visible a usuarios registrados

Gracias,

Edurne.

ResponderCitar
Respondido : 08/02/2016 6:43 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Lo que sucede es que es en javascript en donde estan las traducciones, revisa este hilo de discusión
https://wordpress.org/support/topic/plugin-contact-form-7-datepicker-language-setting

Verifica si con esto se traduce a tu idioma por defecto.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/02/2016 10:37 pm

Cursos Gratuitos WordPress

Edurne
 Edurne
Reputable Member

Buenas tardes,

He seguido el hilo indicado y el archivo /wp-content/plugins/contact-form-7-datepicker/contact-form-7-datepicker.php no contiene el código que se indica en el foro para sustituir.

He buscado en todos los archivos del plugin y en ningúno encuentro add_action('init', array(__CLASS__, 'admin_l10n')); para poder cambiarlo. (adjunto archivo)

Tengo las últimas versiones en ambos plugins. 2.5.1 en datepicker y 4.3.1 en contact form 7.

Viendo que en la ruta /contact-form-7-datepicker/js/jquery-ui-timepicker/i18n/jquery-ui-timepicker-es.js están los textos en castellano seguro que habrá manera de poder activarlo, pero yo al menos no lo consigo.

A ver si me podéis ayudar. Gracias.

ResponderCitar
Respondido : 09/02/2016 5:41 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

HOla

En la línea 73 del archivo adjunto hay un código que hace referencia al .js

plugins_url('js/jquery-ui-timepicker/i18n/jquery-ui-timepicker-' . $regional . '.js', __FILE__),

Prueba cambairlo por :

plugins_url('js/jquery-ui-timepicker/i18n/jquery-ui-timepicker-es.js', __FILE__),

Es decir en lugar de que la ruta se forme en funcio´n de la variable regional, colocas directamente el nombre del archivo en español

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/02/2016 8:20 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Edurne
 Edurne
Reputable Member

Buenos días;

He cambiado el código tal y como me indicáis pero los textos siguen apareciendo en inglés :-((

Adjunto archivo editado y enlace web Contenido solo visible a usuarios registrados

Alguna sugerencia? Gracias,

Edurne.

ResponderCitar
Respondido : 10/02/2016 11:16 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Analizando el código fuente de tu página parece que ya se está cargando el archivo js correcto, pero veo que sigue sin aplicarse. Es posible que haya un conflicto con el plugin WPML. Entiendo que el idioma por defecto que tienes configuración en tu WordPress es el español. De no ser así, prueba a ponerlo para ver si funciona.

En este hilo del soporte del plugin se explica otra posible solución que podrías probar:

https://wordpress.org/support/topic/language-for-datetimepicker

Recuerda hacer una copia de seguridad de los archivos que vayas a modificar, para poder volver al estado anterior en caso de que surjan problemas tras los cambios.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/02/2016 1:53 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Edurne
 Edurne
Reputable Member

Solucionado!

No había conflicto con WPML, la solución ha sigo añadir el siguiente código en Apariencia / editor / footer.php antes de la etiqueta

Mil gracias,

Edurne.

ResponderCitar
Respondido : 10/02/2016 4:04 pm

Por favor Iniciar Sesión o Registro