Fallos en w3 total cache  

 
Salvador
 Salvador
Usuario activo

Buenos dias, he seguido vuestro fantástico tutorial:
https://www.webempresa.com/blog/item/1389-como-conseguir-que-tu-wordpress-sea-ultrarrapido.html
y se presenta 2 "fallos".

Cuando activo "Object Cache" el panel de administración se vuelve muy muy lento, tardando casi 30 segundos en acceder a cualquier opción, deshabilito el Object Cache y todo vuelve a la normalidad.

Otra cosa que es el tema del CDN, he creado el subdominio cdn.XXXX:com que apunta a la raiz del dominio principal, /public_html. Pues bien, pongo el subdominio, le doy a test mirror y me da el error "Error: Unable to resolve hostname: cdn.XXXXXX.com, añado que el subdomonio funciona bien.

Si aun ese error, habilito el CDN, el blog pierde el formato, cosa normal porque no se estan cargando los estáticos.

Pues bien, ¿como podría solucionar estos 2 errores? Muchas gracias de antemano

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 01/04/2014 11:39 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

El problema con el Object caché podría estar relacionado con el tema de WordPress que estás usando o algún plugin adicional que hayas añadido a tu WordPress. Para averiguar esto tendrías que probar a cambiar temporalmente de tema de WordPress o a desactivar algunos plugins para ver si encuentras la causa del problema, aunque quizá lo mejor sería que desactivaras el Object Cache.

Sobre el tema del CDN, en primer lugar tendrías que asegurarte de que el subdominio está creado correctamente y funciona. Tendrías que indicarnos la url de ese subdominio para comprobar que funciona. Comentas que cuando lo activas no carga elementos de la página. Cuando esto ocurra tendrías que revisar el código fuente de la página para que la dirección de carga del CSS para tratar de averiguar si la ruta es correcta y se corresponde con la del subdominio.

ResponderCitar
Respondido : 01/04/2014 3:09 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Salvador
 Salvador
Usuario activo

Buenas¡¡, gracias por responder.

El subdominio creado para el CDN es cdn.kustruki.com ¿funciona perfectamente verdad?

ResponderCitar
Respondido : 01/04/2014 3:11 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

El subdominio parece correctamente creado. Tal como está debería de funciona la activación del CDN en el W3 Total Cache.

Tendrías que activarlo temporalmente para que pudiéramos ver que se muestra y su código fuente.

ResponderCitar
Respondido : 01/04/2014 6:15 pm

Cursos Gratuitos WordPress

Salvador
 Salvador
Usuario activo

Pues lo acabo de activar, a ver si podemos solucionarlo 😀

ResponderCitar
Respondido : 01/04/2014 6:25 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Veo que tu web carga bien, pero revisando el código fuente no parece que el CDN se encuentre activado en este momento.

ResponderCitar
Respondido : 01/04/2014 6:41 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Salvador
 Salvador
Usuario activo

Acabo de vaciar la cache, seguramente sera por eso no?

Ahora mismo mi configuración a excepción de la Object Cache, es similar al tutorial

ResponderCitar
Respondido : 01/04/2014 6:44 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Salvador

Veo que con las configuracoines que has realizado tiene una carga buena en tiempo de tu sitio web, por ejemplo :

Contenido solo visible a usuarios registrados

Limpia la cache de tu navegador o prueba desde otro navegador y verifica si carga lenta

Saludos.

ResponderCitar
Respondido : 01/04/2014 7:56 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Salvador
 Salvador
Usuario activo

Muchas gracias, parece que funciona todo a la perfección, un 10 por vosotros.

ResponderCitar
Respondido : 01/04/2014 9:47 pm