Avisos
Vaciar todo

[Resuelto] imposible instalar Learndash  

 
Jose Ignacio
 Jose Ignacio
Usuario eminente

Buenos días,

Estoy intentando instalar Learndash, y parece labor imposible. Incluso desinstalando y volviendo a instalar, limpiando caché, todo actualizado al día, no se me marcan incompatibilidades... no hay forma (mis conocimientos informáticos son muy básicos). Les he enviado un ticket y se lo están tomando con mucha tranquilidad.

El error que me aparece es este:

Fatal error: Cannot redeclare wpProQuiz_autoload() (previously declared in /home2/aptitude/public_html/wp-content/plugins/wp-pro-quiz/wp-pro-quiz.php:40) in /home2/aptitude/public_html/wp-content/plugins/sfwd-lms/includes/lib/wp-pro-quiz/wp-pro-quiz.php on line 77

 

¿Alguien sabe a qué se debe o si hay algo que se me ha pasado?

Muchas gracias !!!

Contenido solo visible a usuarios registrados

Respondido : 03/03/2021 9:09 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Jose.

El problema por lo que muestras esta en el plugin " wp pro quiz "

Modifica la versión de PHP que tienes instalada paar ese dominio e instale la 7.4.

Puedes modificar la versión de PHP fácilmente desde tu cuenta de cPanel -> Configurar PHP, solo tienes que seleccionar la versión del desplegable:

-> https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

 

El cambio de Version de PHP no afecta a los archivos de tu instalación, una vez modificado revisa que todas las secciones caguen sin problemas, si vieras que alguna sección hay problemas puedes bajar de versión de PHP.

 

Revisa si con estos pasos se soluciona.

 

Un saludo

Respondido : 03/03/2021 9:42 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Jose Ignacio
 Jose Ignacio
Usuario eminente

@pepesoler

Cambiado a 7.4 y sigue igual, aproveché para mirar el estado de salud, y me pone esto relacionado con el php:

 

falta uno o más módulos recomendados

Los módulos PHP realizan la mayoría de las tareas en el servidor que hacen que tu sitio funcione. Cualquier cambio en ellos debería hacerlo el administrador de tu servidor.

El equipo de alojamiento de WordPress mantiene una lista de estos módulos, tanto los recomendados como los obligatorios, en el manual del equipo (abre en una nueva pestaña).

  • Advertencia El módulo opcional, imagick, no está instalado, o ha sido desactivado.

 

No recuerdo haber quitado nada de estas cosas   ....

Respondido : 03/03/2021 10:00 am
Jose Ignacio
 Jose Ignacio
Usuario eminente

listo, todo arreglado, era una incompatibilidad con otro plugin de encuestas. Muchísimas gracias !!!

Respondido : 03/03/2021 10:16 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Jose.

Genial !!! me alegra que lo solucionaras 😀 

Deja la version de PHP en la 7.4 si funcina todo bien.

 

Cerramos el tema.

Un saludo

Respondido : 03/03/2021 10:40 am