Avisos
Vaciar todo

menu movil  

 
Daniel
 Daniel
Usuario activo

Hola,
Ayer estuve actualizando los plugins, temas y demás cosas y hoy me han reportado un problema con el menú.
El menú principal en dispositivo movil no se ve cuando se pincha en las barritas de desplegado. Tengo un error en la sección de menú: Menu walker class is overriden by a theme/plugin. Current value = Porto_Walker_Nav_Menu_Edit. Navigation menu permissions may still work. How to fix?

He intentado ver por internet alguna solución pero no he conseguido hacerlo.
Pueden ayudarme?

Gracias, un saludo.

Contenido solo visible a usuarios registrados

Citar
Respondido : 18/10/2021 5:23 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Hola Daniel,

Hemos podido revisar el comportamiento del menu mobile de tu sitio y se despliega sin problemas, también no hemos podido ver el error al que haces referencia.

Nos podrías compartir captura de donde visualizas el error y de ser posible en que caso no te funciona el menu ya que por aca si que nos ha funcionado.

Saludos!

ResponderCitar
Respondido : 18/10/2021 5:46 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Daniel
 Daniel
Usuario activo

Hola Bruno,

Al darle para que muestre el menú en la izquierda sale el menú de usuario, pero no el menú principal.

Si te metes desde PC se ve el menú con 8 categorías y varias subcategorías en cada una. Esto desde el móvil no se ve.

 

IMG 06640C860CF5 1
Captura de pantalla 2021 10 18 a las 19.45.37

Un saludo.

 

ResponderCitar
Respondido : 18/10/2021 6:46 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal Daniel,

Vale la impresión al revisar el sitio es que las categorías se ocultan en mobile, y el funcionamiento del menu mobile es correcto

Necesitamos ubicar el error, anteriormente cuando se visualizaba el sitio en mobile a donde se mostraban dichas categorías? en el menu desplegable donde solo aparecen las opciones de usuario?

Quedamos atentos a ver las capturas solucitadas donde puede apreciarse el error que mencionabas y en este caso nos gustaría ver si es posible como funcionaba el menu antes del problema

Saludos!

ResponderCitar
Respondido : 18/10/2021 7:04 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Daniel
 Daniel
Usuario activo

Anteriormente en el desplegable donde ahora se muestra solo el menú de usuario se mostraba primero el principal y debajo el de usuario.

Ayer actualice el Tema y algunos plugins y hoy he visto que no se mostraba, no he cambiado nada.

En la sección de menú me salta este error que antes no estaba:

Captura de pantalla 2021 10 18 a las 20.09.31

 

Gracias por la ayuda.

Un saludo.

ResponderCitar
Respondido : 18/10/2021 7:10 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Daniel, 

Actualmente veo que tienes diferentes errores en tu tema, específicamente en el child theme que usas

[18-Oct-2021 14:47:59 UTC] PHP Fatal error: require_once(): Failed opening required 'custom-class-walker-nav-menu.php' (include_path='.:/opt/alt/php73/usr/share/pear') in /home/panthers/public_html/panthershishastore.com/wp-content/themes/porto-child/functions.php on line 78
[18-Oct-2021 14:48:09 UTC] PHP Fatal error: require_once(): Failed opening required 'custom-class-walker-nav-menu.php' (include_path='.:/opt/alt/php73/usr/share/pear') in /home/panthers/public_html/panthershishastore.com/wp-content/themes/porto-child/functions.php on line 78
[18-Oct-2021 14:48:15 UTC] PHP Fatal error: require_once(): Failed opening required 'custom-class-walker-nav-menu.php' (include_path='.:/opt/alt/php73/usr/share/pear') in /home/panthers/public_html/panthershishastore.com/wp-content/themes/porto-child/functions.php on line 78

Es posible que el error este relacionado directamente con el childtheme, prueba activar el tema padre y verifica si se solucioar si es asi te sugiero contactes con el soporte de la plantilla y le comentes lo que sucede para que te indique de forma precisa como solucionarlo o si tienes una nueva versión para el childtheme, ten en cuenta que al ser un tema de pago no podemos comprobar su funcionalidad o porque sucede este error

Realiza la prueba sobre el tema padre y nos comentas como ha ido todo

PD: Ten en cuenta siempre realizar una copia de seguridad de tu sitio web, de esta forma si se genera algun error puedes restaurarla. De igual forma si deseas restaurar una versión del sitio web cuando funcionaba puedes usar la herramienta de superbackup que tienes disponible en tu cPanel, puedes ver como funciona en el siguiente articulo -> https://www.webempresa.com/blog/copias-de-seguridad-desde-el-panel-de-hosting-cpanel.html

Un Saludo 

 

ResponderCitar
Respondido : 18/10/2021 7:40 pm

Cursos Gratuitos WordPress

Daniel
 Daniel
Usuario activo

Hola Karen,

Muchas gracias por la ayuda, hago las comprobaciones e intentaré contactar con el soporte del tema.

Si no consigo resolverlo haré un restore del backup.

Os comento con lo que sea.

 

Un saludo.

ResponderCitar
Respondido : 18/10/2021 8:07 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Hola Daniel,

Quedamos atentos a que puedas resolver el error, nos comentas el resultado

Saludos!

ResponderCitar
Respondido : 18/10/2021 8:11 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Daniel
 Daniel
Usuario activo

Hola Bruno,

Ante la duda, he restaurado el public_html del Sábado pasado y todo funciona con normalidad.

Creo que el problema es un plugin interno del Tema que actualicé el Domingo.

 

Muchísimas gracias por la ayuda, a partir de ahora haré backups antes de cada actualización.

Un saudo.

ResponderCitar
Respondido : 19/10/2021 9:28 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Daniel

Genial!!! me alegar que lo solucionaras.

Cualquier consulta que tengas no dudes en comunicarlo.

 

Cerramos el tema.

Un saludo

 

ResponderCitar
Respondido : 19/10/2021 9:58 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación