paginas amp AMPforWP  

 
diego
 diego
Estimable Member

hola buenos dias tengo instalado el modulo AMPforWP para las paginas amp. Cuando busco esas paginas en el googlesearch me pone esto

https://proasalud.com/atremorine-75gr-ebiotec/amp
Tipo de robot de Google: Móvil: smartphone
Redireccionada el lunes, 9 de abril de 2018, 10:27:07 GMT-7
Esta URL redirige a:
https://proasalud.com/atremorine-75gr-ebiotec
Respuesta HTTP descargada:

?

Sabeis porque se genera esa redireccion? no tendria que ser una pagina distinta?

Citar
Respondido : 10/04/2018 2:24 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola diego.

Esa dirección la realiza el propio plugin.
Los plugin de AMP lo que realizan es crear otra versión de la pagina para la versión móvil y dependido de el soporte que utilice el usuario muestra una u otra.

Te dejo información a la guía del plugin:
-> https://ampforwp.com/tutorials/article/amp-in-wordpress-beginners-guide/

Un saludo

ResponderCitar
Respondido : 10/04/2018 3:03 pm

Cursos Gratuitos WordPress

diego
 diego
Estimable Member

Ya Pepe , hasta ahi llego. Lo que te digo es que en otras tiendas que tengo existen esas 2 paginas.
https://proasalud.com/atremorine-75gr-ebiotec/amp
https://proasalud.com/atremorine-75gr-ebiotec
Y aqui aparece la primera redireccionada a la segunda aunque lo haga desde un movil, y el searchconsole me dice

proasalud.com/atremorine-75gr-ebiotec/amp
Tipo de robot de Google: Móvil: smartphone
Redireccionada el lunes, 9 de abril de 2018, 10:27:07 GMT-7
Esta URL redirige a:
proasalud.com/atremorine-75gr-ebiotec
Porque se genera esa redireccion?

ResponderCitar
Respondido : 10/04/2018 6:10 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es como si tuvieras algún tipo de redirección, has agregado código en tu .htaccess?, posiblemente también puede hacer conflicto con otro plugin, prueba ir desactivando plugins

Saludos.

ResponderCitar
Respondido : 10/04/2018 6:57 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

diego
 diego
Estimable Member

no ,no he agregado nada.Algunas paginas existen en las 2 versiones normal y amp y otras las amp esta redireccionadas. Tiene que ser alguna opcion de este modulo.

ResponderCitar
Respondido : 10/04/2018 7:14 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Prueba si te sucede lo mismo con un plugin alterno, por ejemplo:
https://es.wordpress.org/plugins/amp/

Saludos.

ResponderCitar
Respondido : 10/04/2018 10:44 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

diego
 diego
Estimable Member

instale este y aqui el problema es que las paginas de los productos con la terminacion amp me da error 404 page not found. Probe a añdirle el yoast glue y lo mismo. Con el otro plugin me direccionaba las amp a la pagina normal y con este que me digiste tu me dice pagina no encontrada. Vamos a peor jajajaja

ResponderCitar
Respondido : 11/04/2018 12:43 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Diego.

vuelve a dejar el modulo que tenias instado.

Para probar si las URL están bien implementadas puedes acceder a esta URL y añadiendo la URL que quieres probar te indicara si esta bien implementada.

-> https://search.google.com/test/amp

Un saludo

ResponderCitar
Respondido : 11/04/2018 2:41 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

diego
 diego
Estimable Member

Hecho :me dice esto:
Se ha detectado un enlace a una página AMP en la URL enviada
Parece que has incluido la URL de una página canónica. Esta página dirige a la siguiente URL de AMP:
https://proasalud.com/atremorine-75gr-ebiotec/amp/
y si pincho ahi me dice:
Soluciona los 4 problemas siguientes

Etiqueta HTML prohibida con equivalente de AMP
La etiqueta "img" solo puede depender de la etiqueta "noscript". ¿Querías decir "amp-img"?
1 instancia

La etiqueta HTML está prohibida o bien se ha hecho un uso no válido
El atributo "action" no puede aparecer en la etiqueta "FORM [method=POST]".
1 instancia
A la etiqueta "style amp-custom" le falta el atributo obligatorio "amp-custom".
3 instancias
A la etiqueta "FORM [method=GET]" le falta el atributo obligatorio "target".
1 instancia

Hojas de estilo CSS no válidas
No se permite insertar el atributo "style" en documentos de AMP. En su lugar, utilice la etiqueta "style amp-custom".
3 instancias
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/plugins/advanced-woo-search/assets/css/common.css?ver=1.37", que no es válido.
1 instancia
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.0.1", que no es válido.
1 instancia
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/plugins/improved-sale-badges-free-version/assets/css/style.css?ver=4.9.5", que no es válido.
1 instancia
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/plugins/kirki/assets/css/kirki-styles.css?ver=3.0.25", que no es válido.
1 instancia
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/plugins/woocommerce-facebook-share-like-button/css/fbshare.css?ver=4.9.5", que no es válido.
1 instancia
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/plugins/woocommerce/assets/css/photoswipe/default-skin/default-skin.css?ver=3.3.3", que no es válido.
1 instancia
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/plugins/woocommerce/assets/css/photoswipe/photoswipe.css?ver=3.3.3", que no es válido.
1 instancia
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=3.3.3", que no es válido.
1 instancia
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=3.3.3", que no es válido.
1 instancia
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=3.3.3", que no es válido.
1 instancia
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/plugins/yith-woocommerce-ajax-search/assets/css/yith_wcas_ajax_search.css?ver=4.9.5", que no es válido.
1 instancia
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/themes/giga-store-pro/css/animate.min.css?ver=3.5.1", que no es válido.
1 instancia
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/themes/giga-store-pro/css/bootstrap.min.css?ver=3.3.6", que no es válido.
1 instancia
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/themes/giga-store-pro/css/flexslider.css?ver=2.6.3", que no es válido.
1 instancia
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/themes/giga-store-pro/css/font-awesome.min.css?ver=4.6.3", que no es válido.
1 instancia
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/themes/giga-store-pro/css/jquery.mmenu.all.css?ver=1", que no es válido.
1 instancia
El atributo "href" de la etiqueta "link rel=stylesheet for fonts" se ha establecido con el valor "https://proasalud.com/wp-content/themes/giga-store-pro/style.css?ver=1.4.0", que no es válido.
1 instancia

Faltan etiquetas de AMP o no son correctas
Falta la etiqueta obligatoria "amphtml engine v0.js script" o esta no es correcta.
1 instancia
Falta la etiqueta obligatoria "head > style[amp-boilerplate]" o esta no es correcta.
1 instancia
Falta la etiqueta obligatoria "meta charset=utf-8" o esta no es correcta.
1 instancia
A la etiqueta "html ⚡ for top-level html" le falta el atributo obligatorio "⚡".
1 instancia
Falta el texto obligatorio en la etiqueta "noscript > style[amp-boilerplate] - old variant" o no es correcto.
1 instancia
Al atributo "content" de la etiqueta "meta name=viewport" le falta la propiedad "minimum-scale".
1 instancia
Debe incluir la extensión en JavaScript 'amp-form' para la etiqueta 'FORM [method=GET]'.
1 instancia
Debe incluir la extensión en JavaScript 'amp-form' para la etiqueta 'FORM [method=POST]'.
1 instancia

ResponderCitar
Respondido : 11/04/2018 2:54 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Diego.

Pues esos errores son de codigo, parece que la web no esta bien para poder soportarlo o tienes algún plugin que te esta provocando esos errores.

Prueba a ir desactivando los plugin y ver si se soluciona.

Revisa lo siguiente -> https://algoentremanos.com/worpress-y-amp-errores-mas-comunes-y-como-solucionarlos/

Comprueba que lo tengas todo actualizado, plugins, WP y sobre todo tu plantilla, revisa si tienes actualizaciones de plantilla.

Un saludo

ResponderCitar
Respondido : 11/04/2018 3:17 pm

Cursos Gratuitos WordPress