Hosting WordPress Divi con Soporte en Español

pagos con Redsys no se marcan como completados  

 
Maria Elisa
 Maria Elisa
Usuario activo

Buenos días,

He buscado en el foro pero no encontré ningún tema (con solución) que responda a este.

La web funcionaba correctamente, y sin haber hecho ninguna actualización los pagos que se realizan con redsys se quedan en pendiente de pago, los realizados con paypal se completan correctamente.

Tiene algo que ver el tipo de certificado contratado? (esta con let's encrypt)

Alguna idea?

Muchas gracias!

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 29/08/2019 12:45 pm
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Elisa.

No creo que sea por tema de certificado a no ser que el plugin que tengas sea de hace mucho tiempo, los plugin de Redsys anteriormente no soportaban en certificado y se quedaban como pendientes.

¿ que módulo utilizas para redsys ? ¿ Te lo proporciono el banco, es el oficial ? ¿ Cuando termina el pago redirige a la web ?

Descarga el módulo de la web oficial de Redsys y vuelve a configurarlo
-> https://pagosonline.redsys.es/descargas.html

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 29/08/2019 12:58 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Maria Elisa
 Maria Elisa
Usuario activo

Buenas tardes,

Muchas gracias por responder Pepe, el módulo que uso para redsys es el oficial y está actualizado, y si, cuando termina el pago redirige correctamente a la web.

He reconfigurado el plugin y sigue igual :-/

ResponderCitar
Respondido : 29/08/2019 1:11 pm
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Elisa.

Ok, ¿ utilizas algún plugin de seguridad como puede ser Wordfence ?
si lo tienes lo desactivas.

.- Actualiza la versión de WordPress que veo que esta desactualizada.
.- Si tienes un plugin de SSL, lo desactivas
.- Elimina los plugins de redsys que tienes instalados menos el último que descargaste
.- En ajustes -> generales comprueba que las URL cargan con el protocolo https://tudominio....
.- Accede a las opciones de WooCommerce y edita las opciones de Redsys
.- Comprueba que en estado se encuentre en Procesando
. revisa si en el htaccess hay algun codigo de bloqueo de https

Ten en cuenta que el pedido no se queda como completado se queda como procesando hasta que cambies el estado a completado.

Revisa lo que te comento y vamos descartando cosas

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 29/08/2019 2:33 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Maria Elisa
 Maria Elisa
Usuario activo

Hola Pepe, te pido disculpas no haberte respondido, he estado hasta arriba de trabajo y vi tus pasos pero no tuve tiempo de ponerme con ellos, pero agradezco enormemente que tomaras tu tiempo en responder 🙂

Voy a intentar ponerme hoy con ello y te cuento qué tal, muchas gracias!

Elisa,

ResponderCitar
Respondido : 03/09/2019 9:53 am
Maria Elisa
 Maria Elisa
Usuario activo

Hola de nuevo Pepe,

He realizado todos los pasos que comentas, a excepción de actualizar wordpress a la última vesión, que al ser el paso a la versión 5 que tiene cambios mayores tengo que comprobar antes que todo sea compatible.

El resto de pasos los he hecho todos tal cual:
He desactivado el plugin de SSL, eliminado los plugins de redsys y vuelto a configurar, comprobado que en ajustes/generales cargue con https, configurado el módulo de redsys y en htaccess lo he dejado con lo mínimo:

# BEGIN WordPress

RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END WordPress

No se qué mas puedo hacer, alguna otra idea? U^_^

muchas gracias por vuestra atención!

ResponderCitar
Respondido : 04/09/2019 12:48 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Maria Elisa
 Maria Elisa
Usuario activo

Buenos días,

He conseguido dar con la solución, dejo aquí puesta la solución por si a alguien le ocurre lo mismo:
Teniendo CloudFlare , en firewall/settings hay que desactivar la opción "Browser Integrity Check", ahora toda la tienda funciona con https y redsys es capaz de devolver la acción validada a la tienda.

Resuelto, gracias igualmente 🙂

ResponderCitar
Respondido : 06/09/2019 11:20 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Elisa.

Genial !!! me alegra que lo solucionaras.
Gracias por informarnos y aportar la solución 😉

Cerramos el tema.

Un saludo y de nuevo agradecerte que aportarás la solución.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 06/09/2019 11:59 am

Cursos Gratuitos WordPress

Hosting WordPress Divi con Soporte en Español

Por favor Iniciar Sesión o Registro