Problema con los formularios de contacto.  

 
Ruben
 Ruben
Usuario eminente

Hola! Decidí escribirles porque ya no se que hacer. Primero estaba seguro que no era un problema del hosting pero despues de hacer algunas pruebas me quedé sin ideas y necesito un poco de ayuda.

Tengo varios sitios web alojados en la cuenta de hosting. Casi todos realizados en WordPress.
El problema es que no me funciona el formulario de contacto. Yo uso Contact Form 7 en todos los sitios.

El problema es que despues de intentar y no poder hacerlo funcionar decidí eliminar el plugin y probar con otros. Por ejemplo el de Jetpack y el Ninja Form.

Para mi sorpresa tampoco me funcionan y por eso decidí escribirles.

Los sitios web afectados son http://www.fabioshoes.com.ar y http://www.ruta25nono.com.ar

Con el Contact Form 7 me tira un error "Falló el envío del mensaje. Por favor, inténtelo más tarde o contacte con el administrador por otro medio." y en los demás plugin pareciera que funciona bien pero nunca me llegan las consultas. Tengo configurado un Gmail para recibir pero también probé usar un correo del hosting con el mismo resultado.

Muchas gracias.

Rubén Russo

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 25/02/2016 7:30 am
Julen
 Julen
Miembro Admin

Hola,

Los formularios de Contact Form recomendamos configurarlos con una cuenta de correo del Hosting y no de un servicio externo.

Prueba a modificar el campo FROM:

[your-name] 

Por:

[your-name] 

o simplemente:

tu_cuenta-del dominio@correo.com

Saludos

ResponderCitar
Respondido : 25/02/2016 9:22 am

Cursos Gratuitos WordPress

Ruben
 Ruben
Usuario eminente

Gracias por la respuesta. El tema es que antes funcionaba bien y ahora no. Es más, ya probé Ninja Form, Contact Form 7, Fast Secure Contact Form y el de JetPack y ninguno me llega la notificación al correo, a pesar que lo he cambiado por otros. Por eso creo que es un problema más profundo. Muchas gracias

ResponderCitar
Respondido : 26/02/2016 6:23 pm
Ruben
 Ruben
Usuario eminente

El Plugin Fast Secure Contact Form tiene un modo de envío de prueba y me dió un resultado "False"

Pego el log por si sirve para encontrar la solución:

Mensaje De Prueba Enviado
wordpress Examine correo electrónico a rukyrukeado@hotmail.com
El resultado fue:
Ver FAQ
bool(false)
Se muestra a continuación el resultado completo de la depuración:
Ver FAQ
object(PHPMailer)#14243 (75) {
["Version"]=>
string(6) "5.2.14"
["Priority"]=>
NULL
["CharSet"]=>
string(5) "UTF-8"
["ContentType"]=>
string(10) "text/plain"
["Encoding"]=>
string(4) "8bit"
["ErrorInfo"]=>
string(82) "SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshootin g"
["From"]=>
string(23) "rukyrukeado@hotmail.com"
["FromName"]=>
string(24) "Fast Secure Contact Form"
["Sender"]=>
string(0) ""
["ReturnPath"]=>
string(0) ""
["Subject"]=>
string(53) "Examine correo electrónico a rukyrukeado@hotmail.com"
["Body"]=>
string(85) "Esto es un mensaje de prueba generado por Fast Secure Contact Form
WordPress plugin. "
["AltBody"]=>
string(0) ""
["Ical"]=>
string(0) ""
["MIMEBody":protected]=>
string(86) "Esto es un mensaje de prueba generado por Fast Secure Contact Form
WordPress plugin.
"
["MIMEHeader":protected]=>
string(464) "Date: Fri, 26 Feb 2016 17:39:16 +0000
To: rukyrukeado@hotmail.com
From: Fast Secure Contact Form
Subject: =?UTF-8?Q?Examine_correo_electr=C3=B3nico_a_rukyrukeado@hotmail.com?=
Message-ID:
X-Mailer: PHPMailer 5.2.14 ( https://github.com/PHPMailer/PHPMailer)
Reply-To: rukyrukeado@hotmail.com
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

"
["mailHeader":protected]=>
string(0) ""
["WordWrap"]=>
int(0)
["Mailer"]=>
string(4) "smtp"
["Sendmail"]=>
string(18) "/usr/sbin/sendmail"
["UseSendmailOptions"]=>
bool(true)
["PluginDir"]=>
string(0) ""
["ConfirmReadingTo"]=>
string(0) ""
["Hostname"]=>
string(0) ""
["MessageID"]=>
string(0) ""
["MessageDate"]=>
string(31) "Fri, 26 Feb 2016 17:39:16 +0000"
["Host"]=>
string(0) ""
["Port"]=>
string(0) ""
["Helo"]=>
string(0) ""
["SMTPSecure"]=>
string(3) "ssl"
["SMTPAutoTLS"]=>
bool(true)
["SMTPAuth"]=>
bool(true)
["SMTPOptions"]=>
array(0) {
}
["Username"]=>
string(0) ""
["Password"]=>
string(0) ""
["AuthType"]=>
string(0) ""
["Realm"]=>
string(0) ""
["Workstation"]=>
string(0) ""
["Timeout"]=>
int(300)
["SMTPDebug"]=>
int(2)
["Debugoutput"]=>
string(4) "echo"
["SMTPKeepAlive"]=>
bool(false)
["SingleTo"]=>
bool(false)
["SingleToArray"]=>
array(0) {
}
["do_verp"]=>
bool(false)
["AllowEmpty"]=>
bool(false)
["LE"]=>
string(1) "
"
["DKIM_selector"]=>
string(0) ""
["DKIM_identity"]=>
string(0) ""
["DKIM_passphrase"]=>
string(0) ""
["DKIM_domain"]=>
string(0) ""
["DKIM_private"]=>
string(0) ""
["action_function"]=>
string(0) ""
["XMailer"]=>
string(0) ""
["smtp":protected]=>
object(SMTP)#14245 (13) {
["Version"]=>
string(6) "5.2.14"
["SMTP_PORT"]=>
int(25)
["CRLF"]=>
string(2) "
"
["do_debug"]=>
int(2)
["Debugoutput"]=>
string(4) "echo"
["do_verp"]=>
bool(false)
["Timeout"]=>
int(300)
["Timelimit"]=>
int(300)
["smtp_conn":protected]=>
bool(false)
["error":protected]=>
array(4) {
["error"]=>
string(0) ""
["detail"]=>
string(0) ""
["smtp_code"]=>
string(0) ""
["smtp_code_ex"]=>
string(0) ""
}
["helo_rply":protected]=>
NULL
["server_caps":protected]=>
NULL
["last_reply":protected]=>
string(0) ""
}
["to":protected]=>
array(1) {
[0]=>
array(2) {
[0]=>
string(23) "rukyrukeado@hotmail.com"
[1]=>
string(0) ""
}
}
["cc":protected]=>
array(0) {
}
["bcc":protected]=>
array(0) {
}
["ReplyTo":protected]=>
array(0) {
}
["all_recipients":protected]=>
array(1) {
["rukyrukeado@hotmail.com"]=>
bool(true)
}
["RecipientsQueue":protected]=>
array(0) {
}
["ReplyToQueue":protected]=>
array(0) {
}
["attachment":protected]=>
array(0) {
}
["CustomHeader":protected]=>
array(1) {
[0]=>
array(2) {
[0]=>
string(8) "Reply-To"
[1]=>
string(24) " rukyrukeado@hotmail.com"
}
}
["lastMessageID":protected]=>
string(56) ""
["message_type":protected]=>
string(5) "plain"
["boundary":protected]=>
array(3) {
[1]=>
string(35) "b1_f13a1603f0cf14ce6348ee36f322b479"
[2]=>
string(35) "b2_f13a1603f0cf14ce6348ee36f322b479"
[3]=>
string(35) "b3_f13a1603f0cf14ce6348ee36f322b479"
}
["language":protected]=>
array(19) {
["authenticate"]=>
string(35) "SMTP Error: Could not authenticate."
["connect_host"]=>
string(43) "SMTP Error: Could not connect to SMTP host."
["data_not_accepted"]=>
string(30) "SMTP Error: data not accepted."
["empty_message"]=>
string(18) "Message body empty"
["encoding"]=>
string(18) "Unknown encoding: "
["execute"]=>
string(19) "Could not execute: "
["file_access"]=>
string(23) "Could not access file: "
["file_open"]=>
string(33) "File Error: Could not open file: "
["from_failed"]=>
string(35) "The following From address failed: "
["instantiate"]=>
string(36) "Could not instantiate mail function."
["invalid_address"]=>
string(17) "Invalid address: "
["mailer_not_supported"]=>
string(25) " mailer is not supported."
["provide_address"]=>
string(54) "You must provide at least one recipient email address."
["recipients_failed"]=>
string(45) "SMTP Error: The following recipients failed: "
["signing"]=>
string(15) "Signing Error: "
["smtp_connect_failed"]=>
string(22) "SMTP connect() failed."
["smtp_error"]=>
string(19) "SMTP server error: "
["variable_set"]=>
string(30) "Cannot set or reset variable: "
["extension_missing"]=>
string(19) "Extension missing: "
}
["error_count":protected]=>
int(1)
["sign_cert_file":protected]=>
string(0) ""
["sign_key_file":protected]=>
string(0) ""
["sign_extracerts_file":protected]=>
string(0) ""
["sign_key_pass":protected]=>
string(0) ""
["exceptions":protected]=>
bool(false)
["uniqueid":protected]=>
string(32) "f13a1603f0cf14ce6348ee36f322b479"
}
A continuación se muestra la salida de la depuración de Correo Electrónico:
Ver FAQ
2016-02-26 17:39:16 SMTP ERROR: Failed to connect to server: php_network_getaddresses: getaddrinfo failed: Name or service not known (0)
2016-02-26 17:39:16 SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

ResponderCitar
Respondido : 26/02/2016 6:39 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Por lo que muestras anteriormente hay un error en la conexión al servidor SMTP

Tienes algún plugin para envio de correos por SMTP configurado?

En todo el log no veo nada referente a tu dominio fabioshoes.com.ar , veo que tienes configurado trabajar con google Apps
Contenido solo visible a usuarios registrados

Entiendo que desde google no tienes problemas para enviar y recibir correos.
Desde el Cpanel de tu cuenta de hosting en Entradas MX, luego de seleccionar tu dominio, asegurate de que la gestión de correos sea Remota.

ResponderCitar
Respondido : 26/02/2016 8:42 pm
Ruben
 Ruben
Usuario eminente

El problema lo tengo en dos sitios web: www.fabioshoes.com.ar y www.ruta25nono.com.ar
El Log es de Ruta 25 Nono donde estuve probando distintos plugins de contacto sin éxito.
No estoy seguro del tema de SMTP. Te pego una lista de los plugins activos que tengo:

Akismet
Chats
Contact Form DB
Fast Secure Contact Form
Gantry 4 Framework
Jetpack por WordPress.com
MercadoPago para WooCommerce
Regenerate Thumbnails
Responsive WordPress Slider - Soliloquy Lite
RokCommon Library
RokSprocket
Widget de Mapas de Google
WooCommerce
WooCommerce ARS Currency
WooCommerce Catalog Visibility Options
WooThemes Helper
WP Super Cache
Yoast SEO

ResponderCitar
Respondido : 26/02/2016 9:06 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Estos dos sitios se encuentran en cuentas diferentes? o comparten la misma cuenta?

Enfocate sólo en uno de ellos, ya que de otra manera sería dificil seguir lo que haces, por ejemplo trabaja primero con : www.fabioshoes.com.ar

Lo primero que deberías descartar es problemas con tu cuenta, podrías probar instalando un nuevo sitio web desde cero en una carpeta de este dominio , instalar contact forms, con un formulario básico y probar si te funciona.

Luego si funciona correctamente, quiere decir que tu cuenta esta funcionando correctamente, luego tendrías que localizar el problema en tu sitio, usualmente por conflicto de plugins, tendrías que ir desactivando plugins, especialmente :

Akismet
Chats
Contact Form DB
Jetpack por WordPress.com
MercadoPago para WooCommerce
Regenerate Thumbnails
Widget de Mapas de Google
WP Super Cache
Yoast SEO

Saludos.

ResponderCitar
Respondido : 26/02/2016 9:51 pm
Ruben
 Ruben
Usuario eminente

Justo te estaba escribiendo. Estaba haciendo algo parecido a lo que me decías y dio con la solución a la web de www.ruta25nono.com.ar

El problema era el plugin Chat
http://www.wp-chat.com/

Al desactivarlo empezó a funcionar el formulario.

Voy a seguir con el de www.fabioshoes.com.ar ahora aunque puede ser la nueva validación del contact form 7. En este sitio no tengo instalado el Chat, en ese sitio uso smartsupp.

Muchas gracias. Si resuelvo el de Fabio Shoes escribo la respuesta aquí. Muchas gracias.

ResponderCitar
Respondido : 26/02/2016 9:56 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Ok, ya nos comentas.

Saludos.

ResponderCitar
Respondido : 26/02/2016 10:08 pm
Ruben
 Ruben
Usuario eminente

En la página de Fabio Shoes lo pude solucionar haciendo esto. Muchas gracias!

ResponderCitar
Respondido : 27/02/2016 1:10 am

Cursos Gratuitos WordPress