Avisos
Vaciar todo

Hosting WordPress 70% dto Dominios promo

[Resuelto] Problemas con el cambio de idioma en la web  

 
Ana
 Ana
Reputable Member

Hola,

Tengo un problema raro...

Al escribir en navegadores de ordenador la url de la web: delprosl.com (versión en castellano),  se redirige automáticamente o carga,  delprosl.com/home/  (la versión en ingles)  y una vez en la versión en ingles si con el menu de idioma deseo cambiar a la versión en español no lo hace, sigue en: delprosl.com/home/

He hecho pruebas, y si escribo en el navegador la url de alguna de las otras página de la web, como por ejemplo:  delprosl.com/nuestraesencia/  si la carga bien, y se queda en la versión en español, y parece que estando ahí, si te mueves por las otras paginas e español también funciona bien, pero si de nuevo vas a la página de inicio en español te  vuelve a ir a la versión en ingles.

(el plugin de idioma instalado es Polylang)

image

Lo curioso es que solo pasa en navegadores de ordenador, por que si se abre la web con un móvil, carga bien la url   delprosl.com  en castellano y se mantiene ahí y no redirige ni hace nada raro, todo funciona bien tanto en español como en ingles, este problema parece que solo pasa en navegadores de ordenador.

 

Seríais tán amables de ayudarme por favor?

Quedo pendiente de la respuesta, muchas gracias por vuestra ayuda y amabilidad por anticipado!.

Saludos!

Ana  🙂

 

Contenido solo visible a usuarios registrados

Respondido : 02/09/2022 1:21 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Ana, 

En este caso revisa lo siguiente, veo que actualmente no estás añadiendo el selector de idiomas en el menú que permita cambiar al usuario y seleccionar el idioma donde quiere navegar para añadirlo ve al apartado de Apariencia -> Menú y activa en la parte superior para que se duplique la opción del selector 

image

Luego de añadir la opción del selector debes añadir los idiomas en cada menú que tienes en tu sitio web, ya sea inglés y español

image

Luego de tener el selector de idioma en ambos menús revisa que estés asignado la página principal según cada idioma, para ello accede a Ajustes -> lectura y sobre la opción del idioma español seleccionar su página principal, lo mismo debes hacer para el idioma inglés

Untitled
image

Finalmente, revisa que idioma tienes asignado como principal en tu sitio web, ten en cuenta que de acuerdo a este cuando se ingrese al dominio se mostrara primero este idioma, para comprobarlo puedes ir al apartado de Idiomas -> Idiomas y asegurarte de tener marcado como prioritario el idioma principal

image

Revisa estas opciones y nos comentas como ha ido todo

Un Saludo 

Respondido : 02/09/2022 1:44 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Ana
 Ana
Reputable Member

Hola Karen,

Gracias por tu respuesta.

Pues... he revisado y hecho todo lo que me has dicho, pero el problema sigue. Te pongo capturas de pantalla para que veas configuraciones.

El menú de idioma está en el "top menú" (microwidget parece que le llama en theme)

Top menú con el desplegable de idiomas:  

image

Configuración del top menu:

image

Configuración de ajustes de lectura:

image

Configuración de idioma por defecto:

image

 

Parece que todo está bien, pero sigue igual, es un poco desesperante, la verdad.

Y encima en la versión móvil todo va bien. 

Que podemos probar de hacer ahora?

Quedo a la espera. Gracias por tu ayuda Karen!  🙂

 

Ana

 

 

Respondido : 02/09/2022 3:13 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Ana,

Vamos a verificar el actualizar los enlaces permanentes, primero ingresa en tu carpeta de panel:

Cpanel > administrador de archivos > Public_html > Dominio > archivo .htaccess

Modifica el nombre de este archivo a .htaccess_old, luego ingresas en tu wordpress, ajuste > enlaces permanentes.

Actualiza los enlaces, solo guarda aunque no cambies nada, para que se regenere el archivo .hataccess y verificar si es un problema de enlaces, como comentas funciona en versión móvil, verífica también adicional a esto vaciar la cache, veo que tienes autoptimize, para vaciar esta cache en la parte superior haz clic aquí:

image

También verífica el vaciar la cache de magic cache, si es posible desactiva momentáneamente el complemento mientras trabajas con cambios fundamentales.

Verifica y nos comentas.

Un saludo 🖐️ 

Respondido : 02/09/2022 4:26 pm

Ana
 Ana
Reputable Member

Hola Argenis,

Gracias por tu respuesta. 😊 

Al leer todos tus consejos, antes de ponerme con los archivos y renombrar el .htacces, que es algo delicadillo... me he dicho de hacer lo otro que dices, lo de vaciar las caches.

Yo ya vaciaba la caché de autoptimize cada vez que hacia algo, por si acaso, y nada, no resultaba.

Pero al decirme de vaciar la cache de "magic cache"... no me di cuenta si habia otro plugin de cache, y si lo hay, bueno, concretamente el que hay es vuestro y se llama "Varnish cache" así que por si hay había suerte, he vaciado su caché manualmente, tal como me indicaste y al recargar la página, parece que por fin funciona bien. 😊   Menos mal.... 😥 

Te digo como está configurado ese plugin:

image
image

Es correcto?

La duda es si volverá a pasar esto. 🙄 

¿Que puedo hacer para que se vacíe la cache automáticamente y no tener que estar entrando a limpiar la cache?

 

Gracias por tu gran ayuda Argenis!!

 

Ana  😊 

 

 

 

Respondido : 02/09/2022 4:52 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Ana,

Está todo perfecto, el problema es que no modificaste contenido, por esto no se actualizó automáticamente, cuando son cambios tan grandes siempre es mejor vaciar las caches de forma manual, sobre todo porque algunas veces los plugins tienen rutinas, es decir, vacían cache cada cierto tiempo.

Entonces nos confirmas que está resuelto el tema? para poder cerrarlo? 😀 

Un saludo 🖐️ 

Respondido : 02/09/2022 4:58 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ana
 Ana
Reputable Member

Hola Argenis,

Si, creo que lo podemos dar por resuelto. 😊 

Argenis, te doy las gracias por tu ayuda y a Karen también.

Os deseo que tengáis un gran fin de semana!!!

Un abrazo!

Ana 😊 🤗 

Respondido : 02/09/2022 5:03 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Ana,

Encantados siempre 🤗, si tienes alguna otra duda recuerda que puedes crear un nuevo tema y con todo gusto lo vemos.

Un saludo 🖐️ 🤓 

Respondido : 02/09/2022 5:08 pm

wpdoctor-revisa-la-salud-de-tu-wordpress