Problemas con Elementor  

 
Gonzalo
 Gonzalo
Usuario activo

Tengo un problema en una web que tengo en la cual es un sitio de membresia. Actualmente tengo alumnos dentro y la verdad que no he querido tocar hasta estar seguro.

Dentro de la web hay dos páginas diseñadas con ELEMENTOR y acutalmente al cargarlas me sale que no se encuentran. He ido al dashboard, páginas y si que están ahí. El problema pasa cuando quiero editarlas, no me deja y si sale un cartel aprender más. (adjunto captura de pantalla)

¿Cómo puedo solucionarlo?

Dato importante: hace dos dias actualice el PHP porque el learndash lo necesitaba, pero no puedo volver atrás porque hay alumnos que ya han avanzado

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 02/07/2019 5:44 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Gonzalo.

hace dos dias actualice el PHP porque el learndash lo necesitaba
Revisando tu cuenta veo que estas utilizando la versión 5.6 de PHP, prueba a modificar la versión de PHP de ese subdominio e instala una versión de la rama 7x por ejemplo 7.2

-> https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

El cambio de versión de PHP es a nivel servidor y no afecta a los archivos de tu web, es decir, una vez modificada la versión de PHP revisa que todo cargue bien, si ves que hay algún problema con en algún apartado de la web, siempre puedes volver a una versión anterior.

En la captura que mandas verás que tienes una opción " Preview Debug ", si seleccionas ese link mostrará un informe con los errores que están provocando este fallo.

El único error que veo es del dia 1 de Julio.

[01-Jul-2019 15:44:01 Europe/Madrid] PHP Fatal error: Call to undefined function get_header() in /home2/heroesdi/public_html/wp-content/themes/Newspaper/index.php on line 6

Y no veo que se haya vuelto a reproducir a si que supongo que a dia de hoy esta solucionado.

Revisa lo que te indico y vemos si mejora.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 02/07/2019 6:02 pm

Cursos Gratuitos WordPress

Gonzalo
 Gonzalo
Usuario activo

Hice todo lo que dijiste pero da error.

No me deja usar el contructor visual, aparece el mismo error, y si pongo Preview debug me sale que no encuentra la pagina.

Adjunto captura

ResponderCitar
Respondido : 02/07/2019 7:46 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Entiendo que no puedes hacer muchas pruebas en tu sitio actual, te recomendaría ir desactivando plugins hasta ver si alguno te causa el problema , pero mejor realiza esto en un clon de tu sitio web para no dejar inoperativo el sitio. Revisa: https://guias.webempresa.com/preguntas-frecuentes/clonar-mi-web/

Entiendo que estas usando Elementor Pro, una opción sería consultar directamente con los desarrolladores para ver si pueden detectar algo.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/07/2019 8:45 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Gonzalo
 Gonzalo
Usuario activo

No tengo la versión pro, es la free por lo que no tengo soporte.

Puede ser algún plugin? lo digo porque sino se ha instalado nada nuevo, no debería pasar, no?

ResponderCitar
Respondido : 03/07/2019 12:49 am
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Saludos Gonzalo,

He estado analizando tu caso y veo que migraste tu CPanel recientemente.

La web con la que estás teniendo problemas se encuentra fuera de la carpeta public_html/; la web que hemos estado revisando es la que indicaste originalmente en el ticket, heroesdigitales.net, y hemos visto (como lo indicaste aquí en foro) que el problema lo estás teniendo con app.heroesdigitales.net . Te pedimos disculpas por la demora en la resolución, debido a este motivo.

Si estos problemas que estás experimentando con Elementor solo se han dado desde que cambiaste la versión de php, te recomendaría que respondieses de nuevo al ticket existente, indicando que el problema es con la web app.heroesdigitales.net , para que comprueben que a nivel de extensiones de php, y otros elementos del alojamiento, está todo bien, ya que las comprobaciones se hicieron sobre heroesdigitales.net.

En tu respuesta, para agilizar la revisión, sería también recomendable que indicases si además de actualizar learndash, has actualizado o instalado algún otro componente (y en particular si actualizaste también Elementor), o si el problema empezó exactamente con el cambio de versión de php de 5.6 a 7.2.

Puedes revisar la documentación de Elementor aqui -> https://docs.elementor.com/category/412-compatibility y comprobar que lo tengas correctamente configurado y constatar que los plugins que estás usando son compatibles

Saludos.

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

ResponderCitar
Respondido : 03/07/2019 2:54 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Por favor Iniciar Sesión o Registro