Avisos
Vaciar todo

[Resuelto] Productos Woocommerce  

 
Ana
 Ana
Usuario activo

Hola,

En las páginas de cada producto se pierde la personalización que si aparece correctamente en el resto de las páginas. Tanto el menú como los colores con los que he personalizado el tema (DIVI) no aparecen personalizados sino en el color azul que Wordpress dispone por defecto.

He desactivado cada plugin uno por uno para ver si ese era el error pero sigue sin funcionar.

¿Alguna solución? 

Muchas gracias

Contenido solo visible a usuarios registrados

Citar
Respondido : 28/02/2021 10:46 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tienes construída páginas de productos con Divi?, o simplemente estas usando los estilos por defecto del tema o de WooCommerce?

Tendrías que habilitar tu sitio temporalmente para verificar, ya que actualmente esta en mantenimiento.

Saludos.

ResponderCitar
Respondido : 28/02/2021 1:30 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Ana
 Ana
Usuario activo

Gracias por tu respuesta.

He desactivado ya el mantenimiento. La personalización de las páginas del producto están realizadas con el personalizador de DIVI.

Cuando veo las páginas de producto mientras las personalizo se ve correctamente los cambios que he realizado. También cuando habilito el constructor visual. Pero cuando se ven las páginas en directo (front-end), la página no mantiene los cambios personalizados sino que aparecen los colores, tipografía, etc. que dispone Wordpress por defecto.

Envié un ticket a Webempresa y me dicen que han visto este error: [28-Feb-2021 11:47:00 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/paginaw4/public_html/hiperasia.store/wp-content/themes/Divi/core/components/Portability.php on line 1400

Tal vez está relacionado con ese error porque creo que comenzó en ese momento. Antes se veía bien.

He desactivado todos los plugins (excepto WooCommerce, claro) y el problema persiste.

¿Alguna idea?

Saludos

 

ResponderCitar
Respondido : 28/02/2021 6:05 pm
Ana
 Ana
Usuario activo

El error se ha solucionado eliminando este CSS que tenía para personalizar la cabecera.

/*Estado original*/
#main-header {background-color: rgba(255,226,226,0.67);}

/*Estado de Scrolling*/
#main-header.et-fixed-header {background-color: rgba(255,255,255);}

¿Cómo podría realizar este cambio sin tener problemas?

Muchas gracias

ResponderCitar
Respondido : 28/02/2021 6:22 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Ana
 Ana
Usuario activo

Vale. He realizado el cambio con el personalizador y ya está solucionado.

Muchas gracias

ResponderCitar
Respondido : 28/02/2021 6:45 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Ok, que bueno que encontraste la solución.

Saludos.

ResponderCitar
Respondido : 28/02/2021 8:04 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress