Avisos
Vaciar todo

slider  

 
diego
 diego
Estimable Member

Tengo un tema instalado que tiene la opcion de colocar slider en la cabecera. Tengo este problema 

He revisado la web proasalud.com y veo que en los tres navegadores (Firefox, Chrome y Safari), solo carga la primera vez, al actualizar la imagen del slider desaparece, revisando a detalle veo errores con dos scripts (adjunto captura), en este caso primero te recomiendo actualizar todos los plugins y el tema a la última versión, en caso de que si al realizar esto el problema continúa, tendrás que solicitar soporte con tu proveedor de tema.

Los scripts que te están afectando son:

https://proasalud.com/wp-content/themes/giga-store-pro/js/bootstrap.min.js?ver=3.3.6
https://proasalud.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0

Ya tengo todo actualizado pero no resuelvo el problema

Contenido solo visible a usuarios registrados

Citar
Respondido : 24/07/2021 6:05 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

He probado tu sitio y veo que carga correctamente el slider, lo he probado con firefox

Sin embargo si que veo que se generan errores javascript, pero también el mensaje te sugiere la solución:

 Bootstrap's JavaScript requires jQuery version 1.9.1 or higher, but lower than version 3

Es una dependencia de tu theme, por lo que verifica si tienes la versión más reciente de tu theme o consulta directamente con los desarrolladores, ya que al parecer necesitan una versión de Jquery más actual.

Por otro lado, a veces ocurren problemas javascript debido a plugins de optimización, podrías probar desactivando el pugin de autoptimize, que es justamente el que genera al parecer el otro error javascript.

Saludos.

ResponderCitar
Respondido : 24/07/2021 6:25 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

diego
 diego
Estimable Member

el autoptimize no es por lo que tiene que ser la otra opcion

Es una dependencia de tu theme, por lo que verifica si tienes la versión más reciente de tu theme o consulta directamente con los desarrolladores, ya que al parecer necesitan una versión de Jquery más actual.

El desarrolador del tema es imposible contactar. Me podrias ayudar a actualizar la version Jquery del archivo js que da problemas?

ResponderCitar
Respondido : 24/07/2021 8:45 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

En realidad revisando, necesitas una vesión anterior de Jquery, Wordpress actualmente en tu sitio te carga la versión 3.6

En el mensaje de tu theme se indica:

"Bootstrap's JavaScript requires jQuery version 1.9.1 or higher, but lower than version 3"

Es decir o bien tendrías que bajar la versión de Jquery (cosa que no te recomiendo) o bien actualizar tu theme, más específicamente Bootstrap que es una dependencia de tu theme.

El archio de bootstrap lo tienes en esta ruta:

wp-content/themes/giga-store-pro/js/bootstrap.min.js

Tendrías que posiblemente generar un bootstrap.min.js más actual, sin embargo ten en cuenta que si tu theme tiene otras dependencias del bootstrap anterior posiblemente no termine de funcionar bien, es por eso que mejor tendrías que consultar con el desarrollador.

Saludos.

ResponderCitar
Respondido : 24/07/2021 9:52 pm

Cursos Gratuitos WordPress