Avisos
Vaciar todo

Smush Pro  

Página 1 / 2
 
Carmen
 Carmen
Usuario activo

Hemos adquirido este plugin para convertir y servir imágenes en Webp, pero aunque hemos hecho las modificaciones en el archivo .htaccess lanza un error: 

The server rules have been applied but the server doesn't seem to be serving your images as WebP. We recommend contacting your hosting provider to learn more about the cause of this issue.

He puesto un tickect a soporte pero me dicen que estas preguntas aquí en el foro.
Gracias por la ayuda.
Carmen

Contenido solo visible a usuarios registrados

Citar
Respondido : 21/06/2021 9:37 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Carmen.

Es un plugin de pago y no podemos probarlo, tienes que consultarlo con el soporte del desarrollador.

En este enlace tratan el tema:

-> https://wpmudev.com/forums/topic/smush-pro-smush-pro-says-not-serving-in-webp-to-contact-host-support/

 

Un saludo

ResponderCitar
Respondido : 21/06/2021 10:29 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Carmen
 Carmen
Usuario activo

@pepesoler gracias, pero ya he consultado con ellos y la respuesta es la que he puesto más arriba:

 

The server rules have been applied but the server doesn't seem to be serving your images as WebP. We recommend contacting your hosting provider to learn more about the cause of this issue.

 

Es por eso que estoy contactando con nuestro hosting 🙁

ResponderCitar
Respondido : 21/06/2021 10:33 am
Carmen
 Carmen
Usuario activo

Por otra parte me dan en modo manual lo siguiente:

 

If you are unable to get the automated method working, follow these steps:

  1. Copy the generated code below and paste it at the top of your .htaccess file (before any existing code) in the root directory.
  2. Next, re-check WebP conversion status to see if it worked.
# BEGIN SMUSH-WEBP
<IfModule mod_rewrite.c>
 RewriteEngine On
 RewriteCond %{DOCUMENT_ROOT}/wp-content/smush-webp/disable_smush_webp !-f
 RewriteCond %{HTTP_ACCEPT} image/webp
 RewriteCond %{DOCUMENT_ROOT}/wp-content/smush-webp/$1.webp -f
 RewriteRule wp-content/uploads/(.*.(?:png|jpe?g))$ wp-content/smush-webp/$1.webp [NC,T=image/webp]
</IfModule>

<IfModule mod_headers.c>
 Header append Vary Accept env=WEBP_image
</IfModule>

<IfModule mod_mime.c>
 AddType image/webp .webp
</IfModule>
# END SMUSH-WEBP

Troubleshooting

If .htaccess does not work, and you have access to vhosts.conf or httpd.conf, try this:

  1. Look for your site in the file and find the line that starts with <Directory> - add the code above that line and into that section and save the file.
  2. Reload Apache.
  3. If you don't know where those files are, or you aren't able to reload Apache, you would need to consult with your hosting provider or a system administrator who has access to change the configuration of your server.

 

He realizado la primera parte y nada, pero la segunda parte, ni idea de como hacerlo.

ResponderCitar
Respondido : 21/06/2021 10:35 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Carmen.

Lo que te indican es que copies el código al principio del archivo .htaccess que encontrara en la raiz de la instalación:

# BEGIN SMUSH-WEBP
<IfModule mod_rewrite.c>
 RewriteEngine On
 RewriteCond %{DOCUMENT_ROOT}/wp-content/smush-webp/disable_smush_webp !-f
 RewriteCond %{HTTP_ACCEPT} image/webp
 RewriteCond %{DOCUMENT_ROOT}/wp-content/smush-webp/$1.webp -f
 RewriteRule wp-content/uploads/(.*.(?:png|jpe?g))$ wp-content/smush-webp/$1.webp [NC,T=image/webp]
</IfModule>

<IfModule mod_headers.c>
 Header append Vary Accept env=WEBP_image
</IfModule>

<IfModule mod_mime.c>
 AddType image/webp .webp
</IfModule>
# END SMUSH-WEBP

 

Una vez lo tengas añadido prueba si puedes hacer la conversión.

 

Ten en cuenta que son ellos los que tiene que proporcionarte ese soporte, nosotros solo podemos orientarte segun lo que te digan como por ejemplo ahora con lo de añadir el código.

 

Un saludo

 

ResponderCitar
Respondido : 21/06/2021 11:35 am
Carmen
 Carmen
Usuario activo

@pepesoler gracias Pepe eso es lo primero que hice, pero si te fijas, da unas indicaciones para reiniciar el servidor Apache (que es precisamente lo que no sé hacer), si lo primero falla. O:)

ResponderCitar
Respondido : 21/06/2021 1:02 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Carmen
 Carmen
Usuario activo

Según entiendo, el problema (según ellos me indican) está es nuestro hosting, en mi caso webempresa, que tiene limitado el servir imágenes WebP. No sé si será cuestión de permisos o algo parecido, de ahí que recurriese al soporte vuestro.

ResponderCitar
Respondido : 21/06/2021 1:04 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Carmen, 

De forma predeterminada WordPress no acepta este formato por seguridad es por ello que necesitas añadir reglas adicionales que permitan soporte el formato webp, sobre el reinicio del servidor solo se debe ejecutar si el código falla, has realizado las pruebas añadiendo este código en tu archivo .htaccess?, si no es así añádelo y luego realizas las pruebas verificando si todo funciona de forma correcta. 

Un Saludo 

ResponderCitar
Respondido : 21/06/2021 1:16 pm

Cursos Gratuitos WordPress

Carmen
 Carmen
Usuario activo

@karen hola.

Si es lo primero que hicimos, añadir el codigo correspondiente, pero nada.

Llevamos ya dos días haciendo pruebas y... "The server rules have been applied but the server doesn't seem to be serving your images as WebP. We recommend contacting your hosting provider to learn more about the cause of this issue."

Lo cual indica que está recogiendo los cambios con el codigo agregado, pero nos vuelven a remitir al hosting.

Gracias por responder

 
ResponderCitar
Respondido : 21/06/2021 1:48 pm
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Carmen.

, que tiene limitado el servir imágenes WebP. 

No hay ninguna limitación en los archivos WebP e una extension mas de imagenes y los soporta sin problemas.

 

En el foro no damos soporte a versiones de pago de plugin ya que no podemos probarlos y tienes que consultar con el soporte del plugin son ellos los que tiene que ofrecerte ese soporte.

 

Puedes probar con una alternativa al plugin:

-> https://es.wordpress.org/plugins/webp-express/

En esta entrada del blog tienes información:

-> https://www.webempresa.com/blog/usar-imagenes-webp-wordpress.html

 

Un saludo

ResponderCitar
Respondido : 21/06/2021 2:29 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Carmen
 Carmen
Usuario activo

@pepesoler gracias de nuevo Pepe,

Si fue el primero que probamos por ser de pago, pero nos pasaba igual que a otro usuario que leimos en este foro. Daba errores por doquier, Forbiden, luego nos bloqueaba la IP, totalmente descartado 🙁

 

En fn, seguiré intentando con el soporte del plugin y si no, pues lo devolveremos.

Que tengáis un buen día

Carmen

ResponderCitar
Respondido : 22/06/2021 7:55 am
Carmen
 Carmen
Usuario activo

Por si a alguien posteriormente sirve de ayuda, me acaban de responder de soporte lo siguiente: 

 

Hi Carmen Manzano

I hope you’re well today and thank you for contacting us!

The webserver that responds to requests from outside is nginx, not Apache. Since there’s no CloudFlare it means that this is most likely a “hybrid” setup where the site itself is handled by Apache webserver but there’s nginx acting as a proxy/caching-proxy.

Can you consult your host about that?

If I’m right about it then there are two ways to solve this:

1. Your host would have to adjust NGINX configuration in a way that all the requests for images would be directly passed to Apache – not cached/modified in any way but just directly “passed through” to Apache;

Once that’s done, rules that are already added to Apache should start working and after you run bulk-smushing (if you didn’t do it already after adding rules to .htaccess) images would be converted to webp and served as webp.

2. Alternatively, rules should be added – and that’s again something your host should be able to help with to NGINX config instead of Apache.

– remove Smush Local WebP rules from .htaccess
– go to “Smush Pro -> Local WebP” page
– you’ll see “Server Type” option there – select “Nginx”
– below you’ll then see rules that should be added to nginx conf so please pass them over to your host to be added

– your host should also restart nginx after rules are added there
– and you’d need to run bulk-smushing to get images actually converted.

Note please: these two methods above are alternatives – please try one and only try the other one if the first one doesn’t work.

Alternatively, you can also just used Smush CDN instead as it has WebP conversion option built-in. It’s a separate option and for CDN to serve images as WebP, the “Local WebP” option does not have to be enabled.

Best regards,
Adam

 

Al parecer no es Apache como detectaba automaticamente O:)

ResponderCitar
Respondido : 22/06/2021 7:58 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Carmen, Buenos días.

Si, nuestros servidores trabajan con NGINX

Lograste solucionarlo con lo que te indicaron ?

 

Un saludo

ResponderCitar
Respondido : 22/06/2021 9:33 am
Carmen
 Carmen
Usuario activo

@pepesoler no Pepe,

Tengo a nuestro informático (el que sabe ;)) de vacaciones y no sé modificar lo de Nginx. Mis conocimientos son limitados, ficheros de wordpresss, pero a nivel de servidor, poquito.
No sé en soporte me podríais ayudar o en algún departamento.

Si no, a esperar.

Gracias

ResponderCitar
Respondido : 22/06/2021 10:12 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Carmen
 Carmen
Usuario activo

Por cierto @pepesoler Has leido esta parte?

 

1. Your host would have to adjust NGINX configuration in a way that all the requests for images would be directly passed to Apache – not cached/modified in any way but just directly “passed through” to Apache;

(1. Su host tendría que ajustar la configuración de NGINX de manera que todas las solicitudes de imágenes se pasen directamente a Apache, no se almacenen en caché / se modifiquen de ninguna manera, sino que simplemente se "pasen" directamente a Apache; Una vez hecho esto, las reglas que ya están agregadas a Apache deberían comenzar a funcionar y, después de ejecutar el smushing masivo (si no lo hizo ya después de agregar reglas a .htaccess), las imágenes se convertirían a webp y se servirían como webp.)

¿Esto lo podéis hacer vosotros?

Los cambios en .htaccess ya los hice yo y están aplicandose.

Si esto no funciona, habrá que pasar a la opción 2)

 

ResponderCitar
Respondido : 22/06/2021 10:15 am
Página 1 / 2