Validación SMTP con plugin WP-Mail-SMTP  

 
Carlos
 Carlos
Usuario activo

Hola a todos, espero puedan indicarme cómo solucionar esta incidencia.

Escenario:
He trasladado una web de e-commerce a WebEmpresa, usa el plugin de reserva AweBooking y como auxiliar WP-Mail-SMTP.

Tras haber habilitado en el soporte técnico la validación SMTP, funciona casi correctamente, sólo que tras hacer el test de envío el código que encabeza el registro es

The result was:
bool(false)
... además del largo código que explica la verificación..

en vez de:

The result was:
bool(true)
... además del largo código que explica la verificación..

Con esto no funciona el envío de correo a clientes.

He leído algunos comentarios en el foro, aunque sigo sin poder solucionarlo.
Alguien ha usado estos plugins? Sabrían alguna solución?

Mil gracias! 🙂

URL del sitio: Contenido solo visible a usuarios registrados

Amo parir ideas y verlas crecer.

Citar
Respondido : 18/06/2016 3:50 pm
Rafael
 Rafael
Miembro Moderator

Buenas tardes Carlos

¿Nos facilitas capturas de pantalla de la configuración que tienes aplicada en el plugin WP Mail SMTP?

Te será útil -> http://wiki.webempresa.com/Captura_de_Pantalla

No obstante, revisando el plugin que nos indicas, me he encontrado con esto que quizás te sea de utilidad:

-> http://awethemes.com/comment/5609#comment-5609

Saludos
.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/06/2016 3:59 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Carlos
 Carlos
Usuario activo

Gracias Rafael 🙂

Sí de hecho, llevo un mes con este tema, los chicos de Awe me han dicho que cambie de alojamiento, por ejemplo en Hostgator funciona el plugin, lo que sucede es que su servicio es terrible y me estoy quitando de ese proveedor.

El password de la app también funciona bien, hice un test en Hostgator. 🙂

Adjunto la config y este es el resultado del test (perdón por lo largo):

Test Message Sent
The result was:
bool(false)
The full debugging output is shown below:
object(PHPMailer)#11836 (75) {
["Version"]=>
string(6) "5.2.14"
["Priority"]=>
NULL
["CharSet"]=>
string(5) "UTF-8"
["ContentType"]=>
string(10) "text/plain"
["Encoding"]=>
string(4) "8bit"
["ErrorInfo"]=>
string(82) "SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshootin g"
["From"]=>
string(31) "reservas@casablancatenerife.com"
["FromName"]=>
string(25) "Casablanca Bed & Brekfast"
["Sender"]=>
string(0) ""
["ReturnPath"]=>
string(0) ""
["Subject"]=>
string(46) "WP Mail SMTP: Test mail to mundocaco@gmail.com"
["Body"]=>
string(68) "This is a test email generated by the WP Mail SMTP WordPress plugin."
["AltBody"]=>
string(0) ""
["Ical"]=>
string(0) ""
["MIMEBody":protected]=>
string(69) "This is a test email generated by the WP Mail SMTP WordPress plugin.
"
["MIMEHeader":protected]=>
string(413) "Date: Sat, 18 Jun 2016 13:04:38 +0000
To: mundocaco@gmail.com
From: Casablanca Bed & Brekfast
Subject: WP Mail SMTP: Test mail to mundocaco@gmail.com
Message-ID:
X-Mailer: PHPMailer 5.2.14 ( https://github.com/PHPMailer/PHPMailer)
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

"
["mailHeader":protected]=>
string(0) ""
["WordWrap"]=>
int(0)
["Mailer"]=>
string(4) "smtp"
["Sendmail"]=>
string(18) "/usr/sbin/sendmail"
["UseSendmailOptions"]=>
bool(true)
["PluginDir"]=>
string(0) ""
["ConfirmReadingTo"]=>
string(0) ""
["Hostname"]=>
string(0) ""
["MessageID"]=>
string(0) ""
["MessageDate"]=>
string(31) "Sat, 18 Jun 2016 13:04:38 +0000"
["Host"]=>
string(14) "smtp.gmail.com"
["Port"]=>
string(3) "465"
["Helo"]=>
string(0) ""
["SMTPSecure"]=>
string(3) "ssl"
["SMTPAutoTLS"]=>
bool(true)
["SMTPAuth"]=>
bool(true)
["SMTPOptions"]=>
array(0) {
}
["Username"]=>
string(30) "casablancabbtenerife@gmail.com"
["Password"]=>
string(16) "bcubzjifzpslwjdz"
["AuthType"]=>
string(0) ""
["Realm"]=>
string(0) ""
["Workstation"]=>
string(0) ""
["Timeout"]=>
int(300)
["SMTPDebug"]=>
bool(true)
["Debugoutput"]=>
string(4) "echo"
["SMTPKeepAlive"]=>
bool(false)
["SingleTo"]=>
bool(false)
["SingleToArray"]=>
array(0) {
}
["do_verp"]=>
bool(false)
["AllowEmpty"]=>
bool(false)
["LE"]=>
string(1) "
"
["DKIM_selector"]=>
string(0) ""
["DKIM_identity"]=>
string(0) ""
["DKIM_passphrase"]=>
string(0) ""
["DKIM_domain"]=>
string(0) ""
["DKIM_private"]=>
string(0) ""
["action_function"]=>
string(0) ""
["XMailer"]=>
string(0) ""
["smtp":protected]=>
object(SMTP)#11837 (13) {
["Version"]=>
string(6) "5.2.14"
["SMTP_PORT"]=>
int(25)
["CRLF"]=>
string(2) "
"
["do_debug"]=>
bool(true)
["Debugoutput"]=>
string(4) "echo"
["do_verp"]=>
bool(false)
["Timeout"]=>
int(300)
["Timelimit"]=>
int(300)
["smtp_conn":protected]=>
bool(false)
["error":protected]=>
array(4) {
["error"]=>
string(0) ""
["detail"]=>
string(0) ""
["smtp_code"]=>
string(0) ""
["smtp_code_ex"]=>
string(0) ""
}
["helo_rply":protected]=>
NULL
["server_caps":protected]=>
NULL
["last_reply":protected]=>
string(0) ""
}
["to":protected]=>
array(1) {
[0]=>
array(2) {
[0]=>
string(19) "mundocaco@gmail.com"
[1]=>
string(0) ""
}
}
["cc":protected]=>
array(0) {
}
["bcc":protected]=>
array(0) {
}
["ReplyTo":protected]=>
array(0) {
}
["all_recipients":protected]=>
array(1) {
["mundocaco@gmail.com"]=>
bool(true)
}
["RecipientsQueue":protected]=>
array(0) {
}
["ReplyToQueue":protected]=>
array(0) {
}
["attachment":protected]=>
array(0) {
}
["CustomHeader":protected]=>
array(0) {
}
["lastMessageID":protected]=>
string(57) ""
["message_type":protected]=>
string(5) "plain"
["boundary":protected]=>
array(3) {
[1]=>
string(35) "b1_1087e51f13a95d5d75b07f6f7404b51f"
[2]=>
string(35) "b2_1087e51f13a95d5d75b07f6f7404b51f"
[3]=>
string(35) "b3_1087e51f13a95d5d75b07f6f7404b51f"
}
["language":protected]=>
array(19) {
["authenticate"]=>
string(35) "SMTP Error: Could not authenticate."
["connect_host"]=>
string(43) "SMTP Error: Could not connect to SMTP host."
["data_not_accepted"]=>
string(30) "SMTP Error: data not accepted."
["empty_message"]=>
string(18) "Message body empty"
["encoding"]=>
string(18) "Unknown encoding: "
["execute"]=>
string(19) "Could not execute: "
["file_access"]=>
string(23) "Could not access file: "
["file_open"]=>
string(33) "File Error: Could not open file: "
["from_failed"]=>
string(35) "The following From address failed: "
["instantiate"]=>
string(36) "Could not instantiate mail function."
["invalid_address"]=>
string(17) "Invalid address: "
["mailer_not_supported"]=>
string(25) " mailer is not supported."
["provide_address"]=>
string(54) "You must provide at least one recipient email address."
["recipients_failed"]=>
string(45) "SMTP Error: The following recipients failed: "
["signing"]=>
string(15) "Signing Error: "
["smtp_connect_failed"]=>
string(22) "SMTP connect() failed."
["smtp_error"]=>
string(19) "SMTP server error: "
["variable_set"]=>
string(30) "Cannot set or reset variable: "
["extension_missing"]=>
string(19) "Extension missing: "
}
["error_count":protected]=>
int(2)
["sign_cert_file":protected]=>
string(0) ""
["sign_key_file":protected]=>
string(0) ""
["sign_extracerts_file":protected]=>
string(0) ""
["sign_key_pass":protected]=>
string(0) ""
["exceptions":protected]=>
bool(true)
["uniqueid":protected]=>
string(32) "1087e51f13a95d5d75b07f6f7404b51f"
}
The SMTP debugging output is shown below:
2016-06-18 13:04:38 Connection: opening to ssl://smtp.gmail.com:465, timeout=300, options=array (
)
2016-06-18 13:07:47 SMTP ERROR: Failed to connect to server: Connection timed out (110)
2016-06-18 13:07:47 SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

Gracias!

Amo parir ideas y verlas crecer.

ResponderCitar
Respondido : 18/06/2016 4:08 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Si utilizas la opción de PHP mail() te funciona?, caso contrario tienes que enviar un ticket a soporte para que habiliten la opción SMTP remoto.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/06/2016 4:18 pm

Cursos Gratuitos WordPress

Carlos
 Carlos
Usuario activo

He probado y vuelve a aparecer el mismo resultado "bool(false)"
pido a soporte que habiliten SMTP remoto a ver qué me dicen.

🙂

Gracias!

Amo parir ideas y verlas crecer.

ResponderCitar
Respondido : 18/06/2016 7:07 pm

Por favor Iniciar Sesión o Registro