Woocommerce-redsys (Pedido pendiente de pago)  

 
RAUL
 RAUL
Nuevo usuario

Hola,

Tengo un problema que parece común pero he intentado varias cosas y sigue sin funcionar.

Estoy realizando pruebas con redsys (plugin oficial) y woocommerce y después de haber realizado el pago con tarjeta los pedidos se quedan en pendiente de pag en lugar de procesando como debería ser..

 

El archivo htacces está de la siguiene forma:

<FilesMatch ".(php4|php5|php3|php2|php|phtml)$">
SetHandler application/x-lsphp74
</FilesMatch>
RewriteEngine On
RewriteCond %{ENV:HTTPS} !on [NC]
RewriteCond %{HTTP_HOST} ^runrabbit\.es$ [OR]
RewriteCond %{HTTP_HOST} ^www\.runrabbit\.es$
RewriteRule ^(.*)$ https://www.runrabbit.es/$1 [R,L]

## .htaccess generado por la herramienta WPCenter

# BEGIN WordPress
# Las directivas (líneas) entre «BEGIN WordPress» y «END WordPress» son
# generadas dinámicamente y solo deberían ser modificadas mediante filtros de WordPress.
# Cualquier cambio en las directivas que hay entre esos marcadores serán sobrescritas.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

 

Gracias por la ayuda

 

Citar
Respondido : 15/10/2020 10:07 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Raul.

Veo que estás utilizando el plugin " woo-redsys-gateway-light " que no es el oficial de Redsys, porlo que veo este plugin esta teniendo problemas en el cambio de estado:

-> https://wordpress.org/support/topic/error-en-la-notificacion/

-> https://wordpress.org/support/topic/pedido-en-espera-tambien-y-ya-no-se-que-probar/

lo primero prueba con el plugin oficial de Redsys:

-> https://pagosonline.redsys.es/descargas.html

 

Elimina el plugin que tienes ahora y lo sustituyes por el oficial de Redsys

 

Revisa si con eso se soluciona.

 

Un saludo

 

ResponderCitar
Respondido : 15/10/2020 11:04 am

Cursos Gratuitos WordPress

RAUL
 RAUL
Nuevo usuario

Hola Pepe,

Este plugin que comentas lo tenía desactivado. Estaba ya utilizando el oficial. El problema tenía que ver con tema de firewall.

 

Muchas gracias por la pronta respuesta en cualquier caso.

Raúl

 

Saludos

ResponderCitar
Respondido : 15/10/2020 12:01 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Raul.

Ostras, Gracias por confirmar que era problema de firewall

Podrías indicarnos si es por temas de firewall del servidor o es alguna extensión que tenías instalada ?

 

Un saludo y muchas gracias por aportar la solución.

ResponderCitar
Respondido : 15/10/2020 1:58 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación