errores en la pagina principal de mi web  

 
Antonio
 Antonio
Usuario activo

Buenas noches, han aparecido en la pagina web, www.extremaduraprogresista.com unos errores, uno en un modulo a la derecha de la web y y otro abajo del todo de la web,adjunto capturas de la situacion de la web y el error, por favor podeis solucionarlo y a que no sabemos a que es debido ni como intentar subsanarlo.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 06/07/2015 11:40 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Los mensajes reportados son advertencias emitidas por PHP,
Has solicitado recientemente un cambio de PHP por tickets?

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/07/2015 12:13 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Antonio
 Antonio
Usuario activo

Buenas, tenia un problema y le escribí vía ticket y esto me contestaron:
n primer lugar, vemos que en su página web se están repitiendo los mismos errores de forma constante:

[06-Jul-2015 14:27:01 UTC] PHP Warning: ini_set() has been disabled for security reasons in /home2/extprog/public_html/libraries/joomla/session/session.php on line 655
[06-Jul-2015 14:27:02 UTC] PHP Warning: ini_set() has been disabled for security reasons in /home2/extprog/public_html/includes/framework.php on line 55
[06-Jul-2015 14:27:02 UTC] PHP Warning: ini_set() has been disabled for security reasons in /home2/extprog/public_html/libraries/joomla/session/session.php on line 102
[06-Jul-2015 14:27:02 UTC] PHP Warning: ini_set() has been disabled for security reasons in /home2/extprog/public_html/libraries/joomla/session/session.php on line 105
[06-Jul-2015 14:27:02 UTC] PHP Warning: ini_set() has been disabled for security reasons in /home2/extprog/public_html/libraries/joomla/session/session.php on line 655

Por lo que hemos procedido a activar la función ini_set en su Hosting Webempresa para que no vuelva a dar error en su instalación Joomla y por lo tanto, no le genere error_log hasta 2gbs. Se lo mostramos a continuación:

Disable_functions de antes de hacer el cambio:
disable_functions = ini_set,phpinfo,proc_open,show_source,passthru,system,exec,shell,shell_exec,popen,pclose,proc_nice,proc_terminate,proc_get_status,proc_close,pfsockopen,leak,apache_child_terminate,posix_kill,posix_mkfifo,posix_setpgid,posix_setsid,posix_setuid,escapeshellcmd,escapeshellarg

Disable_functions de después de hacer el cambio:
disable_functions=phpinfo,proc_open,show_source,passthru,system,exec,shell,shell_exec,popen,pclose,proc_nice,proc_terminate,proc_get_status,proc_close,pfsockopen,leak,apache_child_terminate,posix_kill,posix_mkfifo,posix_setpgid,posix_setsid,posix_setuid,escapeshellcmd,escapeshellarg

Hemos eliminado el archivo error_log y pasados unos minutos comprobamos que no se vuelve a generar. En el caso de que volviera a generarse, avísenos y no lo borre para que podamos revisarlo.

En cuanto a copias de seguridad, vemos que solo existe la siguiente en su Hosting Webempresa:

92 MB en el fichero /home2/extprog/application_backups/app_extremaduraprogresista-com_Mi-portal_2015-02-21_20-46-55.tar.gz de fecha Feb 21 20:47

Esta copia está colocada en su Hosting desde el traslado de su cuenta cPanel a su Hosting Webempresa.

Puede descargarla y/o eliminarla de su Hosting Webempresa mediante la aplicación de Administrador de Archivos de su cPanel con el fin de liberar espacio en su Hosting Webempresa.

Revise: https://www.webempresa.com/blog/administrador-de-archivos-de-cpanel.html

No obstante, no vemos que se estén generando nuevas copias en el directorio citado. Si utiliza dentro de su instalación Joomla algún tipo de extensión podrá configurarlo desde el mismo.

Adicionalmente a su consulta, vemos los siguientes errores en su instalación Joomla:

El sitio tiene mal configurada la ruta de log_path en su configuration.php, el valor actual es /home/extprog/public_html/logs y el correcto es /home2/extprog/public_html/logs
El sitio tiene mal configurada la ruta de tmp_path en su configuration.php, el valor actual es /home/extprog/public_html/tmp y el correcto es /home2/extprog/public_html/tmp

Lo hemos corregido por usted ya que esto puede ocasionar que no pueda instalar extensiones o tenga problemas en su página web (y contribuya a crecer el archivo error_log).

Cualquier duda, por favor consúltenos.

NO se si es algo de esto, por favor puedes ayudarme??

ResponderCitar
Respondido : 07/07/2015 12:19 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Si que podría tener que ver, es decir siempre tenias errores sin embargo se guardaban en un archivo error_log, ahora tras el cambio se estan mostrando al parecer en tu sitio

La idea sería corregir los errores, para esto veo que se hace referencia a un overrides
/home2/extprog/public_html/templates/ja_purity/html/pagination.php

Posiblemente por un problema de la plantilla, renombra este archivo pagination.php por por ejemplo back_pagination.php y verifica si te reporta errores , la idea es usar el pagination.php q viene con el core y no el del template que al parecer tiene errores o esta desactualizado

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/07/2015 12:33 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Antonio
 Antonio
Usuario activo

Buenas, le he cambiado el nombre al archivo pero no se ha solucionado sigue apareciendo el mismo mensaje en la web principal, que puedo hacer?

ResponderCitar
Respondido : 07/07/2015 12:48 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Refresca tu navegador o limpia cache por que al consultar ya no veo ningún mensaje en la paginación

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/07/2015 1:00 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Antonio
 Antonio
Usuario activo

Buenos, el error del final de la web si se ha solucionado, pero el de la derecha, el que es parecido pero esta vez el directorio es helper.php:
Warning: Creating default object from empty value in /home2/extprog/public_html/modules/mod_latestnews/helper.php on line 109

este aparece varias veces, y si renombro ese archvo, el helper.php no funciona la web, como se puede solucionar?

ResponderCitar
Respondido : 07/07/2015 1:19 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Le he solicitado a un administrador de sistemas que baje tu cuenta a PHP 5.3 ya que este parece ser el error. Prueba a limpiar la cache de tu web y verifica nuevamente.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/07/2015 2:42 am

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro