Joomla v. 3.8.2 - Instalación Multilenguaje no aparece menu principal  

Página 1 / 2
 
Javier
 Javier
Usuario experto

Hola,
Estoy creando en un jomla 3.8.2 y template yootheme.. un site Multilenguaje 5 idiomas.. la web ahora mismo esta en www.iocleanerlab.com/selectiumlab.com

Ya he creado otro de 2 idiomas y funciona bien .. hecho en www.thunderline.es .. por lo que no sé exactamente que ocurre. los pasos que he hecho son..

1.- instalado joomla + los 5 idiomas que necesito
2.- instalada template Juno.. de yootheme valida en principio para joomla y multilenguaje
3.- creado menu principal
4.- creado menus de los 5 idomas, eng, esp, cat, gal, eus
5.- creada asociacion a modulos de menu y creados modulos de menu es,eng,cat,gal,eus
6.- dentro de los modulos solo asigno a cada menu su lenguaje.. y sólo en el menu español asigno el menu en español + la home del menu principal, que es lo que hice en 2 idiomas al ser el esp el principal ( aunque provandolo ahora, parece ser que este o no tambien activada la home del menu principal, no parece cambie nada)
7.- en menu principal.. publico item home y despublico el resto de items del menu .. para que los cambie

solo hago asociaciones de todos los item home en los diferentes idiomas..

en principio con todo esto realizado deberia funcionar.. creo que es lo mismo que hice en la pagina con 2 idiomas.. he mirado algun tutorial pero no sé que ocurre..

si me pueden ayudar

Gracias de antemano

Javier

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 14/11/2017 6:38 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

De manera general parece que los pasos que has realizado son correctos, da una repasada a la versión oficial para configurar multiidiomas por si se te ha pasado algo.

https://docs.joomla.org/J3.x:Setup_a_Multilingual_Site/es

Si sigues con problemas envíanos algunas capturas de pantalla para ver la configuración.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/11/2017 8:16 pm

Cursos Gratuitos WordPress

Javier
 Javier
Usuario experto

hola,

estoy repasando lo que me has enviado.

de momento veo que no tengo los plugins .. system languagefilter
ni el pluguin system language code

en system solo me aparece..
system yootheme framework
system - fabrik scheduled task
system-fabrik

todo lo demás creo que no esta mal.. habria que instalar estos dos pluguins???
me puedes decir donde puedo descargarlos.. a ver si haciendo la instalacion funciona??
gracaias

JAvier

ResponderCitar
Respondido : 14/11/2017 8:28 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Los plugins deberían de existir, verifica si estas revisando la paginación.

Te adjunto el siguiente video tutorial: https://www.youtube.com/watch?v=DnIHpgMkHhY la serie de vídeo tutoriales para multi-idiomas esta en nuestro canal de Youtube.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/11/2017 10:12 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Javier
 Javier
Usuario experto

Hola, si es correcto el plugin existe en castellano como
sistema-código del idioma
sistema-filtra idiomas

ambos ok.. y he mirado tutorial que me envias multi-idioma, te paso pantallazo del estado de parámetros multilnguie.. porque todo está ok.. menos los que dice de despublicar el menu inicio de idioma "todos" .. que entiendo que es dentro del Menu principal ( icono casita) que no es de ningun idioma tengo publicado el home.. y la estrella de inicio activada en el y el resto despublicado... ( pero no me deja despublicarlo.. tengo que publicar algo, ya que a algun item le tengo que poner la estrella de inicio...

adjunto imagen de main menu y estado de parametros multilingue

ResponderCitar
Respondido : 15/11/2017 9:30 am
Javier
 Javier
Usuario experto

he probado quitar la asociacion entre idiomas, y despublicar el Main menu ( icono casa) ..

ahora se puede ver todo el menu.. pero lo que no hace es cambiar el menu de idioma.. es el mismo menu en todos los idiomas.. cuando hay un menu en cada idioma..

otro error que veo es que si haces click en la bandera idioma español.. 1 click funciona bien.. y otro click funciona mal y se va a

http://www.iocleanerlab.com/selectiumlab.com/index.php/es/ (este sería el link correcto)
http://www.iocleanerlab.com/selectiumlab.com/index.php/es/13-categoria-es-es (no se porqué se va aqui o como cambiarlo)

si entras en http://www.iocleanerlab.com/selectiumlab.com/
y vas al idioma castellano podrás verlo

ResponderCitar
Respondido : 15/11/2017 10:12 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Si quitas la asociación de idiomas en el menú es normal que siempre se muestre le mismo menú para todos los idiomas, independientemente del idioma seleccionado.

Tendrías que probar a volver a asignar idiomas en los menús y enviarnos una captura de pantalla donde podamos ver cómo lo tienes configurado.

Sobre lo que comentas de la bandera de España he probado a pulsar varias veces en la bandera y veo que siempre me carga el enlace correcto.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/11/2017 2:39 pm
Javier
 Javier
Usuario experto

hola,

ok he vuelto a asociar todos los menus...
os envío imagenes de los menus, de los modulos, de los pluguins, y del estado de parametros multilingue.. no se si necesitais alguna imagen mas.. pero solo me deja enviar hasta 8...

espero vuestra respuesta

Gracias de antemano.

ResponderCitar
Respondido : 15/11/2017 5:14 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

El Main menu, el menú neutro que tiene Todos los idiomas es necesario para que Joomla funcione, deja sólo el ítem de menú home en este menú y mantenlo activo, el resto de menús si que deben tener ítems del mismo idioma.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/11/2017 8:31 pm
Javier
 Javier
Usuario experto

hola.

ok.. en el main menu ( icono casa) acitvo solo el item home y despublico el resto.. adjunto imagen..

si hago esto en la web sólo me aparece la palabra home.. el resto de items del menu no aparece.. puedes verlo en www.iocleanerlab.com/selectiumlab.com/
ademas si hago click en las banderas.. la palabra home no cambia segun el idioma y en cada idioma home se llama de una manera..

en el post anterior hay 8 imagenes con todos los menus en cada idioma para que puedas chequearlo y ver lo que falla..

Gracias de antemano, pero me estoy volviendo loco..

ResponderCitar
Respondido : 15/11/2017 10:23 pm

Cursos Gratuitos WordPress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

La configuración parecería estar correcta, tienes que continuar realizando las traducciones tanto para los módulos, artículos, etc. Es posible que la falla que comentas es porque también necesites duplicar la plantilla y para cada plantilla tiene que estar seleccionado los menús en su respectivo idioma. Tienes que tener cuidado también en las asignaciones que deben ser para su idioma correspondiente.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/11/2017 11:12 pm
Javier
 Javier
Usuario experto

Hola ,

he realizado otras paginas en varios idiomas.. aunque template diferente, pero misma version de joomla..

puedes verlo en www.thunderline.es funciona correctamente sin duplicar plantilla etc.. lo de duplicar plantilla es viable cuando el tipo de escritura en el idoma es diferente tipo vietnamita, chino.. pero para idiomas como ingles, español, catalan, gallego, vasco creo que no tiene sentido.. por lo que creo que le pasa algo al joomla debe faltar algun fichero o algo pasa..

de hecho si haces click en la bandera idioma español.. no redirige a donde tiene que dirigir que seria..

http://www.iocleanerlab.com/selectiumlab.com/index.php/es/

sino que a veces haces click y te manda a

http://www.iocleanerlab.com/selectiumlab.com/index.php/es/13-categoria-es-es

a parte de que el menu no aparece.. y a la bandera le pasa esto.. es un problema muy extraño.. en soporte de joomla no han sabido arreglarlo o decirme que pasa después de 15 tickets.. y me parece que vosotros tampoco sabéis que ocurre...
yo os puedo dar acceso al panel de administracion de la web si queréis echar un vistazo pero empezar a duplicar cosas por duplicar me parece que no es necesario..

gracias de antemano

ResponderCitar
Respondido : 15/11/2017 11:28 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Lo que comentas no es correcto, es posible que cierta plantilla no lo necesite. Pero de forma general si que tienes que duplicar la plantilla para cada idioma de forma obligatoria ya que esta es la sección donde también se hacen las asignaciones caso contrario no funcionara.

Te recomiendo que revises este punto que seguramente es el que esta fallando.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/11/2017 1:44 am
Javier
 Javier
Usuario experto

hola,

ok.. como me comentas voy a duplicar la template default y la he duplicado una template para cada idioma. asignando todos los items del menu segun sea el idioma.... total 5 templlates más, y después de duplicarla he creado un modulo login switcher nuevo.... que ahora lo veras en la tolbar derecha.. despublicando el que habia en la izquierda

Sigue sin funcionar..

ahora mismo siguen los 2 problemas..

1.- el menu no aparece entero.. si en el main menu ( icono home) sólo dejo activo el item home y despublico el resto. de items.. sólo sale el item home en la web.. pero el item home tiene un nombre distinto como puedes ver en los pantallazos de menu de los mensajes previos.. y no cambia de nombre al cambiar de idioma.. es decir.. no funciona bien..
2.- cuando haces click en la bandera española hay veces que va a
http://www.iocleanerlab.com/selectiumlab.com/index.php/es/13-categoria-es-es
( que no es la direccion correcta) la direccion correcta seria
http://www.iocleanerlab.com/selectiumlab.com/index.php/es/
que es donde va cada bandera para cada idioma..
Parece que haya una direccion predefinida en la bandera de españa..

al crear el multisite... en los diferentes menus para cada idioma me salia un item llamado "categoria" como "oculto" ya que ponia la palabra oculto dentro de un cuadro gris.. ese item no me interesaba y lo he borrado.. no sé si tiene algo que ver.. pensando que la bandera de españa vaya a algo de categoria cuando redirecciona mal es lo que me ha hecho acordarme

Yo ahora mismo he seguido todo lo que me decis.. no sé si necesitais algun pantallazo más de algo o que se os ocurre.. a mi se me acaban las ideas..
si queréis que de alguna forma privada os de acceso al administrador no hay problema.. para echar un vistazo, me decis como y arreglado..

o intentamos arreglar el tema de la bandera primero y luego seguimos con el tema del menu.. en lo que podais ayudarme en esto tan raro.. os lo agradezco.. llevo una semana para poder arreglarlo.. no sé si es mejor borrarlo todo y empezar de cero

ResponderCitar
Respondido : 16/11/2017 9:46 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Tendrías que verificar si en la configuración de las plantillas que has duplicado has asignado para cada una el idioma correspondiente. Es decir, por ejemplo la plantilla que has creado para el idioma español tiene que estar asignada a ese idioma.

En caso de dudas, envía capturas de pantalla de la configuración de la plantilla, para la instancia de alguno de los idiomas.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/11/2017 2:43 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro