Avisos
Vaciar todo

K2 no actualiza ni crea nuevos ítems tras actualización  

 
Angel Diego
 Angel Diego
Usuario activo

Hola.

Hace un par de días realicé la actualización de Joomla a 3.7.5 e inmediatamente después la de K2 a 2.8. Desde entonces, no puedo crear ni modificar ningún registro de K2. Cuando lo intento, al salvar o cerrar se va directamente a la página principal de administración.
Realicé una copia de seguridad antes de la actualización a 3.7.5 y la instalé para ver si evitaba el problema. No funcionó, el problema seguía igual. Borre caché de navegador, probé otro navegador distinto y nada.
He estado buscando por internet casos similares pero todos son bastante viejos y sus soluciones son de versiones muy antiguas, claro.
No sé si me podéis ayudar, si a alguien le suena una posible solución. Por otra parte, el sitio en su front-end, funciona perfectamente.
Gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 21/08/2017 10:12 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Angel.

Puedes restaurar tu web a una fecha anterior al error que nos estas comentando.

Con el nuevo sistema de copias SuperBackup es muy sencillo restaurar tu web a un momento anterior 🙂

Lo ideal es que tu mismo aprendas a hacerlo para que en casos de emergencia, puedas solucionarlo en cuestión de minutos.

No es difícil ya verás 🙂

Vamos paso a paso:

Primero, ve a tu área de clientes -> webempresa.com/areacliente.php

Luego, ve a la pestaña "Hosting" > SuperBackups

A continuación, elige una copia del día anterior de dónde tu web funcionaba correctamente

Por último, de las tres opciones, selecciona estas dos:

1º Desde la pestaña "Restauración parcial" > pulsa en el botón azul "Restaurar el directorio public_html completo"

2º Desde la pestaña "Restauración bases de datos" > selecciona la base de datos que utiliza tu instalación

Con ello, tu web quedará restaurara a la copia que previamente has elegido 🙂

Te será útil -> guias.webempresa.com/preguntas-frecuentes/gestionar-copias-seguridad-superbackup/

Un saludo

ResponderCitar
Respondido : 21/08/2017 5:57 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Angel Diego
 Angel Diego
Usuario activo

Hola.

El problema es que la web está en producción y se lleva a cabo un proceso de registros, formularios y compras de cursos que me impiden volver a una situación del pasado sin perjudicar a personas terceras que, incluso, han desembolsado dinero.

Tengo que buscar una solución que arregle el problema sin tener que tomar esa drástica solución.

ResponderCitar
Respondido : 21/08/2017 8:47 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Lo primero que te sugiero es hacer un clon de tu sitio y en base a este clon tratar de corregir, si esta tu sitio en produccción, mejor no tocar nada de moemento en el de producción.

Para clonar puedes usar un plugin como Akeeba Backup, realizar un respaldo y restaurar el respaldo en alguna carpeta.

En el clon, desactiva la cache o extensiones de optimización que estes usando. Prueba reinstalando k2 si sigues con problemas.

Saludos.

ResponderCitar
Respondido : 21/08/2017 10:25 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Angel Diego
 Angel Diego
Usuario activo

Observo que en el archivo error_log de la carpeta administrator aparece constantemente el warning de PHP: ini_set() has been disabled for security reasons in...
¿Podría tener algo que ver en la imposibilidad de que funcione la actualización de items de K2?

ResponderCitar
Respondido : 22/08/2017 6:22 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Dudo que tenga que ver, ya que esto siempre estuvo deshabilitado, sin embargo puedes solicitar a través de tickets de soporte para que te lo habiliten.

Saludos.

ResponderCitar
Respondido : 22/08/2017 7:50 pm

Cursos Gratuitos WordPress

Angel Diego
 Angel Diego
Usuario activo

Efectivamente, después de que vuestros compañeros habilitaran la opción de ini_set, han desaparecido las líneas de warning del error_log pero el problema con K2 continúa...

ResponderCitar
Respondido : 22/08/2017 8:20 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Realiza un clon de tu sitio y lleva a cabo lo que te comenté:

En el clon, desactiva la cache o extensiones de optimización que estes usando. Prueba reinstalando k2 si sigues con problemas.

Saludos.

ResponderCitar
Respondido : 22/08/2017 10:32 pm

wpdoctor-revisa-la-salud-de-tu-wordpress