[Resuelto] LOGIN no redirije a donde debe  

 
Javier
 Javier
Usuario experto

Hola,

estoy creando una web y me pasa lo siguiente.. al hacer login.. de un usuario registrado.. me va aqui

http://iocleane-cp22.webjoomla.es/index.php/login-web/profile

a ver - te digo lo que he hecho

he creado 4 grupo de usuarios, dentro de Author, y cada uno tiene su acceso como registrado, user1,2,3,4

he hecho un formulario de fabrik para registrar a los usuarios

y he instalado redirect-on login.

hasta aqui todo correcto--

el formulario de fabrik cuando relleno los datos graba bien. y agrega el usuario con su grupo de usuario.

dentro del formulario de fabrik he puesto un plugin JUser para decirle que grupo es etc...

al grabarlo entiendo que el tema fabrik es ok

-------

el componente de redirect on login está configurado para que el user 1, vaya al menu 1, el user 2 vaya al menu 2, el user 3 vaya al menu 3 etc...

por lo que entiendo que es ok

-----------

los modulos de menu 1,2,3,4, estan asignados a las paginas que deben mostrarse

-------

pero cuando hago login ( item menu de users de joomla es el que utilizo para hacer el login) me abre el profile del usuario con el que me conecto

forum webempresa 1

 

 

----------

no entiendo porque me conecta con el profile cuando tendria que mostrar el articulo del item menu 1 y  tampoco porque me muestra el menu principal que se supone que es publico y no registrado, y no me muestra el menu 1, que es registrado y el que corresponde

-------------

alguna idea?? me estoy volviendo loco.

Gracias!

 

This topic was modified hace 4 semanas por Javier
Citar
Respondido : 01/10/2020 2:35 am
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Javier,

Según entiendo has probado por separado los módulos que estas utilizando y has verificado el comportamiento de cada uno como para verificar si al momento de loguearse el usuario lo deja en algún lugar en especifico?

De ser así puedes enviarnos captura de esta configuración sobretodo a nivel de re dirección de los usuarios al hacer login posiblemente alli este empezando el problema.

Un saludo 🖐️ 

ResponderCitar
Respondido : 01/10/2020 2:59 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Javier
 Javier
Usuario experto

modulos he probado el de re-direct on login...

en lo usergroups -- estan asignado a menu item los 4 usuarios distintos como puedes ver en la imagen

forum webempresa 2

y cada usuario por ejemplo el primero esta asociado al menu con su nombre y al primer item de ese menu como  adjunto en la imagen

forum webempresa 3

Esto parece que está bien..

lo tengo igual que en otras web que si funciona

que mas necesitarias ver

ResponderCitar
Respondido : 01/10/2020 3:57 am
Javier
 Javier
Usuario experto

he visto que habia dos errores.. un menú de usuario... al asignarle el módulo... había asignado un módulo que no tocaba, es decir, dos menús de usuario diferente tenían el mismo módulo.

y el redirect on login - no lo habia activado creo.. o se habia desactivado

ahora parece que todo funciona bien..

Gracias!!

ResponderCitar
Respondido : 01/10/2020 7:28 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Javier.

Genial !!! me alegra que lo solucionaras.

Gracias por informarnos y aportar la solución 😉  

 

Cerramos el tema.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 01/10/2020 9:18 am

Por favor Iniciar Sesión o Registro