Problema al actuali...
Avisos
Vaciar todo

Problema al actualizar de Joomla 2.5.28 a 3.4  

Página 2 / 3
 
Francesc
 Francesc
Usuario activo

Hola a todos, estamos intentando actualizar de joomla 2.5.28 a 3.4, hemos seguido los pasos de los tutoriales que hay en webempresa, pero cuando pasa al 85% de la actualización nos da un error, que adjuntamos en un pantallazo, se refiere a la base de datos. Pero ya no sabemos como solucionarlo.
Pedimos ayuda de que debemos hacer.
Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 20/03/2015 10:55 am
Francesc
 Francesc
Usuario activo

Hola Jhon,

Hice justamente todo lo que dices en tu respuesta y no me funcionó.
No sé que más puedo hacer

ResponderCitar
Respondido : 24/04/2015 11:08 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Antonia María
 Antonia María
Usuario eminente

Hola,

Si se queda la pantalla en blanco se debe generar un error 500, tienes que ejecutar Stephan y enviarnos las lineas de referencia.

Hola el resultado del análisis Stephan relacionado con errores 500 es el siguiente:

[23-Apr-2015 21:26:54 Europe/Berlin] PHP Fatal error: require_once(): Failed opening required '/home/servici6/public_html/Test/plugins/system/plg_ztoolsDSplg_ztoolsDSdefine.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/servici6/public_html/Test/plugins/system/plg_ztools/plg_ztools.php on line 18
[23-Apr-2015 21:31:17 Europe/Berlin] PHP Fatal error: require_once(): Failed opening required '/home/servici6/public_html/Test/plugins/system/plg_ztoolsDSplg_ztoolsDSdefine.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/servici6/public_html/Test/plugins/system/plg_ztools/plg_ztools.php on line 18
[23-Apr-2015 21:33:01 Europe/Berlin] PHP Fatal error: require_once(): Failed opening required '/home/servici6/public_html/Test/plugins/system/plg_ztoolsDSplg_ztoolsDSdefine.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/servici6/public_html/Test/plugins/system/plg_ztools/plg_ztools.php on line 18

Saludos.

ResponderCitar
Respondido : 24/04/2015 12:23 pm
Antonia María
 Antonia María
Usuario eminente

Hola
La parte del informe de Stephan que corresponde con error 500 es
[23-Apr-2015 21:26:54 Europe/Berlin] PHP Fatal error: require_once(): Failed opening required '/home/servici6/public_html/Test/plugins/system/plg_ztoolsDSplg_ztoolsDSdefine.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/servici6/public_html/Test/plugins/system/plg_ztools/plg_ztools.php on line 18
[23-Apr-2015 21:31:17 Europe/Berlin] PHP Fatal error: require_once(): Failed opening required '/home/servici6/public_html/Test/plugins/system/plg_ztoolsDSplg_ztoolsDSdefine.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/servici6/public_html/Test/plugins/system/plg_ztools/plg_ztools.php on line 18
[23-Apr-2015 21:33:01 Europe/Berlin] PHP Fatal error: require_once(): Failed opening required '/home/servici6/public_html/Test/plugins/system/plg_ztoolsDSplg_ztoolsDSdefine.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/servici6/public_html/Test/plugins/system/plg_ztools/plg_ztools.php on line 18

Saludos.

ResponderCitar
Respondido : 24/04/2015 2:24 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Según los errores que envías veo que son errores reslacionados con un plugin de terceros : plg_ztoolsDSplg_ztoolsDSdefine.

Lo que te recomiendo es que antes de actualizar de Joomla 2.5 a Joomla 3, desactives todas las extensiones de terceros que estas usando, estas extensiones es posible que tengas que actualizarlas manualmente

Saludos

ResponderCitar
Respondido : 24/04/2015 7:07 pm
Antonia María
 Antonia María
Usuario eminente

Tras desactivar algunos componentes la actualización ha finaluizado y me dan estos errores:
Error on updating manifest cache: (type, element, folder, client) = (component, com_mailto, com_mailto, 0)
Error on updating manifest cache: (type, element, folder, client) = (component, com_wrapper, com_wrapper, 0)
¿Tengo que preocuparme y hacer algo más?

Saludos.

ResponderCitar
Respondido : 24/04/2015 8:34 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Hace referencia a la cache, has tenido habilitada la cache en tu joomla antes de actualizar, tendrías que probar desactivando la cache.

De manera general los archivos de cache se crean nuevamente, por lo que si no has obtenido nuevamente estos mensajes no deberías tener problema, prueba igual deshabilitar la cache si vas a realizar el proceso nuevamente

Saludos

ResponderCitar
Respondido : 24/04/2015 10:39 pm
Grupo
 Grupo
Usuario eminente

Buenos días me dirijo a ustedes para solicitar su ayuda, ya que hemos probado como 20 veces la actualización de joomla 2.5.28 a joomla 3.4.8 y en cada intento nos da un error diferente, les comento como realizamos la actualización.

- Hacemos copia de la web www.madridnorte24horas.com actualmente en joomla 2.5.24
- Restauramos la copia en el directorio www.madridnorte24horas.com/prueba
- Realizamos upgrade de 2.5.24 a la versión 2.5.28
- Desinstalamos los componentes: Akeeba, RS Firewall, Podcast Manager, Xmap y JCE Editor
- Desactivamos el plugin "recuerdame "
- Purgamos la cache de las actualizaciones
- Probamos la actualización:
---Hemos realizado pruebas actualizando automáticamente desde joomla
---Hemos realizado pruebas actualizando manualmente desde gestor de extensiones
---Hemos realizado pruebas actualizando manualmente desde ftp.

Resultado en diferentes casos:

*Página en blanco: Hemos cambiado en el archivo configuration.php la opción: error reporting, de default a maximun y continua igual
Hemos probado a cambiar el archivo del plugin remember.php y continua igual.

*Se visualiza el Panel de control con una serie de errores (adjuntamos pantallazo) pero a la hora de acceder a cualquier item se queda la página en blanco.

Hay que decir que cuando la página se queda en blanco, si consultamos el código fuente de la misma esta vació.

En este momento tenemos la version 2.5.28 restaurada en el directorio madridnorte24horas.com/prueba , por si desean acceder a ello.

Espero me puedan ayudar, ya que como les digo lo hemos intentado 20 veces y no encontramos solución, al hacer análisis con Stefan no muestra ningún error, al igual que en el log.

ResponderCitar
Respondido : 09/08/2016 11:46 am

Cursos Gratuitos WordPress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

Los errores son de duplicado de entrada en la base de datos.

Dices que ya realizaste muchos intentos de actualizar la web, perdona por las consultas, cada vez que instalabas la web clonada en ' Prueba ' y la eliminabas, ¿ eliminabas también la base de datos del clon ?

Puede que queden restos de la anterior instalación y por eso te de problemas de entradas duplicadas.

Un saludo

ResponderCitar
Respondido : 09/08/2016 4:24 pm
Grupo
 Grupo
Usuario eminente

Hola Pepe, la verdad es que estaba eliminando las tablas de la base de datos en vez de crear una nueva para cada intento.
He probado como me dices a crear una nueva base de datos por si acaso, pero continua ocurriendo lo mismo, pantalla en blanco y el panel de control si que aparece en la versión 3 pero con un montón de errores, tal y como te adjunto, pero al pulsar en cualquier item del panel de control la pantalla se queda en blanco.

ResponderCitar
Respondido : 09/08/2016 6:08 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Prueba a entrar desde tu Joomla 3 migrado a Extensiones > Gestor de extensiones > base de datos y luego Corregir.

Si aún sigues con problemas podrías evaluar en lugar de actualizar tu Joomla migrar tu información a un Joomla 3 instalado desde cero.

Saludos.

ResponderCitar
Respondido : 09/08/2016 7:00 pm
Grupo
 Grupo
Usuario eminente

Hola Jhon, no me deja acceder a esa ruta, la página aparece completamente en blanco, he realizado otra prueba y actualizando de manera automática, siempre se para y va a página en blanco en 86,3%.

¿Como posibilidad, como podría migrar la información a un Joomla 3 pre instalado? gracias.

ResponderCitar
Respondido : 09/08/2016 7:08 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

He visto que varios clientes tiene problemas para actualizar de 2.5 a 3.x, sin embargo al final optan por la migración.

Para migrar instala un Joomla 3 desde cero en una carpeta, luego configura tu template y migra tu contenido
Para migrar el contenido puedes evaluar usar alguna extensión por ejemplo revisa la siguiente lista :

http://extensions.joomla.org/category/migration-a-conversion/data-import-a-export

Saludos.

ResponderCitar
Respondido : 09/08/2016 8:12 pm
Grupo
 Grupo
Usuario eminente

Buenos días, he continuando haciendo pruebas y ahora he conseguido que el panel de control me aparezca correcto, los componentes de terceros funcionan correctamente, pero en el momento de pulsar sobre el gestor de artículos, gestor de extensiones...etc, se va a página en blanco...No se si finalmente me aconsejáis la migración con alguna extensión teniendo en cuenta que tenemos unos 16000 artículos publicados. Gracias de nuevo

ResponderCitar
Respondido : 10/08/2016 10:49 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

Como te comenta Jhon lo mejor es que realices una migración, en los packs que tenemos, tienes por ejemplo la plantilla Palene

Para exportar contenido de una plantilla a la otra puedes utilizar J2XML.
Exportar e Importar Artículos en Joomla

Un saludo

ResponderCitar
Respondido : 10/08/2016 11:06 am
Grupo
 Grupo
Usuario eminente

Perfecto, gracias a ambos, me voy a poner con ello...os iré contando, saludos.

ResponderCitar
Respondido : 10/08/2016 11:16 am

Cursos Gratuitos WordPress

Página 2 / 3