Problema registro usuarios  

 
Gabriel
 Gabriel
Estimable Member

Estoy intentando registrar un nuevo usuario en la tienda de mi web, pero, después de introducir todos los datos aparece el siguiente mensaje: "Las palabras que has escrito no coinciden con las mostradas. Por favor, inténtalo de nuevo." referido al Recaptcha. Lo he intentado varias veces por si no interpretaba bien los textos, pero siempre aparece este mensaje. No sé desde cuándo sucede ésto, pero tengo bastantes usuarios que se han registrado sin problemas y me he enterado porque una persona que quería registrarse me ha llamado contándome el problema. ¿Me podéis ayudar?. Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 29/12/2017 7:40 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Parece que tienes mal configurado el recaptcha, luego de intentar usar recaptcha aparece este mensaje:

Input error: c: Invalid version number for captcha challenge token. k: Format of site key was invalid

Qué extensión usas para mostrar recaptcha, prueba configurarla nuevamente o crea nuevamente las claves en Google.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 29/12/2017 8:23 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Gabriel
 Gabriel
Estimable Member

Hola Jhon. Estoy usando el plugin Captcha - ReCaptcha, pero al crear las claves en google sólo me permite crearlas para recaptcha V2 (I'm not a robot) y "Invisible recaptcha". Mi duda es si estoy usando un plugin antiguo que no valga para las últimas versiones de Recaptcha y por eso no funciona. De todas formas he vuelto a generar las claves para invisible recaptcha y sigue apareciendo el mismo mensaje. De todas formas me gustaría, si es posible, instalar el pluging para recaptcha V2 y usar éste. ¿Me puedes indicar cómo?

Gracias

ResponderCitar
Respondido : 24/01/2018 6:17 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

El problema es lo que comentas, estas usando datos generados para invisible captcha en un captcha v1, lo cual es incorrecto.

Si quieres tener un captcha para el registro de usuarios, Joomla incluye uno, no es necesario usar extensiones adicionales, revisa: https://docs.joomla.org/J3.x:Google_ReCaptcha/es

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/01/2018 8:39 pm

Cursos Gratuitos WordPress

Gabriel
 Gabriel
Estimable Member

Hola Jhon. El documento que me indicas es para Joomla 3.4.0 o superior y yo tengo el 2.5.24, por lo que en la configuración no aparece la posibilidad de seleccionar captcha V2. ¿Hay alguna otra forma de reconfigurarlo para 2.5? Gracias

ResponderCitar
Respondido : 25/01/2018 11:07 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Gabriel.

Jommla 2.5 hace mucho tiempo que no tiene soporte y es una versión sin mantenimiento por lo que tanto las extensiones como el propio Joomla no se actualizan y empezaras a tener problemas como estos en diferentes partes de tu web a mas de ser un entrada para posibles atacantes.

Como consejo antes de meterte en el tema del captcha es que te plantees la posibilidad de actualizar tu version de joomla.

https://www.webempresa.com/blog/actualizar-joomla-2-5-28-joomla-3-4-rapida-facilmente.html

Revisando el directori de extensiones de joomla no veo ninguno compatible con joomla 2.5 -> reCaptcha

Puedes probar a desactivar el plugin de Captcha para evitar que se muestre.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 25/01/2018 11:58 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Gabriel
 Gabriel
Estimable Member

Hola.
Leo en este artículo que para versiones anteriores a Joomla 2.5.28 (yo tengo la 2.5.24), es necesario aplicar un parche antes de actualizar a 3.4.x. ¿Me puedes indicar cómo tengo que aplicar ese parche?

Gracias

ResponderCitar
Respondido : 25/01/2018 1:51 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Gabriel.

Actualiza primero a la versión 28 y una vez actualizada a esa version realiza los pasos para actualizar a la 3x

Como consejo, antes que nada realiza un clon de tu web y realiza todas las actualizaciones en ese clon, si ves que todo salió bien y el clon se actualizo sin problemas, realizas los mismos pasos en la web en producción, con esto nunca tendrás la web en producción caída si pasa algun imprevisto mientras se actualiza.

https://docs.joomla.org/Copying_a_Joomla_website/es

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 25/01/2018 2:12 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Gabriel
 Gabriel
Estimable Member

Estoy intentando comprobar los requisitos para actualizar Joomla, pero algunas cosas no sé cómo hacerlas:
- Me pide hacer una lista de las extensiones importantes que tengo instaladas para comprobar si son válidas en Joomla 3.4. Supongo que se refiere a las que he instalado yo. Si es así, ¿cómo puedo saber las que he instalado, aparte de las que vienen con el sistema y dónde compruebo la compatibilidad?

- Estoy usando la plantilla Helena y tengo que comprobar si es compatible con Joomla 3.4, pero no sé dónde mirarlo.

- Dice: desinstala completamente los componentes que no sean compatibles con la nueva versión. ¿Se refiere a las extensiones mencionadas antes, o son otros componentes? ¿Cómo puedo comprobarlo?

Perdonad el bombardeo, pero estoy bastante perdido

ResponderCitar
Respondido : 25/01/2018 6:48 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Con respecto a Captcha, es muy probable que estes usando una version antigua de captcha (v1) la que aparecía con letras para tipear, Google dejará de dar soporte a este recaptcha en Marzo de este año (2018) por lo que o desactivas el recaptcha que tienes o actulizas tu Joomla

Lo que te sugiero es hacer estas consultas en un nuevo hilo de discusión con el título adecuado, de esta manera mantenemos orden en el foro.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/01/2018 8:18 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Gabriel
 Gabriel
Estimable Member

Buenos días. Estoy intentando desactivar Captcha para que no aparezca en el registro de usuarios, ni en en el login de uno registrado, hasta que pueda actualizar Joomla. He desactivado el plugin y en "Configuración Global - Sitio", en la opción Captcha predeterminada he seleccionado "-Ninguno seleccionado-", pero el Captcha sigue apareciendo en la web, según aparece en el archivo adjunto. Quería comentarte también que el Captcha funciona perfectamente en el formulario de contacto, lo que es un misterio para mí, porque entendía que el problema es que los nuevos formatos de captcha permitidos por Google no son compatibles con mi versión de Joomla. Por tanto me gustaría, si es posible, solucionar el problema del captcha en el registro de usuarios y si no es posible ésto, eliminarlo y mantener el del formulario o eliminarlo de todos los sitios.

Gracias

ResponderCitar
Respondido : 05/03/2018 11:10 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Gabriel.

Revisa lo siguinete:

Accede a Extensiones-> Gestor de Plugins y revisa si tienes instalado el plugin de nombre System - EasyCalcCheck PLUS - ECC+.

Si lo tienes en la lista de plugins lo eliminas.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 05/03/2018 11:25 am

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro