Avisos
Vaciar todo

Aparecen los precios sin IVA en Prestashop  

Página 1 / 2
 
Andrea
 Andrea
Usuario experto

Hola,

Desde que creé mi tienda online con Prestashop no he tenido problemas con esto, no sé si ha sido en alguna de las últimas actualizaciones que he hecho.
Los precios que yo ponía al crear un producto nuevo, los ponía con IVA, y directamente recalculaba en el campo correspondiente el precio sin IVA (adjunto fotos), de forma que era un precio distinto en cada campo. Después en la web, se veía con IVA sin problemas.

Ahora como véis en las imágenes, se ve el sin IVA y con IVA igual en ambos campos (y de hecho, es el sin IVA el que aparece), de forma que acabo de ver que todos los precios en mi tienda se están mostrando sin IVA y no sé desde cuándo estoy perdiendo dinero con este problema...

¿Podéis por favor decirme cómo puedo hacer? ¿O tengo que ir manualmente producto a producto modificando todos los precios para que, aunque no esté bien calculado el precio sin y con, por lo menos el que se muestre en mi tienda sea el con IVA?

Muchas gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 05/03/2016 10:43 pm
Rafael
 Rafael
Miembro Moderator

Buenas tardes Andrea,

Te recomiendo echar un ojo primero a este enlace de nuestro blog para comprobar si tienes correctamente colocado para mostrar el IVA en los grupos de usuarios de tu tienda Prestashop

-> https://www.webempresa.com/blog/item/1549-mostrar-precios-con-o-sin-iva-en-prestashop.html

Comprueba si tienes configurado correctamente estas opciones que se indican

Saludos

ResponderCitar
Respondido : 06/03/2016 2:34 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Andrea
 Andrea
Usuario experto

Hola Rafael,

Sí, lo he comprobado y todo eso estaba bien, tengo la tienda desde hace casi un año y lo configuré al principio, y he visto que hasta el mes pasado se estaba mostrando todo correctamente.

El problema es el que comentaba, en la parte del Catálogo de productos, al meter el precio con IVA no recalcula bien el precio sin IVA, y pone por defecto el sin IVA en ambos campos, y es el que se muestra en la web finalmente.

Muchas gracias

ResponderCitar
Respondido : 06/03/2016 5:50 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Tendrías que comprobar si tienes correctamente configurado tanto el IVA como el país por defecto.

En primer lugar, realiza una prueba de pedido con el producto que has puesto de ejemplo, y comprueba si, una vez identificado como usuario y puesta la dirección de envío, se apilcan los impuestos al producto. Es decir, que no los muestra al principio, pero los muestra más adelante.

Vete a Localización->Localización y verifica que en el campo País por defecto tienes seleccionado tu país.

Luego vete a Localización->Reglas de impuestos y verifica que tienes correctamente configurados los impuestos. Ten en cuenta que cuando se crean los impuestos, estos se configuran por países, por lo que no a todas las direcciones de envío se les aplicaría un impuesto, si no lo has configurado así.

ResponderCitar
Respondido : 07/03/2016 2:25 pm

Cursos Gratuitos WordPress

Andrea
 Andrea
Usuario experto

Hola,

Justo es eso, al loggearme con un usuario los precios los veo ya con el IVA. Todo lo que me comentas de Localización, impuestos, etc tiene pinta de estar bien.

Entonces, ¿cómo puedo hacer que los impuestos se muestren sin que el comprador esté loggeado? Todos los grupos de clientes los tengo puestos como "mostrar impuestos incluidos".

Gracias

ResponderCitar
Respondido : 07/03/2016 4:01 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Desde los grupos de prestashop al editarlo verás que se puede o no mostrarl os impuestos, revisa :
https://www.webempresa.com/blog/item/1549-mostrar-precios-con-o-sin-iva-en-prestashop.html

Saludos.

ResponderCitar
Respondido : 07/03/2016 9:45 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Andrea
 Andrea
Usuario experto

Hola,

Eso ya lo he revisado varias veces, tengo todos los grupos con "Mostrar impuestos-SÍ" y todavía sigo viendo los precios sin IVA si no entro con un usuario...

Gracias

ResponderCitar
Respondido : 08/03/2016 12:03 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Si los usuarios registrados ven los impuestos, entonces el problema tiene que estar en algo de la configuración de PrestaShop.

Si dices que todos los grupos de usuarios ya tienen marcada la opción de mostrar impuestos vete a Localización->Localización y envíanos una captura de pantalla donde podamos ver lo que tienes en la pestaña Configuración.

Vete también a Impuestos->Reglas de impuestos y verifica que el impuesto que estés aplicando a tu producto esté aplicado a España en su conjunto.

ResponderCitar
Respondido : 08/03/2016 3:04 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Andrea
 Andrea
Usuario experto

Hola,

Adjunto los pantallazos.

Muchas gracias

ResponderCitar
Respondido : 08/03/2016 3:19 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Todo se ve correcto en las capturas de pantalla. Edita la regla de impuestos "ES Standard rate (21%)" y envíanos una captura de pantalla donde podamos ver cómo está configurada.

Lo mismo para la regla "ES Reduced rate (10%)"

ResponderCitar
Respondido : 08/03/2016 3:36 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Andrea
 Andrea
Usuario experto

Si por eso me estoy volviendo loca... ya no sé dónde puede ser.

Adjunto las capturas del 21% y del 0% (la del 10% es exactamente igual que la del 21%).

Gracias

ResponderCitar
Respondido : 08/03/2016 3:52 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Envía capturas adicionales de la configuración de los grupos de usuarios que tienes creados.

Prueba desactivando este impuesto y crea otro con similares carácterísticas y verifica si te sucede lo mismo.

Saludos.

ResponderCitar
Respondido : 08/03/2016 5:23 pm

Cursos Gratuitos WordPress

Andrea
 Andrea
Usuario experto

Hola,

Adjunto los pantallazos. Voy a crear otro impuesto parecido a ver qué pasa.

Gracias

ResponderCitar
Respondido : 08/03/2016 5:37 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Veo que has añadido nuevos grupos, cuando entras a Clientes => grupos ,

veo que tienes los tres grupos por defecto

Visitor - Todas las personas sin cuenta de cliente o clientes que no se han identificado.
Guest - Todas las personas que realizaron un pedido como Invitado.
Customer - Todas las personas que crearon una cuenta en esta tienda.

Tal vez tengas algún error en los grupos, podrias probar eliminando los grupos adicionales que has creado y verificar igualmente

Saludos.

ResponderCitar
Respondido : 08/03/2016 6:43 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Andrea
 Andrea
Usuario experto

Hola,

Ya sé lo que está haciendo:

El IVA que tiene que mostrar (el del 10%) estaba activo para todas las provincias de España salvo para 4, porque mi intención es que esas 4 tuvieran otro IVA distinto.

Entonces, con la configuración así, supongo que el programa al no saber la provincia de alguien que no se loggea, no muestra ningún IVA. Y al loggearme con mi usuario me mostraba bien el IVA, pues se correspondía con mi dirección (con provincia distinta a esas 4).

Acabo de modificar el impuesto del 10% seleccionando todas las provincias de España y ya se ve bien tanto loggeada como sin estarlo, así que perfecto.

Entiendo que para las personas que vivan en esas 4 provincias específicas lo más fácil será crear un grupo de clientes distinto indicando ese impuesto para ellas y ya está.

Muchas gracias a todos!

ResponderCitar
Respondido : 08/03/2016 6:58 pm
Página 1 / 2