Avisos
Vaciar todo

caracteres extraños en los mensajes de pedidos PrestaShop 1.7  

 
jaime luis
 jaime luis
Estimable Member

Hola Chicos!!!
Bueno, después de buscar y solo encontrar soluciones para PrestaShop 1.5 y con tanto cambio con el 1.7 os pregunto:
En los mensajes de clientes salen caracteres raros con los acentos y ñ... he visto esto:
"codificaciona utf-8 pero me salen caracteres extraños.
La base de datos tambien esta utf-8 spanish." veo mis tablas y hay un poco del todo, pero Spanish no...
este es ejemplo de un mensaje de cliente de pedido:
"Hola!! me la acaba de pedir el cliente, la necesitaría para el día 6, podría ser? podría ir yo a buscarla a Gijón o a donde sea en el caso de que estuviera lista"
Como soluciono?
Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 04/04/2019 2:09 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Jaime.

¿ Te refieres al correo ? ¿ los mensajes es de los clientes ? ¿ De donde provienen esos mensajes, es de algún formulario ?

lo comento por que veo que en la web la codificación está bien:

Necesitamos que nos des un poco mas de informacion y si puede ser una captura 😉

Un saludo

ResponderCitar
Respondido : 04/04/2019 4:10 pm

Cursos Gratuitos WordPress

jaime luis
 jaime luis
Estimable Member

Hola Pepe
Me refiero en el back office, en los pedidos, en la información del pedido si el cliente manda algún mensaje, te adjunto captura de pantalla.
Un saludo

ResponderCitar
Respondido : 04/04/2019 7:37 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Qué versión exacta tienes, ya que veo que hay bugs de los mismo que comentas reportados para la 1.7.x

http://forge.prestashop.com/browse/BOOM-4929

Este es más reciente:
https://www.freelancer.com/projects/php/prestashop-utf-messed-order-messages/

Verifica si tienes actualizaciones pendientes ya sea del propio PS o de módulos.

Saludos.

ResponderCitar
Respondido : 04/04/2019 8:18 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

jaime luis
 jaime luis
Estimable Member

Hola Jhon
Pues tengo la 1.7.5.1

No hay otra, y todos los módulos actualizados

Saludos

ResponderCitar
Respondido : 04/04/2019 8:27 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

No he visto referencia a ese error en PS 1.7.5, de manera general puede ser que la actualización que hayas realizado no se haya hecho correctamente.

Algo que podrías probar es instalar un nuevo PrestaShop en otra carpeta de tu hosting y verificar si con esa versión te sucede lo mismo, si no te sucede lo mismo podrías copiar la carpeta de administración a tu PrestaShop con problemas y luego entrar a la administración usando esa ruta de carpeta (puedes tener varias carpetas de administración con diferente nombre)

Saludos.

ResponderCitar
Respondido : 04/04/2019 11:06 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación