Avisos
Vaciar todo

Duda Buscador y autocompletar en administracion  

 
Jose Antonio
 Jose Antonio
Estimable Member

Hola,
tengo 3 dudas a ver si me podéis ayudar:
1.- Primero una fácil que es más de culturilla, al meter productos en prestashop, hay veces que empiezo a escribir y cuando empiezo algo que se escribe igual que algo escrito anteriormente, me ofrece ese texto de producto mientras voy escribiendo el mismo texto y si se llama igual ahorro tiempo, pero otra veces no me lo ofrece. Es problema del navegador? es casualidad? debería ofrecerme todo lo metido anteriormente? es algo así como el autocompletar de Chrome(que es el que uso) pero para todos los campos, no solo para nombres y medios de pago que hace Chrome. Esto es por si lo sabéis, que ya se que no es de prestashop 😉
2.- Ya sobre el buscador... hay veces que meto productos nuevos y los puedo buscar directamente en el frontal, y otras que hasta que no reinicio el indice totalmente en la administración, no los encuentra. Hay algún motivo para que, estando activada la reindexación automática, haya veces que lo hace bien, y otras que no lo haga?
3.- Por último... en el frontal por ejemplo busco "reloj"... una vez los encuentra, busco por ejemplo, "amortiguador"... una vez encuentra los amortiguadores, los enseña, pero en el buscador deja la palabra "reloj". ¿hay algo mal? Adjunto imagen
Muchas gracias de antemano.
Un Saludo

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 26/07/2016 7:10 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Lo primero que comentas, creo que si depende del navegador que usas y lo que tenga en el historial

Con respecto a la indexación, es posible que sea por que estas usando cache en tu sitio, revisa si desahbilitando cache te sucede lo mismo.

Para el último punto he probado lo que comentas buscando reloj y amortiguardo y veo que se muestra correctamente, que texto no cambia?, envía captura de pantalla.

Saludos.

ResponderCitar
Respondido : 26/07/2016 10:40 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jose Antonio
 Jose Antonio
Estimable Member

Hola

sobre la 1.- Puedes concretar algo más? el navegador que mejor hace esto es el? Si lo sabes... sino, nada, gracias
2.- Lo de la cache acababa de activarla, y esto pasa de antes. La caché es una de las cosas que recomienda activar vuestro recomendador, junto con otra cosas, como por ejemplo ""Smart cache" para las hojas de estilo (CSS)" que he tenido que desactivar porque ni siquiera llegaba a cargarse la tienda bien 🙁 Estas recomendaciones son compatibles con la versión actual de tienda? La dejo o la quito? 🙁
3.- Pues ahora parece que si va bien... de todas formas, pantallazo ya había anexado aunque se me debió olvidar dar al botón

... lo vuelvo a anexar aunque parece que ya no se produce.
Gracias Jhon

ResponderCitar
Respondido : 27/07/2016 8:30 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Con respecto al tema del navegador, uso Firefox y me va bien, supongo que igual con Chrome, podrías variar de navegador para probar , pero no creo que veas mucha diferencia ya que los historiales se manejan de manera similar.

Con respecto al tema de cache, si que es importante activarla, lo que te comenté era solo para probar si es que esto te esta causando el problema de la indexación. Puede ser que tenga que pasar un tiempo hasta que aparezca en la búsqueda de tu sitio, tendrías qeu verificar esto, lo otro es que evalues usar un cron, un proceso automático de indexación que se realice periódicamente, revisa :
https://www.easycron.com/cron-job-tutorials/how-to-set-up-cron-job-for-prestashop-search

Saludos.

ResponderCitar
Respondido : 27/07/2016 6:41 pm

wpdoctor-revisa-la-salud-de-tu-wordpress