Error en reglas de compra  

 
Ramón
 Ramón
Usuario eminente

Estoy intentando crear un descuento que afecte solo a 2 atributos, que se encuentran en dos productos distintos (metacrilato y formas corpóreas) , los atributos son material: metacrilato transparente 5mm y metacrilato transparente 8mm. He probado con los dos sin seleccionar producto, tambien seleccionando los dos productos y los dos atributos, y me da error, también he probado sólo con un producto y un atributo y me sigue dando error, os adjunto pantallazos del error en el carrito de la compra y de la configuración de la regla. Gracias!!

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 19/10/2016 1:24 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Si sólo haces la condición a nivel de producto, sin atributo te funciona?

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/10/2016 6:14 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Ramón
 Ramón
Usuario eminente

si, y si pongo solo 1 atributo no me funciona

ResponderCitar
Respondido : 19/10/2016 6:38 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Si sólo defines un atributo sin producto te sucede lo mismo?, el resto de opciones déjalas por defecto.
Prueba creando nuevos atributos y verifica.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/10/2016 10:13 pm

Cursos Gratuitos WordPress

Ramón
 Ramón
Usuario eminente

Si solo tengo un atributo sin producto tampoco me coge el cupón, he probado cambiándolo por otros diferentes y tampoco. Solo me funciona si es un producto, o incluso si tengo varios, pero con cualquier atributo me da error. Necesito poder ponerlo solo con atributos, sin productos. Gracias

ResponderCitar
Respondido : 20/10/2016 9:21 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Ramón, Buenos Días.

En la captura que mandas, veo que el atributo y el producto lo tienes en distintas reglas.
Tanto el producto como el atributo tienen que estar en la misma Regla del catalogo:

Modifícalo y nos comentas.

Te paso un enlace con tutorial de prestashop con la configuración de las reglas:
Crear reglas de precios y cupones

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 20/10/2016 12:49 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Ramón
 Ramón
Usuario eminente

He probado como dices:
1 prod + 1 atributo + solo envio / producto mas barato / producto seleccionado
Y no me coge el cupón, con ninguna acción
Si vuelvo a probar solo con 1 atributo, sigue sin funcionar, y si pruebo con 1 producto funciona correctamente
Si pongo cualquier atributo en la regla me dice:
Error 1
Usted no puede utilizar este vale con estos productos

Solo me coge el cupón cuando la condición tiene producto.

ResponderCitar
Respondido : 20/10/2016 1:12 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

He probado con lo siguiente, instalando un Pack por defecto y con la configuración indicada si funciona correctamente.

Prueba dejarlo de manera similar en tu sitio, o puedes probar creando nuevos productosy nuevo atributo y verificar con una nueva regla de descuento.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/10/2016 8:50 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ramón
 Ramón
Usuario eminente

Que pack has instalado? He probado con tu configuración y sigue sin funcionar. Utilizo un modulo que se llama megaproduct para calcular el precio por que los productos que vendemos son por metros cuadrados(megaproduct), puede ser esto lo que impida que se lean los atributos?

ResponderCitar
Respondido : 21/10/2016 10:04 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Si te fijas, en la configuración des descuento que ha hecho Jhon, dentro de la pestaña Acciones a seleccionado aplicar el descuento al pedido, en lugar de hacerlo al producto específico. Prueba a hacer lo mismo.

Sobre lo que comentas del módulo megaproduct, no se puede descartar que influya en esto. Si lo de antes no ha funcionado, podrías probar a desactivarlo temporalmente para hacer una prueba.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/10/2016 2:49 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Ramón
 Ramón
Usuario eminente

No puedo desactivar ese modulo porque podria perder mucha información, existe alguna otra manera de encontrar el problema, por lo menos para saber que lo causa?

ResponderCitar
Respondido : 25/10/2016 11:07 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Ramón.

No tienes que eliminarlo, solo tienes que desactivarlo momentáneamente para ver si es el que esta causando el problema. Esto no tendría que eliminar los datos que tienes en el.

Puedes realizar un clon de la web y hacer todas las modificaciones ( desactivar el plugin, etc ) en ese clon, con esto siempre tendrás la web en producción activa.
Duplicar una web PrestaShop ¿cómo lo hago?

Un saludo

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 25/10/2016 11:28 am

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro