interrogante fotos productos destacados  

 
María José
 María José
Usuario experto

Hola de nuevo,
Las fotos de" productos destacados" se ven con un interrogante tanto en ordenador como móvil como tablet, sin embargo las mismas fotos sí se muestran en los productos.
¿Cómo lo soluciono? gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 04/04/2019 9:54 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Prueba regenerar miniaturas, por ejemplo para PrestaShop 1.7 puedes revisar:
https://victor-rodenas.com/2017/04/09/donde-regenerar-miniaturas-en-prestashop-1-7/

Verifica antes si tienes espacio suficiente en tu cuenta de hosting.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 04/04/2019 10:58 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

María José
 María José
Usuario experto

Hola, sí tengo espacio y probé a regenerar miniaturas y siguen las interrogantes , lo curioso es que yo desde mi live_configurator lo veo bien ,pero desde otros equipos y móviles salen las interrogantes.
También me di cuenta que pasa lo mismo con los productos destacados que yo tengo asociados a la categoría de inicio, no son los que se muestran, pero yo sí los veo bien en live_configurator.

ResponderCitar
Respondido : 05/04/2019 11:38 pm
María José
 María José
Usuario experto

Puede ayudarme alguien por favor

ResponderCitar
Respondido : 06/04/2019 12:14 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Maria Jose.

Pueden ser varios los problemas que pueden provocar lo que comentas.
Empecemos por lo más fácil.

1º_ Lo primero que veo es que tienes una versión desfasada de Prestashop, utilizas la version 1.6.1.18 y la ultima estable es la 1.6.1.23

.- Previa copia de seguridad actualiza la versión de prestashop a la última estable.

2º_ veo que la URL que genera es la siguiente:
Contenido solo visible a usuarios registrados

En esa URL no existe ninguna imagen por eso muestra una imagen con interrogante.

.- Accede a preferencias -> imágenes y comprueba el nombre de los tipos de imágenes, en la plantilla por defecto de prestashop 1.6 son las siguientes:

cart_default, small_default, medium_default, home_default, large_default, thickbox_default, category_default
scene_default, m_scene_default

3º_ Puede ser que hayas regenerado las miniaturas pero que no haya terminado, dando time out. Para solucionarlo, ve a preferencias imágenes y regenera nuevamente las miniaturas pero desmarcando la opción que pone borrar imágenes anteriores, es posible que debas repetir este proceso algunas veces, dependiendo de la cantidad de productos.

4º_ Puede que hayas marcado la opción de poner imágenes en el almacenamiento nuevo o que no las hayas movido y tengas el almacenamiento por defecto.
Para solucionarlo debes tener claro como está, ve a preferencias, imágenes y regenera las miniaturas.
Debe darte un error de que no se encuentra la imagen en la ruta por ejemplo img/p/1/2/1/imagen.jpg

Si te da ese error indicalo por que hay que realizar modificaciones en el archivo AdminImagesController.php

5º- URL amigables. Accede a preferencias SEO y URLs y desactiva las URL amigables:

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 06/04/2019 12:59 pm
María José
 María José
Usuario experto

la actualización para hacerla me da el siguiente error PrestaShop's caching features are disabled , donde lo habilito?
Todo eso está revisado y bien y creo que el error está en el módulo productos destacados
el caso es que a la categoría de inicio le cambié el nombre por productos ( adjunto imagen) pero mantiene el 2 como id,

ResponderCitar
Respondido : 06/04/2019 1:20 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

María José
 María José
Usuario experto

la actualización para hacerla me da el siguiente error PrestaShop's caching features are disabled , donde lo habilito?
Todo eso está revisado y bien y creo que el error está en el módulo productos destacados
el caso es que a la categoría de inicio le cambié el nombre por productos ( adjunto imagen) pero mantiene el 2 como id,

Lo he desintalado y vuelto a instalar y sigue igual, el caso es que ahora sale un texto en la home que antes no salía como lo elimino? (" populares")

ResponderCitar
Respondido : 06/04/2019 1:23 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Maria Jose.

Lo he desinstalado y vuelto a instalar y sigue igual,
¿ que desinstalaste ? no lo entiendo, no tienes que desinstalar nada.

Veo que sigues con la misma version que tenias:

la actualización para hacerla me da el siguiente error PrestaShop's caching features are disabled , donde lo habilito?

Tienes que desactivar la cache.
.- accede parámetros avanzados -> Rendimiento y desactiva la cache:

Comprueba todo lo que te indique antes, actualizacion, URL amigables, Miniaturas, etc...

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 06/04/2019 1:42 pm

Cursos Gratuitos WordPress

María José
 María José
Usuario experto

voy actualizar, me va a llevar tiempo ya que tengo de pausar claudflare si nó, no puedo desactivar caché y poner en modo mantenimiento.
Cuando lo haga vuelvo a escribir ,pero sigo pensando que el problema es del módulo productos destacados ya que en el resto de tienda se ven perfectamente las imágenes , solo sale interrogante en esta sección.

ResponderCitar
Respondido : 06/04/2019 2:45 pm
María José
 María José
Usuario experto

Hola, por fín conseguí actualizar a 1.6.1.23 , desinstalé el módulo de productos destacados lo volví a instalar y ya se ven fotos, pero apareció en la home algo nuevo, encima de el texto de PRODUCTOS DESTACADOS pone
POPULARES, adjunto captura, como quito eso?

ResponderCitar
Respondido : 06/04/2019 7:02 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

María José
 María José
Usuario experto

Vale solucionado, tengo tal cacao mental que ya no sé ni lo que hago, tan sencillo como desanclarlo,
gracias todo arreglado

ResponderCitar
Respondido : 06/04/2019 7:12 pm

Por favor Iniciar Sesión o Registro