Mal cálculo de los gastos de envío y de las tarifas del transporte.  

 
David
 David
Usuario experto

Hola, buenas a todos/as.

He estado buscando y leyendo hasta no encontrar nada que me pueda solucionar mi problema. Si de todas formas, la solución está en algún otro tema, reedirigir el hilo para cerrar éste, pero yo no he encontrado nada.

Les cuento.

Tengo una tienda apunto de entregar al cliente y sacar a la luz para que empiece a producir. Haciendo las pruebas, me he dado cuenta de que no hace correctamente los cálculos finales. El producto sí lleva bien aplicado su precio e impuesto "Total productos (IVA incluido)" (el que el cliente desea), y a continuación, se añade un nuevo gasto de envío, "Total gastos de envío IVA incluído:", que no se corresponde con lo que yo he configurado en "transportistas" y "zonas geográficas".

Les voy a adjuntar unas imágenes para que vean el resultado de la compra final, precio y peso transporte del producto, y también para que vean la configuración de "transportistas" y "zonas geográficas" y así pueda servirles mejor para la ayuda que necesito.

¡Muchísimas gracias de antemano y perdonen las molestias!

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 14/08/2015 2:41 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

A priori se ve todo bien. Veo que tienes creados varios métodos de envío, ya que en la página se pueden seleccionar diversos métodos. Tendrías que asegurarte que los precios que se ven en la configuración del método de envío realmente se corresponden con el método de envío seleccionado.

En una de las capturas de pantalla, donde asocias los métodos de envío disponibles para el producto, veo que parece haber 2 métodos de envío con el mismo nombre (uno sale en disponibles y otro en seleccionados). Tendrías que verificar que no hay confusión con los nombres.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/08/2015 4:14 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David
 David
Usuario experto

Hola, Pablo.

Gracias por tu inminente respuesta. Todo lo que me sugieres o aconsejas que mire bien, está correcto. Hago una compra expresamente para la zona de Provincia de Murcia, que, con un producto inferior o superior a 5 kg para el servicio ASM24, rondaría entre los 3 y 5 €uros de transporte, y no los 11, 12 o más €uros que me calcula.

He desactivado y desinstalado el módulo, lo he vuelto a instalar y configurar, pero sigue pasando igual. No encuentro el fallo.

¡Gracias!

ResponderCitar
Respondido : 14/08/2015 4:58 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Tal vez tenga que ver con la provincia has probado con otras provincias?, puedes marcar esta regla para que se aplique a todos, en tu captura de pantalla no consideres localización y aplica a cualquier localización y verifica si te sucede lo mismo

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/08/2015 6:15 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David
 David
Usuario experto

Hola, Jhon.

No entiendo bien lo que me dices de probar. ¿Podrías explicármelo de otra forma o con alguna captura?

¡Muchas gracias!

ResponderCitar
Respondido : 14/08/2015 6:26 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

HOla

Entiendo te sucede con todas las localizaciones que has definido.

Me refiero a que desmarques las condiciones específicas para las localizaciones y uses la opción de All o todos , a manera de preuba y verificar si te sucede lo mismo.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/08/2015 7:58 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

David
 David
Usuario experto

Hola, Jhon, nuevamente.

He hecho lo que me has dicho para uno de los dos servicios que doy para elegir. Te adjunto las imágenes para que veas lo que he hecho y el descuadre total. Sigue saliendo equivocado.

P.D: Decir, que con el servicio de mensajería por defecto, 5 €uros más gastos 8que tiene deejemplo, que se quedan en 6.05 €uros, sí sale todo correcto. Además, por las pruebas que estoy haciendo, veo como si hubiera confrontación entre el servicio por defecto y el que yo quiero implantar, porque me da a veces errores la compra, diciéndome por ejemplo, "que el transportista no trabaja en esta zona". El por defecto tiene marcado: Baleares, Canarias, Ceuta y Melila y la Peninsula.

¡Muchas gracias y perdón por la vara!

Esto es de locos.

ResponderCitar
Respondido : 14/08/2015 9:29 pm
David
 David
Usuario experto

Hola.

Actualizo la información después de varias pruebas más.

He vuelto a configurar nuevamente los transportes, pero como si fueran nuevos y no los que me da por defecto la empresa (así me lo explicaban). Vale, he hecho un ejemplo con el servicio 24 horas y el Económico con un sólo rango de peso y diferentes precios, para ambos servicios (pruebas). Ahora, todo lo hace correcto, salvo cuando llega al penúltimo paso (transporte), que se vuelven a modificar las tasas de envío, cambiando evidentemente el precio final. Se ponen unos precios como predefinidos, porque hasta que no elijo servicio y actualizo carrito, aparece 6.60 € o 15.40 €. Os adjunto en orden, tres imágenes para que vean los pasos y el error. Las imágenes llevan comentarios para que os sea de mayor ayuda.

Haciendo pruebas, parece como si la primera compra que hicieras, es la que luego ya tuviera de tasas fijas, fueran las zonas geográficas.
Acabo de hacer dos compras, la primera ha salido correcta hasta el final de los pasos y la siguiente ya se ha quedado en el paso que les he comentado. Algo se me escapa.

Espero que les sirva de ayuda y me puedan terminar de ayudar.
Muchas gracias y disculpen.

ResponderCitar
Respondido : 15/08/2015 2:12 pm

Cursos Gratuitos WordPress

David
 David
Usuario experto

Hola.

Encontré el error, que en realidad no era un error de la configuración que le había puesto ni del mecanismo del mismo. El error era de mi percepción, puesto al estar registrado para hacer las pruebas con una dirección correspondiente a la "Provincia de Murcia", daba igual la provincia que pusiera para ver que el cálculo lo hacía correctamente, cuando un paso después, yo le confirmaba el pedido (y se cambiaba automáticamente) para que me lo mandara a Murcia. Claro, normal y lógico. ¡Vaya cabeza!

He hecho la prueba con otros registros, haciéndome pasar por ciudadano de otras provincias y haciendo lo mismo, todo sale igual, es decir, correcto o incorrecto (cuando pruebo una comunidad diferente a la mía y después pongo que la lleven a la mía).

¡Muchas gracias y perdonen, de verdad!

ResponderCitar
Respondido : 16/08/2015 2:04 pm

Por favor Iniciar Sesión o Registro