Avisos
Vaciar todo

me da error al cambiar el contenido de los CMS  

 
Antonio
 Antonio
Usuario experto

Estoy traduciendo al inglés la página y al intentar cambiar las CMS no me deja y me da error de contenido inválido. Ni siquiera me deja corregir una letra. Sin embargo, en la página se muestra lo que hay escrito

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 18/11/2016 7:25 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Ese mensaje que te aparece veo que esta relacionado con el código html que tienes, posiblemente tienes un iframe dentro

https://www.webempresa.com/foro/41-Preguntas-sobre-PrestaShop/142834-Insertar-script-o-iframe-en-cms-prestashop-16.html

Prueba creando un nuevo artículo CMS y verifica si te sucede lo mismo colocando un texto de ejemplo.

Saludos.

ResponderCitar
Respondido : 18/11/2016 8:32 pm

Cursos Gratuitos WordPress

Antonio
 Antonio
Usuario experto

He intentado seguir las instrucciones que hay en los otros hilos del foro que me has indicado y la página web se me ha venido abajo. Os adjunto las modificaciones que he hecho yo en el archivo classes/Validate intentando hacer lo que decía en el otro post y las indicaciones que me han dado vuestros compañeros del área de cliente.
Ahora mismo he vuelto a subir el Validate original y la página web funciona, aunque sigo sin poder modificar el contenido de los CMS, no es que no me deja poner código HTML, es que ni siquiera me permite cambiar una letra en la traducción inglesa.

ResponderCitar
Respondido : 19/11/2016 4:54 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Antonio,

El código no se comenta así:

/*
...codigo
*/

Se comenta así:

/**
...código
*/

Saludos

ResponderCitar
Respondido : 20/11/2016 2:22 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Antonio
 Antonio
Usuario experto

¡Esto es lo que pasa cuando un agricultor se mete a informático!
En cualquier caso me limité ha hacer lo más parecido a lo que venía en el post que me indicabáis, y como ya no me fío un pelo de volver a meter la pata, os pido instrucciones más detalladas:
en ése mismo post (imagen comment out) habla de la línea 392; a mí esa cadena me aparece entre la 408 y la 417. ¿Me podríais confirmar que los códigos correctos para comentar los debo poner en la 407 (/**) y en la 418 (*/)?, en mi Validate aparecen unos símbolos {} que no aparecen en el post y ya no me quiero arriesgar a volverme a cargar la web

ResponderCitar
Respondido : 20/11/2016 7:03 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Antonio.

Si son esos los comentarios, Otra opción es que no incluyas los comentarios.

Los comentarios solo hacen referencia a lo que estas introduciendo y solo es información para la persona que esta programando informando de que se trata el bloque.

Simple mente elimina las lineas de los comentarios /* y */

Un saludo

ResponderCitar
Respondido : 20/11/2016 10:10 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación