Avisos
Vaciar todo

No puedo actualizar a PrestaShop 1.7.5  

 
jaime luis
 jaime luis
Estimable Member

Buenos días
Hace unos días que intento actualizar a PrestaShop 1.7.5 (tengo 1.7.4.4) y no hay manera, lo tenía actualizado al 1.7.5.0 pero más tarde he visto que me fallaban módulos y desde ahí no hay manera.
Ocurren varias cosas, primera vuelvo a un backup del 30 de noviembre donde tenia el 1.7.4.4 y después de actualizar no hay forma de entrar en el backoffice. ( adjunto primera captura de pantalla del final de la actualización a 1.7.5.0
Otro tema: instalada la 1.7.4.4 no puedo acceder a la pestaña de actualizaciones de los modulo, adjunto también captura de pantalla.
Si activo el modo debug no me abre nada, adjunto también captura de pantalla.
Se que son demasiadas cosas para un tema, pero es que no se como comenzar, he hecho pruebas incluso de instalar en local y actualizar y todo eso... pero no hay manera tampoco, cambio el archivo parameters, en la base de datos la url pero no hay forma...
Una ayudita porfavor, gracias!!!

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 16/02/2019 10:39 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Jaime.

Pueden ser varias cosas, dices que tenias problemas con modulos y puede ser que venga por esos módulos.

Revisando tu cuenta veo lo siguiente:

16-Feb-2019 08:28:12 Europe/Madrid] PHP Fatal error: Uncaught --> Smarty: 0():Missing '$template' parameter <--
thrown in /home/dkorando/public_html/regalospersonalizadosconfotos.com/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatebase.php on line 177

este error está documentado en prestashop y parece un bug de la version:
-> http://forge.prestashop.com/browse/BOOM-4826
-> https://github.com/PrestaShop/statsdata/pull/7

Antes de hacer nada prueba lo siguiente:
.- accede al módulo 1click
.- en el bloque " OPCIONES DE COPIA DE SEGURIDAD " selecciona la opción " NO " en " Back up my files and database " y " Back up my images "

Una vez eso prueba a realizar la actualización.

Un saludo

ResponderCitar
Respondido : 16/02/2019 12:02 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

jaime luis
 jaime luis
Estimable Member

Hola pepe... Gracias por tu respuesta!!!
Pues no se muy bien que hacer con lo que me has mandado. En cuanto a lo de la actualización a desactivar lo de la copia de seguridad ya lo hago siempre.

Gracias!!!

ResponderCitar
Respondido : 16/02/2019 1:23 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Jaime.

ok, pero la actualizacion segun comentas termina de hacerla bien lo que tienes son problemas con algunos módulos. ¿ los modulso son de prestashop o son de terceros ? ¿ qué módulos son los que tienes los problemas ?

Si tienes actualizaciones de extensiones, realiza primero la actualización de las extensiones y después la de prestashop.

Si ves sigues con el mismo problema después de revisar los pasos anteriores, por favor copia y pega el error que te indica ya que en la captura veo que es por SQL pero no se exactamente que error es ya que no puedo verlo ( Cosas de la Miopía 🙂 )

Un saludo

ResponderCitar
Respondido : 16/02/2019 1:41 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

jaime luis
 jaime luis
Estimable Member

Hola Pepe
hoy he intentado incluso restaurar una copia de octubre con el 1.7.4.3 y nada...eso después de seguir tus consejos.
Te adjunto varias capturas, errores y los mensajes que me salen cuando actualizo. Y otro tema, tengo otra web que se me actualizo al final, es mas sencilla, pero como le de a borrar cache, se queda en blanco.
Bueno te adjunto las capturas.
Muchísimas gracias

ResponderCitar
Respondido : 17/02/2019 2:06 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Esto que comentas:

hoy he intentado incluso restaurar una copia de octubre con el 1.7.4.3 y nada...eso después de seguir tus consejos

Entiendo que has recuperado base de datos y archivos del sitio ambos de la misma fecha.
Antes de actualizar asegúrate de que todo funcione correctamente, elimina la cache y los parámetros de optimización y verifica.

Luego intenta primero actualizar módulos y luego el core de PrestaShop y verifica. Verifica si tienes espacio suficiente en tu cuenta de hosting, ya que sino tienes espacios pueden haber problemas inesperados.

PD. Con respecto a tu otra web mejor no mezclar temas que al parecer es algo diferente.

Saludos.

ResponderCitar
Respondido : 17/02/2019 4:12 pm

Cursos Gratuitos WordPress

jaime luis
 jaime luis
Estimable Member

Buenos días
Ayer estuve haciendo lo que me proponías, y nada, al acceder de nuevo la página en blanco, espacio suficiente pues gasto solo el 50% del los 7GB, que hice al final?
añadí un subdominio, instalé prestashop de nuevo 1.7.5.0, y con un conector lleve la base de datos de productos y tal del que esta operativo al nuevo, y funciona todo perfectamente, el borrado de cache, las urls... todo perfecto, menos lo del principio antes de liarme y es que hay modulos para personalizar cada producto que no funcionan. Solo funciona cuando lo creas de nuevo, luego intentas editarlo y no ha tu tia.
Yo creo que es cosa de la novedad del seo que han puesto en la pestaña de los productos, te adjunto capturas.
Si un producto tiene el seo bien, como la primera captura, que indica la url del producto y tal... entonces si haces click en algún de los modulos de la pestaña del producto funciona, se abre el modulo y puedes configurar. Pero en cambio, si el tema del seo de ese producto esta como ejemplo, adjunto captura 2, entonces si le das al botón de cualquier modulo no se abre el modulo, pero te sale la ventanilla emergente de " configuración actualizada" o sea que no da ningún error....
la tercera captura es la de la pestaña de configuraciones.

Un saludo y gracias!!!

ResponderCitar
Respondido : 18/02/2019 10:35 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Si es posible que este relacionado con lo que comentas, y si desactivas o desinstalas esos módulos relacionados con los productos antes de actualizar te sucede lo mismo?

Esto que comentas no me queda claro:

con un conector lleve la base de datos de productos y tal del que esta operativo al nuevo

Entiendo que has llevado la BD anterior a la instalación que tienes, si es así, lo que has realizado de cambiar la BD podría ser riesgoso en algunas versiones, ya que no serían del todo compatibles los archivos en relación con la BD que tienes, algunas versiones pueden hacer cambios en la estructura de tablas de la BD que no tendrás integradas en tu caso y podrían dar errores inesperados.

Saludos.

ResponderCitar
Respondido : 18/02/2019 5:55 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

jaime luis
 jaime luis
Estimable Member

Hola, buenos días.
No lo he solucionado, supongo que el error venía o viene de atrás. Después de hacer de todo, instalar en local...y yo que se cuantas cosas he hecho, ayer en uno de mis intentos con otro prestashop que tengo 1.7.4... lo iba a instalar en el servidor para hacer pruebas y al bajarme de prestashop la última versión veo que han sacado la 1.7.5.1 y la instalé como nueva en vez de copiar la vieja, luego instalé el tema que uso, y machaque sin borrar la base de datos con la de la tienda en cuestión... y perfectamente, todos los botones que daban error funcionaban perfectamente.
Me dispongo a hacer lo mismo pero con la tienda importante, y perfecto, luego solo tuve que copiar las carpetas de imágenes, módulos, temes, y uploads, y todo a la perfección, todo funciona perfectamente.
He esperado a que se haga el superbackup, y esta mañana he trasladado los archivos de la prueba en 1.7.5.1 a la carpeta de la antigua instalación y enlazado la base de datos y ni un fallo en nada....
O sea, que solucionado no, pero para mi si.
Creo que fue Pepe que me dijo que si era la misma versión de prestashop seguramente las BD serían compatibles y en eso me esperanzé...
Ahora lo que no sabremos es si se iba a arreglar cuando saliese el update a la 1.7.5.1
MUCHISIMAS GRACIAS por vuestras respuestas
Y si puedo aclarar algo me lo decís

Saludosssss

ResponderCitar
Respondido : 19/02/2019 8:54 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Jaime.

O sea, que solucionado no, pero para mi si.
perfecto, si ves que todo carga bien y no tienes problemas pues solucionado.

Creo que fue Pepe que me dijo que si era la misma versión de prestashop seguramente las BD serían compatibles

En principio para las tablas por defecto de prestashop, si son de la misma rama 1.7 sí que son iguales, no cambian. Cambian las tablas de la versión de ramas distintas, es decir por ejemplo de 1.6 a 1.7, por eso no se puede actualizar de 1.6 a 1.7

Cuando restauras tienes que tener en cuenta que hay que restaurar tanto la Base de datos como los archivos y los dos tiene que ser de la misma fecha, piensa que en las tablas se almacenan los datos de usuarios, pedidos, etc... y si no se restaura con al misma fecha de los archivos, es posible que surtan problemas ya que los datos de uno y otro son distintos.

lo que no sabremos es si se iba a arreglar cuando saliese el update a la 1.7.5.1
Si se soluciono con la descarga que realizaste 1.7.5.1, cuando actualices se tiene que solucionar.

Puedes actualizarlo a mano como comentaste al principio , descargando los archivos y sustituyendo por los que tienes de la version anterior.

Un saludo

ResponderCitar
Respondido : 19/02/2019 1:14 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

jaime luis
 jaime luis
Estimable Member

Hola Pepe
Ya cuando recuperaba un backup lo hacia tanto del public como de la bd del mismo día, pero no había manera y con 1.7.4... las tablas tampoco.
Ya no tengo que actualizar nada, en los dos prestashops que tengo he hecho lo mismo. Instalarlo de cero, instalar luego el theme que uso, y luego machacar sin borrar la BD nueva con la anterior ( ambas 1.7...) cuando salga la actualización yo no lo veré... tengo ya la 1.7.5.1 !!! jejeje
Que locura, incluso he probado woocommerce por si tenia que empezar y no me ha gustado... soy de los que ha de ir bien y hasta que no lo consigo no paro..
Muchas gracias

ResponderCitar
Respondido : 19/02/2019 1:34 pm