Avisos
Vaciar todo

Nuevo grupo de tiendas para multitienda  

Página 1 / 2
 
Mario
 Mario
Estimable Member

Buenos días,

He creado un nuevo grupo de tiendas en nuestra multitienda, pero al introducir la URL me redirige a la tienda principal si lo escribo sin www y un error HTTP 500 si lo escribo con las www. ¿Qué puedo estar haciendo mal? Adjunto captura de la configuración en la multitienda. Muchas gracias por adelantado.

Un saludo,
David Redondo

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 19/04/2017 10:52 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Entiendo que la web Contenido solo visible a usuarios registrados es la nueva multitienda.

Si no usas grupos te funciona correctamente?

Saludos.

ResponderCitar
Respondido : 19/04/2017 7:19 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Mario
 Mario
Estimable Member

Hola Jhon,

Si, las demás web que tenemos en la multitienda funcionan correctamente, no he probado a añadirla sin grupo ya que es una tienda independiente y no nos interesa compartir nada. El dominio está en un servidor externo pero ya cambié las DNS a las de webempresa y el dominio lo añadí en la parte de Alias. No sé si hay algo que puedas haber hecho mal.

Un saludo,
David Redondo

ResponderCitar
Respondido : 19/04/2017 7:52 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Si no te interesa compartir nada tal vez te convenga mejor hacer un sitio web independiente.
Si aún quieres mantenerlo como multitienda, prueba realizar el proceso de configuración nuevamente, antes elimina toda la configuración en tu PrestaShop y en tu cuenta y configura nuevamente.

Saludos.

ResponderCitar
Respondido : 19/04/2017 11:05 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Mario
 Mario
Estimable Member

Hola,

He probado a hacerlo todo de nuevo y da el mismo error. Nos interesa hacerlo en esa instalación porque lo tenemos conectado el Prestashop con un ERP. ¿Qué podemos hacer para solucionar el error? Muchas gracias.

Un saludo,
David Redondo

ResponderCitar
Respondido : 20/04/2017 10:27 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Mario.

El error 500 o pagina en blanco generalmente cuando sucede suele ser porque hay algún fallo en la programación, esto puede suceder si se realizo algún cambio en la plantilla del sitio web o si se instalo alguna extensión con algún bug.

Cada vez que se genera uno de estos errores, se genera un fichero error_log y se introduce una línea indicando el motivo del error, el fichero y línea donde se ha producido. Esto nos ayudara para ver donde se producen los errores que aparecen en la web.

Puedes localizarlo accediendo desde cPanel -> administrador de Archivo y despliega la carpeta public_html y edita el fichero error_log.

Adjúntanos los errores que te indica o nos adjuntas el fichero para que podamos revisarlo.

Un saludo

ResponderCitar
Respondido : 20/04/2017 12:50 pm

Cursos Gratuitos WordPress

Mario
 Mario
Estimable Member

Buenas tardes Pepe,

Disculpa la demora, te adjunto el archivo error_log.

He visto un error que es de un modulo externo pero no afecta a la nueva página. Voy a ponerme en contacto con el desarrollador para solucionarlo.

Muchas gracias.

Un saludo.

ResponderCitar
Respondido : 20/04/2017 7:43 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Prueba adjuntar nuevamente tu archivo porque no se adjuntó.

Saludos.

ResponderCitar
Respondido : 20/04/2017 11:03 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Mario
 Mario
Estimable Member

Buenos días,

Lo adjunto de nuevo a ver si esta vez hay suerte.

Un saludo.

ResponderCitar
Respondido : 21/04/2017 10:28 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

La mayoría son warnings, por ejemplo:

[20-Apr-2017 18:24:25 Europe/Madrid] PHP Warning: Invalid argument supplied for foreach() in /home/regalosm/public_html/modules/estimateddelivery/estimateddelivery.php on line 1597

prueba desactivando ese módulo: estimateddelivery y verifica, elimina el archivo error_log y verifica si se genera de nuevo.

Saludos.

ResponderCitar
Respondido : 21/04/2017 5:52 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Mario
 Mario
Estimable Member

Hola Jhon,

El módulo no influye en la página nueva. No se a que se debe el error, pero necesito ayuda urgente porque necesitamos empezar con la página ya 🙁

¿No puede ser que en vez de poner el dominio como alias se ponga como tengo los otros dominios de la multitienda? Gracias.

Un saludo.

ResponderCitar
Respondido : 21/04/2017 6:07 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Algo que puedes probar para ver si es un problema con el dominio es agregar el dominio como dominio adicional, pero apuntandolo a una nueva carpeta, coloca un archivo o instala un sitio en este dominio y verifica si el dominio de manera totalmente independiente funciona correctamente.

Saludos.

ResponderCitar
Respondido : 21/04/2017 10:19 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Mario
 Mario
Estimable Member

Buenos días,

He creado una carpeta dentro de public_html y he apuntado la dirección del dominio a esa carpeta. Dentro he creado un index.php con Hola Mundo y carga perfectamente. ¿Cómo podemos proceder ahora? No podemos crearlo con un Prestashop independiente porque tiene que conectar con el ERP Odoo que ya tenemos conectado con las otras tiendas de la multitienda.

Muchas gracias.

Un saludo.

ResponderCitar
Respondido : 24/04/2017 10:40 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Mario.

Déjalo como estaba todo en un principio con la URL normal y lo revisaremos.
Por cierto ?¿ tienes algunas redireeciones en el archivo htaccess de tu instalación ?
revisa que no tengas direccionamientos para que te cargue con las www o sin la www

un saludo

ResponderCitar
Respondido : 24/04/2017 3:22 pm

Cursos Gratuitos WordPress

Mario
 Mario
Estimable Member

Hola Pepe,

Lo he dejado todo como estaba, he vuelto a crear el dominio de complemento, el grupo de tiendas y la tienda, he probado esta vez a importar algunas cosas de una de las otras tiendas pero sigue sin cargar bien. Del Htaccess no se ha tocado nada. Siempre hemos tenido problemas con las otras tiendas con el asunto de las www o sin www y hemos tenido que crear una redirección para ese caso. Gracias de nuevo.

Un saludo.

ResponderCitar
Respondido : 24/04/2017 6:35 pm
Página 1 / 2