palabras con acento  

Página 1 / 2
 
Daniel
 Daniel
Estimable Member

Hola.
Tengo problemas cada vez que meto algo de testo en un archivo tpl y utilizo los acentos me sale el signo ?
Que puedo hacer.

Saludos.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 30/01/2015 5:59 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

A que texto te refieres, lo correcto sería usar un texto para traducción

Revisa :
https://www.prestashop.com/forums/topic/178891-solucionadocrear-una-constante-de-idioma/

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 30/01/2015 8:10 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Daniel
 Daniel
Estimable Member

Hola.
Estoy reescribiendo en el blocktopmenu.tpl que viene por defecto, y al meter las categorías con acento no me las detecta me sale el signo de ?.

  • Ácidos grasos
  • ResponderCitar
    Respondido : 31/01/2015 11:40 am
    Pepe
     Pepe
    Soporte CMS Webempresa Admin

    Hola Daniel.
    Probaste a realizar las traducciones desde la administración de prestashop "Localización => Traducción de Mensajes"
    Revisa lo siguiente:
    https://www.webempresa.com/blog/item/1505-cambiar-traduccion-de-mensajes-de-texto-en-prestashop.html

    Una cosa más, La tienda es multi idioma?

    Un saludo

    Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
    Enviar Testimonio
    ¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
    Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
    ¡Gracias!.

    ResponderCitar
    Respondido : 31/01/2015 3:17 pm

    wpdoctor-revisa-la-salud-de-tu-wordpress

    Daniel
     Daniel
    Estimable Member

    No me explico bien. He modificado el tpl del top menu para ponerlo a mi gusto entonces mi archivo tpl empieza tal y como os lo muestro a continuación y se ve como no sale los acentos.

    Respondido : 11/02/2015 1:48 pm
    Lorena
     Lorena
    Miembro Moderator

    Hola Daniel,

    ¿Con qué editor estás modificando el fichero? ¿Qué codificación estás utilizando?

    Te recomiendo que lo modifiques utilizando el editor del Administrador de archivos de tu cPanel o un editor como Notepad ++

    https://www.webempresa.com/blog/administrador-de-archivos-de-cpanel.html

    Un saludo.

    Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
    Enviar Testimonio
    ¡Gracias!.

    ResponderCitar
    Respondido : 11/02/2015 2:07 pm

    Cursos Gratuitos WordPress

    Daniel
     Daniel
    Estimable Member

    Utilizo Notepad.

    ResponderCitar
    Respondido : 11/02/2015 5:45 pm
    Daniel
     Daniel
    Estimable Member

    Alguien que me pueda ayudar, no se si es por el hecho de modificar el tpl, creo que no.

    ResponderCitar
    Respondido : 11/02/2015 7:44 pm

    optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

    Jhon Marreros Guzman
     Jhon Marreros Guzman
    Soporte CMS Webempresa Moderator

    Hola

    Es posible qeu el archivo .tpl no te soporte ciertos caracteres, por lo que deberás colocarlo sin tildes ni caracteres especiales

    Luego la traducción lo harás con una constante de texto:
    www.prestashop.com/forums/topic/178891-solucionadocrear-una-constante-de-idioma/

    Saludos.

    Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
    Enviar mi Testimonio
    ¡Gracias!.

    ResponderCitar
    Respondido : 11/02/2015 8:49 pm
    Daniel
     Daniel
    Estimable Member

    He hecho lo que me has comentado y ahora el problema que tengo que cuando voy a traducciones de los módulos y voy a traducir la palabra que sale el recuadro en rojo no se porque me sale lo siguiente
    Usted no tiene permiso para acceder a /adminwe/index.php en este servidor.
    Además, se encontró un error 404 Not Found al intentar utilizar un ErrorDocument para manejar la petición .

    ResponderCitar
    Respondido : 21/02/2015 2:08 pm

    Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

    Luis Mendez Alejo
     Luis Mendez Alejo
    Miembro Admin

    Hola Daniel,

    ¿La url desde la que accedes al back office es la misma que la que tienes declarada en SEO y URLs en "Preferencias?

    Saludos

    Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
    Enviar Testimonio
    ¡Gracias!.

    ResponderCitar
    Respondido : 22/02/2015 2:59 am
    Enrique
     Enrique
    Usuario activo

    Buenos días,

    En HTML hay una serie de caracteres que tenemos que tratarlos de una forma especial. Uno de ellos son los acentos. Para que nuestro explorador pueda interpretar dicho acento, tienes que seguir unas directrices que te pongo a continuación:
    minúscula con acento á á
    á a minúscula con acento á
    é e minúscula con acento é
    í i minúscula con acento í
    ó o minúscula con acento ó
    ú u minúscula con acento ú

    Espero que le sea de ayuda.

    Reciba un cordial saludo

    ResponderCitar
    Respondido : 23/02/2015 11:13 am

    wpdoctor-revisa-la-salud-de-tu-wordpress

    Jhon Marreros Guzman
     Jhon Marreros Guzman
    Soporte CMS Webempresa Moderator

    Hola

    Es extraño que te aprezca el error que comentas, si sólo tendrás un idioma puedes probar lo que te comentó Enrique, aunque al parecer al posterar el foro conviritió los caracteres, lo que quiso decir es poner los caracteres en código html

    Revisa :
    http://ascii.cl/es/codigos-html.htm

    Verás una columna que dice HTML numero, ubica el caracter y usa este HTML número para escribir tus caracteres directamente en el archivo .tpl como parte de tu código

    Saludos.

    Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
    Enviar mi Testimonio
    ¡Gracias!.

    ResponderCitar
    Respondido : 23/02/2015 4:09 pm
    Julen
     Julen
    Miembro Admin

    Hola,

    Posiblemente no se muestren los caracteres correctamente debido a que la codificación no a sido asignada. Prueba a editar el archivo .tpl mediante el bloc de notas, a la hora de guardar los cambios recuerde usar la codificación UTF-8

    Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
    Enviar Testimonio
    ¡Gracias!.

    ResponderCitar
    Respondido : 23/02/2015 4:20 pm

    Cursos Gratuitos WordPress

    Daniel
     Daniel
    Estimable Member

    Mil Gracias a todos, ya lo he resuelto.

    ResponderCitar
    Respondido : 23/02/2015 9:06 pm
    Página 1 / 2

    Por favor Iniciar Sesión o Registro