prestashop 1.7.3 y bootstrap  

 
Jose Luis
 Jose Luis
Usuario activo

En mi antigua tienda prestashop 1.6 habia creado un pequeño navegador grafico de categorias, utilizando para ello el llamado gancho home beautystudio.es/tienda, donde el codigo html que contiene funciona bien. con sus correspondientes clases bootstrap (por ejemplo <img class="img-responsive)
Ahora estoy intentando actualizar "a mano" a la version 1.7.3 (alojada en un subdominio del mismo dominio) y me encuento con que si utilizo el modulo "bloques de texto personalizado" incluyendo en el, html funciona, puedo incluir imagenes enlaces etc, pero sin embargo en dicho modulo no funcionan las clases botstrap.
Por poner un ejemplo en el modulo bloque de texto personalizado si puedo incluir imagenes, html, tablas etc, pero bootstrap no funciona o sea por ejemplo img-responsive no funciona.
ayudaaaa por favor. (llevo toda la tarde con este tema)
Utilizo tiny MCE editor aunque tambien he probado a escribir el codigo a mano.
en en enlace podeis verlo

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 14/03/2018 5:35 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

El theme Classic de Prestashop 1.7 no esta basado en boostrap, si quieres usar componentes o clases de boostratp tendrías que incluir los archivos .css y .js adicionales de manera manual.

Puedes descargar boostrap desde: https://getbootstrap.com/docs/4.0/getting-started/download/
Pueedes evaluar incluir estos archivos desde un CDN, ver opción BootstrapCDN en el enlace

Sin embargo para incluir estos archivos debes modificar tu theme, incluyéndolos como parte de la cabecera.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/03/2018 8:25 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jose Luis
 Jose Luis
Usuario activo

si, muchas gracias por tu respuesta.
efectivamente no habia reparado en eso.
de todas formas y espero que esto le sirva a alguien, en mi caso la solucion ha sido instalar el modulo super tiny MCE pro. (lo tenia instalado en mi version 1.6)
este modulo habilita el css bootstrap asi como un monton de cosas mas (fonts awersome, fuentes adicionales etc etc).
una vez instalado, ya dispones de todas las clases bootstrap para cualquier html de prestashop 1.7.3 (botones, tablas, etc etc).
lo unico que al habilitar el modulo y pasar la tienda a utilizar el css de bootstrap, veras que el tamaño de las fuentes se recuce mucho. (te asusustas un poco 🙁 )
esto se soluciona en el propio modulo creando la siguente regla css
html {font-size:1em}
con esto ya tenemos nuestra tienda 1.7.3 bootstrap.
un abrazo y gracias de nuevo

ResponderCitar
Respondido : 14/03/2018 9:05 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Que bueno que lo solucionaste.
Gracias por el aporte.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/03/2018 9:16 pm

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro