Avisos
Vaciar todo

redirección 301 con .htaccess  

 
Daniel
 Daniel
Estimable Member

Estoy intentando realizar una redireción 301 pero no hay forma.
quiero que esta url antigua:
http://www.sherrysport.es/index.php?page=shop.browse&category_id=7&option=com_virtuemart&Itemid=1

me redireccione a mi url principal:
http://www.sherrysport.es

Si me pueden ayudar.
Gracias.
Saludos.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 08/04/2014 1:52 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

En internet existen algunas herramientas para generar el código de las redirecciones para el htaccess. Prueba alguno para ver si te funciona. Te doy algunas opciones:

http://www.htaccessredirect.net/

http://www.rapidtables.com/web/tools/redirect-generator.htm

http://www.htaccessredirect.com/

ResponderCitar
Respondido : 08/04/2014 3:39 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Daniel
 Daniel
Estimable Member

Me sale el siguiente código.

# Permanent URL redirect - generated by www.rapidtables.com
Redirect 301 /index.php?page=shop.browse&category_id=7&option=com_virtuemart&Itemid=1 http://www.sherrysport.es/

No me funciona y con los otros igual. No se si estoy haciendo algo mal.

ResponderCitar
Respondido : 08/04/2014 6:49 pm
Daniel
 Daniel
Estimable Member

tengo esto en mi .htaccess

RewriteEngine on
RewriteCond %{HTTP_HOST} ^www.sherrysport.es$
RewriteRule . - [E=REWRITEBASE:/]
RewriteRule ^api/?(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L]
RewriteCond %{HTTP_HOST} ^www.sherrysport.es$ [NC]
RewriteCond %{QUERY_STRING} ^$
Redirect 301 /index.php?page=shop.browse&category_id=7&option=com_virtuemart&Itemid=1 http://www.sherrysport.es/

ResponderCitar
Respondido : 08/04/2014 7:31 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Daniel

El código de redirección debe ser el primero en ejecutase, deberás mover tu código al inicio del archivo

Saludos.

ResponderCitar
Respondido : 08/04/2014 8:34 pm
Daniel
 Daniel
Estimable Member

Lo he puesto así y nada no funciona. La cache no tendrá nada que ver no.

RewriteEngine on
Redirect 301 /index.php?page=shop.browse&category_id=7&option=com_virtuemart&Itemid=1 http://www.sherrysport.es/
RewriteCond %{HTTP_HOST} ^www.sherrysport.es$
RewriteRule . - [E=REWRITEBASE:/]
RewriteRule ^api/?(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L]
RewriteCond %{HTTP_HOST} ^www.sherrysport.es$ [NC]
RewriteCond %{QUERY_STRING} ^$

ResponderCitar
Respondido : 08/04/2014 8:53 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Daniel

Tal como te comente debe ir al incio de todo.

Saludos.

ResponderCitar
Respondido : 08/04/2014 10:37 pm
Daniel
 Daniel
Estimable Member

Lo he puesto al principio de todo y nada te lo adjunto para que lo veas

Redirect 301 /index.php?page=shop.browse&category_id=7&option=com_virtuemart&Itemid=1 http://www.sherrysport.es/
# ~~start~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again
# .htaccess automaticaly generated by PrestaShop e-commerce open-source solution
# http://www.prestashop.com - http://www.prestashop.com/forums

RewriteEngine on
RewriteCond %{HTTP_HOST} ^www.sherrysport.es$
RewriteRule . - [E=REWRITEBASE:/]
RewriteRule ^api/?(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L]
RewriteCond %{HTTP_HOST} ^www.sherrysport.es$ [NC]
RewriteCond %{QUERY_STRING} ^$

ResponderCitar
Respondido : 09/04/2014 11:43 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Prueba a realizar una redirección tal como se indica en el siguiente enlace para ver si te funciona:

http://stackoverflow.com/questions/10135702/301-redirect-from-url-with-query-string-to-new-domain-with-different-query-strin

ResponderCitar
Respondido : 09/04/2014 5:22 pm
Daniel
 Daniel
Estimable Member

Muchas gracias. lo he puesto como dice el post y ya sale correctamente. He tenido que desctivar la url canonical para evitar bucles.
Tendré problemas por desactivar el canonical.

ResponderCitar
Respondido : 09/04/2014 7:37 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Daniel

Si no tienes páginas repetidas no hay problema, sin embargo indícanos en que parte exacta desactivaste esto

Saludos.

ResponderCitar
Respondido : 09/04/2014 7:50 pm
Daniel
 Daniel
Estimable Member

Hola, en preferencias seo y url desactivar canonical.
Si la activo no me funciona.

el .htaccess lo he dejado igual.

como puedo saber si tengo páginas repetidas.

Saludos

ResponderCitar
Respondido : 09/04/2014 9:30 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Daniel

Entiendo que te refieres a la opcion de prestashop, te recomiendo siempre especificar bien o enviar una captura de pantalla.

Efectivamente tal como se comenta en la descripción de esta opcion en prestashop :
Redirigir automáticamente al enlace principal (cononical URL) : "Esta opción es recomendada, pero el tema debe ser compatible"

Cuando tienes varias urls iguales deberás indicar a google específicamente a través de una etiqueta html meta cual url usar

Usualmente sabras que urls tienes repetidas cuando google indexe tu sitio web y desde las herramentas de webmaster podrás ver los avisos

Sin embargo es extraño que te cause un problema por la redirección veo que la redirección redirecciona desde virtuemart a una tienda en prestashop, sería bueno que nos expliques mejor esto.

Saludos.

ResponderCitar
Respondido : 09/04/2014 11:08 pm
Daniel
 Daniel
Estimable Member

Hola.
Si me hace la redirección desde virtuemart que es una tienda anterior a prestashop, porque esa dirección de virtuemart es la que tenemos puesta en un anuncio de google google adwors y si cambiamos la url nos rechaza el anuncio.
Si quito la redirección me aparece la pagina de error 404 de prestashop, y si un cliente accede y ve eso no es muy bueno.

Por eso lo de hacer la redirección 301.

ResponderCitar
Respondido : 10/04/2014 12:02 pm

wpdoctor-revisa-la-salud-de-tu-wordpress