Avisos
Vaciar todo

Al hacer cambios en enlaces permanentes,dejan de funcionar todos los enlaces.  

 
carlos
 carlos
Estimable Member

Hola.
Estoy intentando cambiar los ajustes de "enlaces permanentes" para pasarlo de predeterminado, a nombre de entrada. El problema es que al hacerlo, pruebo los enlaces y me envían a una página de error, por alguna razón los enlaces no funcionan, y para que vuelvan a funcionar, tengo que poner los enlaces permanentes como predeterminado.
Y no sé si tendrá algo que ver, pero al intentar entrar en ajustes del plugin wp Super Cache me aparece este mensaje.
Permlink Structure Error
A custom url or permalink structure is required for this plugin to work correctly. Please go to the Permalinks Options Page to configure your permalinks.

Por ahí he leído algo del archivo htaccess, pero como no lo tengo claro, prefiero que me guieis un poco por aquí.¿Alguna idea de por qué me pasa eso? Muchas gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 06/03/2015 8:24 pm
Rafael
 Rafael
Miembro Moderator

¡Hola Carlos!

Para restablecer los enlaces permanentes por defectos deberás de ir a tu cuenta cPanel (midominio.com/cpanel) -> Archivos -> Administrador de archivos.

Allí, deberás de ir a la carpeta public_html y editar el archivo .htacess. Deberás de borrar todo el código por este:

# BEGIN WordPress

RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END WordPress

Corresponde a los enlaces por defectos de Wordpress. Una vez pegado, deberás de pulsar en salvar cambios. No obstante, revisa que no tengas ningún plugin de redirección o similar que pueda afectar a su página Web.

Siempre haz copia de seguridad del archivo por lo que pudiera pasar. Al igual, asegúrate que si los quieres colocar desde Wordpress > Ajustes > Enlaces permanentes, el archivo tenga permisos 644 (botón derecho sobre él > change permissions).

Si no sabes muy bien cómo usar el administrador de archivos, te recomendamos que visites:

https://www.webempresa.com/blog/administrador-de-archivos-de-cpanel.html

Saludos

ResponderCitar
Respondido : 06/03/2015 8:38 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

carlos
 carlos
Estimable Member

Hola Rafa, una cosa antes de tocar nada, he ido al archivo .htacess que me comentas, y allí hay como unas 68 líneas, las tengo que eliminar todas y pegar el código que me has dado tú? y otra cosa, ¿cómo hago la copia de seguridad del archivo? Gracias.

ResponderCitar
Respondido : 06/03/2015 8:47 pm
Rafael
 Rafael
Miembro Moderator

¡Hola Carlos!

Para realizar la copia de seguridad al archivo tan solo tienes que descargartelo desde la pestaña "descargar" por si tienes que volver a subirlo desde el propio Administrador de archivos. No obstante, aprovecho para comentarte que puedes hacer copia de todo tu sitio web con una aplicación llamada CPRemote desde cPanel.

Te recomiendo que visites este enlace:

https://www.webempresa.com/blog/copias-de-seguridad-desde-el-panel-de-hosting-cpanel.html

Una vez que hayas hecho copia del archivo o de la web, efectivamente tendrás que reemplazar esas 68 líneas eliminándola por lo que te he dado. No olvides de revisar los permisos para que luego pueda ser escrito desde enlaces permanentes de wordpress y así, activar las url amigables del sitio.

Saludos

ResponderCitar
Respondido : 06/03/2015 8:52 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

carlos
 carlos
Estimable Member

Acabo de hacer los cambios que me has comentado, pero sigo con el mismo problema. Aunque ahora ya puedo entrar a ajustes de wp Super Cache, pero me salen estos avisos:
Rewrite rules must be updated
The rewrite rules required by this plugin have changed or are missing. Scroll down the Advanced Settings page and click the Update Mod_Rewrite Rules button.

Notice: Mod_rewrite or Legacy caching enabled. Showing Advanced Settings Page by default.

Alguna idea?

ResponderCitar
Respondido : 06/03/2015 9:16 pm
Rafael
 Rafael
Miembro Moderator

¡Hola Carlos!

Acabo de revisar tu sitio web y veo que los enlaces permanentes ya funcionan. Prueba a entrar desde otro navegador o vaciando la caché del mismo.

¿Quieres algún tipo de enlace en especial?

El error te dice que vayas a la página Advance settings y hagas clic en el botón Update Mod_Rewrite Rules para actualizar desde el plugin los enlaces permanentes de su página.

Por lo que el error se encontraba en este plugin mencionado. Prueba a cambiarlo y si vuelve a fallar, tendrás que desactivarlo.

Saludos

ResponderCitar
Respondido : 06/03/2015 9:21 pm

Cursos Gratuitos WordPress

carlos
 carlos
Estimable Member

Hola, los enlaces ya funcionan. Además de seguir los pasos que me dijiste, he tenido que desactivar el plugin" google xml sitemaps" por que si lo activo, otra vez dejan de funcionar los enlaces. Tengo activado el plugin "wordpress Seo" de yoast, que creo que cumple la misma función que el otro, así que lo eliminaré y ya está. Podemos dar el tema por cerrado. Muchas gracias.

ResponderCitar
Respondido : 07/03/2015 5:28 pm