[Resuelto] "Deprecated" error tras el traslado de la web  

Página 1 / 2
 
Guillem
 Guillem
Usuario activo

Buenas a todos,

Siento de verás si he podido duplicar el tema pero no he encontrado ninguno que sea exactamente lo que me ha pasado.

Tenía la web en Webempresa con un hosting pequeño.

Tenía contratado otro hosting en Webempresa pero de mayor tamaño que contraté más recientemente. Se me ocurrió aprovechar el tamaño de ese hosting para meter ambas webs. Todo fue correctamente excepto cuando pocos días atras Google Search Console me dice que hay un error de redireccionamiento.  Cuando abro la web me sale este error en la cabecera, que copio y pego. El resto de la web se ve bien.

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; FeedBurnerFormWidget has a deprecated constructor in /home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-content/plugins/feedburner-form/control/widgets.php on line 3

Deprecated: Function create_function() is deprecated in /home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-content/plugins/feedburner-form/control/widgets.php on line 214

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; social_stickers_widget has a deprecated constructor in /home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-content/plugins/social-stickers/social-stickers.php on line 1790

Deprecated: Function create_function() is deprecated in /home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-content/plugins/social-stickers/social-stickers.php on line 25

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; WGGXML has a deprecated constructor in /home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-content/plugins/wangguard/wangguard-xml.php on line 51

Deprecated: has_cap was called with an argument that is deprecated since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-includes/functions.php on line 4997

Qué pensáis que pueda estar pasando? Habría alguna solución o me recomendáis volver a empezar con la web? 

Gracias de antemano!!

Citar
Respondido : 21/04/2020 7:54 pm
Karen Rios
 Karen Rios
Usuario Moderator

Hola Guillen,

Por lo que puedo ver en los mensajes, tienes problemas con algunos plugins. Desactiva los siguientes desde la opción de administración de plugin de tu wordpress

  • wangguard
  • feedburner-form
  • social-stickers

Prueba si al desactivar estos no te muestra el error

Saludos

 

ResponderCitar
Respondido : 21/04/2020 8:55 pm

Cursos Gratuitos WordPress

Guillem
 Guillem
Usuario activo

Buenas Karen, 

Lo he hecho y sigue habiendo problemas. La home de la web no carga ni ahora ni antes, que se me olvidó decirlo me dice que hay un problema de redireciones ("Load conos follow more than 20 redirections".

Copio y pego lo que me sale ahora: 

Deprecated: has_cap was called with an argument that is deprecated since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-includes/functions.php on line 4997

Gracias!!

ResponderCitar
Respondido : 22/04/2020 10:24 am
Guillem
 Guillem
Usuario activo

En el panel de admin salen más errores...

 

...called with an argument that is deprecated since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-includes/functions.php on line 4997

Deprecated: has_cap ha sido llamado con un argumento que está obsoleto desde la versión 2.0.0. El uso de niveles de usuario está obsoleto. Utiliza las capacidades en su lugar. in /home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-includes/functions.php on line 4997

Notice: Undefined variable: help in /home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-content/plugins/filebrowser/app/functions.php on line 16

Deprecated: add_contextual_help ha quedado obsoleto desde la versión 3.3.0. Utiliza get_current_screen()->add_help_tab() en su lugar. in /home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-includes/functions.php on line 4713

Warning: is_readable(): open_basedir restriction in effect. File(/home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-content/plugins/icon-fonts/icon-fonts.php/languages/icon-fonts-es_ES.mo) is not within the allowed path(s): (/home/simposi1:/home2/simposi1:/usr/lib/php:/usr/local/lib/php:/tmp:/opt/alt/php73) in /home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-includes/l10n.php on line 669

ResponderCitar
Respondido : 22/04/2020 10:28 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Guillem
 Guillem
Usuario activo

He quitado plugins "FileBrowser" e "Icon.Fonts" y ya no salen errores pero la home no carga. 

Esto es lo que dicen en los navegadores Chrome y Safari...


ResponderCitar
Respondido : 22/04/2020 10:31 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Guillem.

Tienes errores en varios plugins:

PHP Fatal error:  require(): Failed opening required 'ABSPATHWPINC/option.php' (include_path='.:/opt/alt/php73/usr/share/pear') 
in /home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-includes/functions.php
PHP Fatal error: Uncaught Error: Call to undefined function register_activation_hook()
in /home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-content/plugins/social-stickers/social-stickers.php:23 PHP Fatal error: Uncaught Error: Class 'WP_Widget' not found
in /home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-content/plugins/feedburner-form/control/widgets.php:3 PHP Fatal error: Uncaught Error: Call to undefined function add_action()
in /home/simposi1/public_html/xn--notariabegoanuez-hubd.es/wp-content/plugins/icon-fonts/icon-fonts.php:28

Estos errores hacen referencia a los plugins " social-stickers, feedburner-form e icon-fonts ", elimina los plugin o revisa si hay actualizaciones, si hay actualizaciones comprueba la última version de que fecha no sea un proyecto muerto y no se actualicen desde hace mucho tiempo.

 

Es posible que no poporte la version 7.3 de PHP que es la que tienes instalada, puedes probar a bajar de version:

-> https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

 

Un saludo

 

 

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 22/04/2020 12:58 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Guillem
 Guillem
Usuario activo

@pepesoler

Buenas Pepe,

Ya los he inactivo y borrado y ya no salen esos errores.

No obstante, la home de la web sigue sin cargarse aunque haya bajado a php 7.0.

Me sigue diciendo el problema de los redireccionamientos y esto es desde que hice un traslado de la web de un hosting que tenia a otro, siempre dentro de Webempresa...

Puede tener que ver con algo de los DNS??

Gracias!!

ResponderCitar
Respondido : 22/04/2020 1:09 pm
Karen Rios
 Karen Rios
Usuario Moderator

Hola Guillen,

Puedes probar desactivando todos los plugins, con esto puedes verificar si ademas de los que indica el código de error hay otro que te causa el conflicto.

Luego ver activando uno por uno hasta verificar cual es el que puede estar ocasionando el problema.

Saludos

ResponderCitar
Respondido : 22/04/2020 1:37 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Guillem
 Guillem
Usuario activo

@karenrios

Buenas Karen,

Ya lo hice. Los errores han dejado de aparecer pero la home sigue sin cargar. En mi post anterior ponía un par de capturas de los navegadores Safari y Chrome...

Sigue sin funcionar...

Gracias!

ResponderCitar
Respondido : 22/04/2020 6:08 pm
Karen Rios
 Karen Rios
Usuario Moderator

Hola Guillen,

¿Puedes decirnos la URL de tu sitio web que no carga? Para poder ver mas a detalle

También no logro ver las imágenes de tu post anterior, puedes subirlas de nuevo?

Saludos

ResponderCitar
Respondido : 22/04/2020 7:25 pm

Cursos Gratuitos WordPress

Guillem
 Guillem
Usuario activo

@karenrios

La web es esta: https://notariabegoñanuñez.es

Y pongo las imágenes:

 

Captura de pantalla 2020 04 22 a las 11.29.35
Captura de pantalla 2020 04 22 a las 11.29.25

 

Gracias!!

This post was modified hace 5 meses por Guillem
ResponderCitar
Respondido : 22/04/2020 7:28 pm
Karen Rios
 Karen Rios
Usuario Moderator

Hola Guillen,

Cuando intento entrar a tu cuenta aparece el dominio xn--notariabegoanuez-hubd.es

Puedes verificar las url asignadas dentro de tu sitio web para que este marcada como https://notariabegoñanuñez.es

De igual forma verifica dentro tu archivo .htaccess que tu antiguo dominio este re-diseccionando al nuevo para ello debe ir a

cpanel -> public_html en ella ingresas a la carpeta donde tienes los archivos de tu sitio web y ubica el archivo .htaccess

 

imagen

RewriteEngine On RewriteCond %{HTTP_HOST} ^viejodominio.com$ [OR] 
RewriteCond %{HTTP_HOST} ^www.viejodominio.com$
RewriteRule (.*)$ http://www.nuevodominio.com/$1 [R=301,L]

En este articulo puedes ver un poco mejor como funciona las re-direcciones -> https://www.webempresa.com/blog/redirecciona-urls-de-forma-correcta-usando-cpanel-y-htaccess.html

Saludos

ResponderCitar
Respondido : 22/04/2020 8:51 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Guillem
 Guillem
Usuario activo

@karenrios

Buenas Karen,

Me sale esto al final del .htaccess:

# END WordPress
RewriteCond %{HTTP_HOST} ^xn\-\-notariabegoanuez\-hubd\.es$ [OR]
RewriteCond %{HTTP_HOST} ^www\.xn\-\-notariabegoanuez\-hubd\.es$
RewriteRule ^/?$ "https\:\/\/notariabego\Ã\±anu\Ã\±ez\.es\/" [R=301,L]

Puedes ser un tema de eñes? El caso es que desde un principio webempresa me asigno ese dominio y me comentaron que no pasaba nada porque no salgan las eñes...

Gracias.

ResponderCitar
Respondido : 22/04/2020 9:14 pm
Guillem
 Guillem
Usuario activo

Buenas de nuevo,

He quitado todo eso en el .htaccess y ya funciona todo correctamente.

He hecho lo correcto? Quién o cuándo se ha alterado ese archivo??

Gracias!

ResponderCitar
Respondido : 22/04/2020 9:24 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@guillemjoesgmail-com

Hola Guillen,

Creo que si has hecho lo correcto, saber quién, cómo y cuándo se modificó desde el foro no es posible saberlo, dudo que a nivel servidor existan registros de ello aunque podrías consultarlo con soporte técnico mediante tickets desde tu área de cliente. 

Saludos.

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

ResponderCitar
Respondido : 22/04/2020 11:55 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro