Hosting WordPress Divi con Soporte en Español

"Desaparación" en web de las fotografías vinculadas a un producto  

 
Ramón
 Ramón
Usuario eminente

Buenas tardes,

A principios de agosto, cambiamos el tema de la página web. Recomendaban instalación limpia pero con más de 3000 productos en la página no era algo viable. También aprovechamos a pasar "Media Cleaner" para poder liberar espacio con las fotografías que ya no estaban asociadas a ningún producto.

Pero, la limpieza fue más intensa de lo que pensamos.

Muchos de los productos que aún seguían vigentes perdieron su foto. Sin embargo, la foto se encontraba en el servidor (entrando por FTP). Era como si se hubiera roto el enlace entre producto y foto. Las resubimos manualmente.

Hubo varios cientos de productos que no perdieron su fotografía. Sin embargo, hoy, las fotos de los productos que no se perdieron entonces, no se ven. Algunas han desaparecido del servidor pero otras sí que están aunque no se muestran como la imagen de producto.

Si a alguien le ha pasado algo parecido o sabe qué puede ser, agradecería respuesta. Quizás la manera de haber explicado el problema no sea la más correcta, preguntad vuestras dudas y miraré de responderos a ver si podemos llegar a solucionar el asunto (sin tener que resubirlas de nuevo manuamente).

Un saludo,

Ramon

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 03/09/2019 8:17 pm
Bulmaro
 Bulmaro
Miembro Moderator

Hola Ramón,

Por lo que veo las imágenes perdidas tienen una ruta de subida distinta a las que se muestran correctamente. Pareciera que primero o en algún momento fue Contenido solo visible a usuarios registrados

Si accedes al administrador de archivos desde el cPanel al directorio /public_html/raiz_de_web/uploads. Aparecen imágenes además de las carpetas de año y mes?

Saludos.

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

ResponderCitar
Respondido : 04/09/2019 3:30 am

Cursos Gratuitos WordPress

Ramón
 Ramón
Usuario eminente

Hola ArellanoB,

Sí, en uploads/año/mes aparecen fotografías. Algunas fotografías es como si se hubiera deslinkado del producto y, otras, simplemente, no están.

ResponderCitar
Respondido : 04/09/2019 12:19 pm
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Ramon.

¿ cuando pasó lo de la ultima perdida de datos ?
Lo que puedes realizar es restaurar la carpeta uploads a una fecha donde se mostraban todas la imagenes.

.- Accede a tu cuenta de cPanel -> Administrador de archivos -> wp-content y renombra la carpeta Uploads
.- Accede a tu cuenta de cPanel -> SuperBackup
.- Selecciona Restaurar fichero/archivo

.- Selecciona la Fecha y la Carpeta a restaurar.

Una vez termine, revisa si aparecen todos las imagenes, si ves que está todo correcto, elimina la carpeta Uploads que renombrar.

Si tienes el plugin " Media Cleaner " lo eliminas, una de las opciones del plugin es la eliminación de imágenes automáticamente transcurrido un tiempo.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 04/09/2019 2:17 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Ramón
 Ramón
Usuario eminente

Hola Pepe,

Ayer estuve hablando con el servicio técnico de Webempresa y me comentaron lo mismo que me has dicho. Sin embargo, por lo que vieron ellos, no se había roto el enlace sino que era como si no se hubiera subido jamás ninguna foto a esa producto (no salía foto rota, sino la imagen por defecto para cuando no hay foto).

Así que aunque pudiera recuperarlas con lo del Superbackup (ahora voy a ver si puedo hacerlo porque me ahorraría mucho tiempo en buscalas), tendría que hacer la "conexión" de manera manual.

Miro lo que me has dicho y os comento.

Por cierto, ya he quitado el plugin Media Cleaner.

Gracias!

ResponderCitar
Respondido : 04/09/2019 2:24 pm
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Ramón.

Ok, dejo la entrada en espera por si tienes que retomarlo.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 04/09/2019 2:47 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Ramon.

Disculpa, se me olvidó comentarlo antes.
.- Accede a Woocommerce y comprueba si tienes un aviso de actualización de la base de datos.

las últimas versiones de WooCommerce necesitan actualizar la Base de datos y se hace en segundo plano, es decir es el propio WooCommerce el que realiza la actualización pero no lo hace de golpe.

.- Si ves el aviso de que está actualizando la base de datos verás que tienes una opción en el mismo aviso de actualizarla manualmente.

Una vez realizada la actualización comprueba si se muestran las imágenes.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 04/09/2019 4:02 pm
Ramón
 Ramón
Usuario eminente

Hola Pepe,

Ya actualice las BBDD. Gracias.

En lugar de hacer lo del Superbackup, (por si acaso) lo que he hecho ha sido descargarme el backup de la página en el ordenador. En el del día 1 de setiembre ya no aparecen, aunque estaban..

Ahora me estoy bajando el backup de antes de utilizar el Media Cleaner. Con ello, supongo que ahí sí que seguirán las fotos y podré ir añadiéndolas manualmente.

Un saludo y muchas gracias de nuevo

ResponderCitar
Respondido : 04/09/2019 4:12 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ramón
 Ramón
Usuario eminente

Bueno, al final, tuve que volver a entrar todas las fotografías que faltaban manualmente, pero hoy por hoy, ya está solucionado.

Esperemos que no vuelva a ocurrir.

¡Gracias por todo!

ResponderCitar
Respondido : 12/09/2019 6:06 pm

Hosting WordPress Divi con Soporte en Español

Por favor Iniciar Sesión o Registro