Avisos
Vaciar todo

Hosting WordPress 70% dto Dominios promo

Duda sobre cambios / estilos de un tema hijo que no se aplican (o tardan en aplicarse)  

 
Álvaro
 Ãlvaro
Estimable Member

Hola, buenas.

Recientemente hemos hecho unos cambios de etiquetado para optimizar el SEO.

El último de ellos fue cambiar un H2 del título del bloque de comentarios en los artículos del blog (por ejemplo) que pone "Deja tu respuesta". El bloque de comentarios que aparece al final, que hay pasar el "Deja una respuesta", de H2 a H3, en este enlace por ejemplo del blog  https://galernaestudio.com/diseno-web-inbound-marketing/ ....

Así aparecía antes del cambio:

He modificado donde aparecía lo del h2 y h3 y he puesto un span.
 
Antes :
D5pQR0qUJvNYZsLH
Ahora después del cambio:
 
l20oLv5QHmEmiIVL
 
 
 
 
En el fichero style.css del child he añadido esta regla para que tuviera el mismo aspecto que antes:
 
image.png
 
 
Pero como me ha pasado ya en otra ocasión recientemente, no se aplica los nuevos estilos o cambios aplicados en el child, porque al cargar el fichero se sigue mostrando la versión anterior.
 
Si se pone en el navegador: https://galernaestudio.com/wp-content/themes/galerna-child/style.css puedes ver que la línea donde debe salir eso no aparece:
image.png
 
He accedido a la cuenta de Web Empresa, he borrado la caché y demás y no hay manera, no sé cómo refrescar ese fichero ya.
 
Lo único que se me ocurre es ponerle a fuego en el fichero comments.php el estilo que debe llevar, pero claro, prefiero que se haga como debe aplicarse.
Si no consigo solucionar lo de la caché tendré que poner cambiar esto :
 
<?php
comment_form(
array(
'title_reply_before' => '<span id="reply-title" class="comment-reply-title">',
'title_reply_after'  => '</span>',
)
);
?>
 
Por esto en el comments.php: 
 
<?php
comment_form(
array(
'title_reply_before' => '<span id="reply-title" class="comment-reply-title" style="font-size:24px;font-weight:700;color:#000000">',
'title_reply_after'  => '</span>',
)

 

Hasta he desactivado los plugins de WP Rocket y Varnish caché, pero nada.

 

¿Puedes ser la caché de servidor de Web Empresa?, ¿hay alguna razón por la que no se carguen ahora mismo esos estilos o la caché de Web Empresa tarda bastante tiempo en recargarse?

 

Un saludo.

 

 

 

Contenido solo visible a usuarios registrados

Citar
Respondido : 02/02/2024 10:20 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Álvaro.

Por favor adjunta una captura del texto que quieres modificar, si puedes una captura de lo que tendría que mostrarse y lo que se muestra.

¿Puedes ser la caché de servidor de Web Empresa?,

Yo me decantaría más por caché de navegador, puedes probarlo con el navegador en Privado:

-> https://support.google.com/chrome/answer/95464

 

Un Saludo

ResponderCitar
Respondido : 02/02/2024 11:47 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Álvaro
 Ãlvaro
Estimable Member

Hola @pepesoler

Creo que ya lo he resuelto.

Cualquier cosa, os comento.

Un saludo y gracias.

 

 

 

 

 

 

ResponderCitar
Respondido : 02/02/2024 10:34 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Álvaro, 

Enhorabuena lograste solucionarlo, es un placer para nosotros siempre poder ayudarte. 

Quedamos atentos como ha ido todo. 

Un Saludo 😊 

ResponderCitar
Respondido : 02/02/2024 11:14 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress