Avisos
Vaciar todo

Hosting WordPress 70% dto Dominios promo

[Resuelto] El buscador de productos me lleva siempre a página de 'No se encontraron resultados'  

 
Antonio Luis
 Antonio Luis
Nuevo usuario

Buenas, estoy usando el plugin Fibosearch de Woocommerce para las búsquedas de productos, cuando busco un producto y le doy a la opción 'MostrarTodos' me lleva siempre a la página de 'No se encontraron resultados'.

Probé a desactivarlo y usar el buscador normal por defecto pero al darle a 'Enter' para mostrar resultados me pasa igual, me lleva a la página de 'No se encontraron resultados'. Así que descarté que fuera del plugin.

Antes funcionaba perfectamente y hace poco actualizamos a PHP 8.1.10, Wordpress 6.1.1 y Woocommerce 7.2.0.

He actualizado, activado y desactivado algunos plugins a ver, pero nada, sigue igual.

No se si sabéis donde puede estar el problema, gracias.

Contenido solo visible a usuarios registrados

Respondido : 15/12/2022 2:54 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Antonio, 

En este caso probemos lo siguiente, ingresa al apartado de Ajustes → enlaces permanentes y sin realizar ningún cambio pulsa en el botón guardar cambios. 

Luego comprueba si al realizar las búsquedas no muestra este error.

Verifica esto y nos comentas como ha ido todo

Un Saludo 

Respondido : 15/12/2022 2:58 pm

Cursos Gratuitos WordPress

Antonio Luis
 Antonio Luis
Nuevo usuario

Muchas gracias por la respuesta, pero seguí esos pasos y sigue igual, no he probado a cambiar nada de ahí por si acaso.

No se si se os ocurre alguna otra idea.

Respondido : 15/12/2022 6:59 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Antonio,

Has verificado desactivar todos los complementos (plugins) y dejar únicamente activo el plugin del buscador? verifgica si hay algún problema de compatibilidad entre otros complementos que tienes.

Revisa esta documentación de los desarrolladores del plugin:

-> https://fibosearch.com/documentation/troubleshooting/search-bar-is-not-responding/

 

Verifica y nos comentas.

Un saludo 🖐️ 

Esta publicación ha sido modificada el hace 1 año por Pepe
Respondido : 15/12/2022 7:33 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Antonio Luis
 Antonio Luis
Nuevo usuario

Bueno, os comento:

Tras cientos de chequeos y desactivar todos los plugins, fragmentos de códigos y demás sólo me quedaba cambiar de tema.

Al desactivar el Divi sí que me funcionó la búsqueda, pero es una opción no viable ya que me destroza la página por completo y es una página funcional y terminada, aunque nunca deja de estar en proceso de diseño como casi cualquier web.

No se si se os ocurre alguna idea más allá de recuperar una copia de seguridad, ya que no estoy seguro desde cuando empezó concretamente este fallo, imagino que sería a partir de una de las actualizaciones del tema. Aparte de la pérdida d emuchas horas de trabajo, claro. ¿Sabéis si hay a corto plazo previstas actualizaciones del tema Divi?. Me parece haber leído, no recuerdo si en este foro, a otra persona con mi mismo problema pero tampoco se le ha dado solución. A ver si aquí tenemos más suerte. Gracias..

 

Respondido : 28/12/2022 6:02 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Antonio, 

En este caso puedes indicarnos que versión tienes actualmente instalado de Divi, entiendo se está generando el error con el plugin de fibosearch has probado algún otro plugin como:

https://fr.wordpress.org/plugins/add-search-to-menu/

https://fr.wordpress.org/plugins/advanced-woo-search/

Es posible que el error se esté generando con la versión del plugin tras la actualización, probemos descartar si el error está en el plugin probando alguno de estos y nos comentas como va todo

Un Saludo 

 

Respondido : 28/12/2022 6:46 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Antonio Luis
 Antonio Luis
Nuevo usuario

Creo que no me expliqué bien en el primer post, la búsqueda fallaba incluso sin Fibosearch.

 

SOLUCIONADO:

El problema me lo daba el editor de temas. Tenía personalizada la página de RESULTADO DE LA BÚSQUEDA. Por alguna razón me dejó de funcionar tras alguna actualización. La eliminé y la rediseñé y ahora sí que va.

A veces nos enfocamos en lo más complicado y se nos olvida revisar lo más elemental. Gracias a todos.

Respondido : 29/12/2022 12:08 pm
Pepe me gusta
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Antonio.

Genial !!! Me alegra que lo solucionaras, Gracias por informarnos y aporta la solución 😀 

Cualquier consulta que tengas no dudes en comunicarlo.

 

Un saludo

Respondido : 29/12/2022 12:14 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress