Avisos
Vaciar todo

error 500 al hacer compra  

 
Dionisio
 Dionisio
Usuario activo

Hola, hemos configurado la pasarela de pago de la web, y el servidor proyecta un error 500, que manda un aviso que anula el pedido, no vacía el carro, ni vaciía el stock. Cómo se podría eliminar éste error 500?
Muchas gracias.

Saludos,

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 22/10/2015 1:33 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

En primer lugar comprueba si en la raíz de tu sitio web tienes un archivo de nombre error_log. De ser así, edita el archivo y revisa su contenido para ver si muestra información sobre el error que se pueda estar produciendo.

¿Este error solo se produce tras configurar la nueva pasarela de pago? ¿Si se selecciona otro método de pago no da el error? De ser así, es posible que estés utilizando un plugin para la pasarela que no sea compatible con tu versión de WooCommerce.

Otra posibilidad es que hubiera un conflicto entre el tema que estás utilizando en tu WordPress y la versión de WooCommerce.

ResponderCitar
Respondido : 22/10/2015 3:01 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Dionisio
 Dionisio
Usuario activo

Hola Pablo:
Me comentan desde el servicio técnico de la pasarela de pago que confirme si el servidor tiene restricciones a la hora del ds-respond, ya que la transacción se hizo con éxito, pero al enviar la información al servidor parece que no la dejó entrar, por lo que puede tener algún tipo de restricción. Coméntame como podemos solucionarlo. Si hay que añadir algo en la línea 315 que aparece en el error que daba el archivo que comentas:
[22-Oct-2015 08:35:45 UTC] PHP Fatal error: Call to a member function get_items() on a non-object in /home/bellotad/public_html/wp-content/plugins/woocommerce/includes/wc-order-functions.php on line 315

ResponderCitar
Respondido : 27/10/2015 10:57 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

El error que indicas es del propio plugin WooCommerce y no del plugin de Redsys que estás usando en él.

Es posible que esto ocurra debido a que el plugin de Redsys está tratando de llamar a funciones WooCommerce que no son compatibles con la versión de WooCommerce que tienes actualmente, o a que no le está pasando los datos correctos. También podría tratarse de un bug de WooCommerce.

¿Qué plugin concreto de Redsys estás utilizando?

ResponderCitar
Respondido : 27/10/2015 1:33 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Dionisio
 Dionisio
Usuario activo

Hola Pablo,
El plugin de Redsys es el último que han sacado, la versión 2.8.2 (comentan desde redsys que se debe utilizar éste último) y el plugin de woocommerce es el 2.4.7.

Ya me comentas.

Muchas gracias por todo y saludos.

ResponderCitar
Respondido : 27/10/2015 1:38 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

La última versión disponible para WooCommerce es la 2.4.8. Previa copia de seguridad de tu web prueba a actualizar el plugin a esta versión y verifica si el problema continua.

De ser así, tendrías que ponerte en contacto con el soporte de Redsys indicando la incidencia. Tendrás que especificar que la notificación de Redsys genera un error en un archivo de WooCommerce, lo que puede ser indicativo de que tengan algún bug en el plugin.

ResponderCitar
Respondido : 27/10/2015 2:22 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Dionisio
 Dionisio
Usuario activo

OK Pablo actualizo y te confirmo.

Muchas gracias, saludos.

ResponderCitar
Respondido : 27/10/2015 2:35 pm
Dionisio
 Dionisio
Usuario activo

Hola Pablo, he actualizado woocommerce a 2.4.8....y sigue el mismo error....ya me comentas cómo lo podríamos solucionar.

Muchas gracias.

Saludos.

ResponderCitar
Respondido : 27/10/2015 3:35 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Has reportado este problema a redsys?, ya que como te comentó Pablo es posible que sea algún tipo de bug
Para descartar problema con algo en tu sitio puedes probar instalandolo en otro sitio web nuevo y verificar si te sucede lo mismo.

Saludos.

ResponderCitar
Respondido : 27/10/2015 5:25 pm
Dionisio
 Dionisio
Usuario activo

OK Jhon, ya he hablado con Redsys y están con ello. VOy a esperar a ver que solución ofrecen y os confirmo.

Muchas gracias por todo.

Saludos.

ResponderCitar
Respondido : 27/10/2015 6:10 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Dionisio
 Dionisio
Usuario activo

Hola Jhon, han pasado muchos días y desde Redsys, siguen sin saber que ocurre, y yo he intentado hacer lo que comentas, pasar la web a otro hosting y probarla, pero por las dos vías que suelo usar siempre, me da error,....puede ser que vuestro hosting en cuestión tenga unos mecanismos de seguridad muy elevados que estén causando este tipo de contratiempos? Porque Redsys usa su pasarela en muchas tiendas y la compra se llega a realizar, pero existe algún elemento (me comentan desde Redsys, que muy probablemente dentro del hosting) que deniega la DS_RESPOND al realizar la compra.

Saludos, Vicente.

ResponderCitar
Respondido : 02/11/2015 5:44 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Si has instalado otro sitio en tu misma cuenta y te ocurre lo mismo, podrías consultar esto a través de tickets para que verifiquen, desde foro no vemos detalles de tu cuenta.

Saludos.

ResponderCitar
Respondido : 02/11/2015 10:06 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Dionisio
 Dionisio
Usuario activo

OK, reporto un ticket

ResponderCitar
Respondido : 02/11/2015 10:16 pm