Avisos
Vaciar todo

No se muestran anuncios Adsense  

Página 1 / 2
 
Alfons
 Alfons
Usuario activo

Hola, 

Desde que he hecho la migración a webempresa me han dejado de aparecer los anuncios de Adsense en mi web. En todos los posts me salen huecos en blanco donde se supone que tiene que ir el anuncio pero no se ve nada. A veces aparece uno, pero todos los demás me salen en blanco. Es un problema, porque tenemos unas 4000 páginas visitadas al día y ingresos de 7 o 8 euros y desde que hemos hecho la migración solo tenemos 0,80 céntimos. 

Hable con soporte técnico de webempresa y me hizo hacer algunas comprobaciones de DNS y estaba todo correcto, así que no se que puede ser, pero me gustaría saber si me pueden ayudar. 

En soporte técnico me hicieron una captura de pantalla de unos posible errores que salían:

Refused to frame 'URL' because it violated the following content security policy directive: "frame-src cm.g.doubleclick.net googleads.g.doubleclick.net <URL> accounts.google.com

Espero vuestra ayuda para poder solventar este error,

Muchas gracias, 

  • Alfons

Contenido solo visible a usuarios registrados

Citar
Respondido : 12/10/2021 8:33 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Alfonso.

Prueba añadir las cabeceras de seguridad al archivo htaccess.

Tienes documentación en esta guia:

-> https://soporteforo.webempresa.eu/guia/como-anadir-las-cabeceras-content-security-policy-x-content-type-x-frame-xss-en-tu-htaccess/

 

Un saludo

ResponderCitar
Respondido : 12/10/2021 11:21 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alfons
 Alfons
Usuario activo

@pepesoler hola Pepe, gracias por contestar.

El código que tengo que poner en las cabeceras cuál es? Exactamente igual al que sale en el enlace que has enviado? 

Un saludo

ResponderCitar
Respondido : 12/10/2021 11:57 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Alfonso, 

Los códigos son los que encuentras en el articulo debajo del texto "Una vez pulsamos en “editar”, se abrirá el archivo donde tenemos que pegar nuestro código para las cabeceras."

Screenshot   2021 10 12T071411.571
## Cabecera X-Frame-Options para mejorar la seguridad

Header always append X-Frame-Options SAMEORIGIN

# Tell the browser to attempt the HTTPS version first

Header add Strict-Transport-Security "max-age=157680000"

## Cabecera X-XSS-Protection para evitar ataques XSS en IE y Chrome

Header set X-XSS-Protection "1; mode=block"

## Cabecera X-Content-Type-Options para evitar que se carguen hojas de estilo o scripts maliciosos

Header set X-Content-Type-Options "nosniff"

# Disable server signature

Header set ServerSignature "Off"

Header set ServerTokens "Prod"

# Control Cross-Domain Policies

Header set X-Permitted-Cross-Domain-Policies "master-only"

## Charset UTF-8

Header set Content-Type "text/html; charset=UTF-8"

Ten en cuenta lo que se menciona enel articulo sobre a cabecera para Content Security Policy

Screenshot   2021 10 12T071527.557

Verifica si con esto logras mostrar nuevamente los anuncios

Un Saludo 

ResponderCitar
Respondido : 12/10/2021 12:17 pm

Cursos Gratuitos WordPress

Alfons
 Alfons
Usuario activo

@karen hola Karen,

Mi duda es si tengo que poner todos los codigos o solo el de la última imagen? Es lo que no me queda claro.

Un saludo,

Alfons

ResponderCitar
Respondido : 12/10/2021 2:25 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Alfons,

Mientras mas codigos de estos agregues es mejor ya que te evitas problemas a futuro sin embargo si solo quieres agregar uno también puedes hacerlo, sin embargo ten en cuenta tener un respaldo siempre ya que estas tocando archivos delicados de tu sitio.

Un saludo 🖐️ 

ResponderCitar
Respondido : 12/10/2021 2:33 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alfons
 Alfons
Usuario activo

@argenis si, lo se, pero es que antes de pasar mi web a Webempresa funcionaba y claro ahora me encuentro que hay varias cosas que no me van, como muchas fotos que no se muestran (que ya me han dicho que es por que tienen caracteres extraños) y ahora tampoco me van los anuncios de Adsense, asi que claro, muy contento con el cambio no estoy de momento, estoy teniendo muchos problemas. Ahora intento hacer una copia de seguridad pero es que ya no se como hacerlo, estoy un poco desesperado ya la verdad.

Quería hacer una captura de pantalla pero veo que no se puede. El texto que me sale en el archivo que tengo que modificar es este:

# BEGIN rlrssslReallySimpleSSL rsssl_version[5.1.1]
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteCond %{REQUEST_URI} !^/\.well-known/acme-challenge/
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]
</IfModule>

# END rlrssslReallySimpleSSL
# BEGIN WordPress
# Las directivas (líneas) entre «BEGIN WordPress» y «END WordPress» son
# generadas dinámicamente y solo deberían ser modificadas mediante filtros de WordPress.
# Cualquier cambio en las directivas que hay entre esos marcadores serán sobrescritas.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

 

Donde pongo exactamente el código este que me dicen?

Saludos, 

Alfons

 

ResponderCitar
Respondido : 12/10/2021 2:42 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Alfons,

Agrega al final del todo luego del # END WordPress:

## Cabecera X-Frame-Options para mejorar la seguridad

Header always append X-Frame-Options SAMEORIGIN

# Tell the browser to attempt the HTTPS version first

Header add Strict-Transport-Security "max-age=157680000"

## Cabecera X-XSS-Protection para evitar ataques XSS en IE y Chrome

Header set X-XSS-Protection "1; mode=block"

## Cabecera X-Content-Type-Options para evitar que se carguen hojas de estilo o scripts maliciosos

Header set X-Content-Type-Options "nosniff"

# Disable server signature

Header set ServerSignature "Off"

Header set ServerTokens "Prod"

# Control Cross-Domain Policies

Header set X-Permitted-Cross-Domain-Policies "master-only"

## Charset UTF-8

Header set Content-Type "text/html; charset=UTF-8"

Únicamente esto para probar.

Un saludo 🖐️ 

ResponderCitar
Respondido : 12/10/2021 2:51 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Alfons
 Alfons
Usuario activo

@argenis Hola, ya he hecho las modificaciones que me han dicho:

# BEGIN rlrssslReallySimpleSSL rsssl_version[5.1.1]
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteCond %{REQUEST_URI} !^/\.well-known/acme-challenge/
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]
</IfModule>

# END rlrssslReallySimpleSSL
# BEGIN WordPress
# Las directivas (líneas) entre «BEGIN WordPress» y «END WordPress» son
# generadas dinámicamente y solo deberían ser modificadas mediante filtros de WordPress.
# Cualquier cambio en las directivas que hay entre esos marcadores serán sobrescritas.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress
## Cabecera X-Frame-Options para mejorar la seguridad

Header always append X-Frame-Options SAMEORIGIN

# Tell the browser to attempt the HTTPS version first

Header add Strict-Transport-Security "max-age=157680000"

## Cabecera X-XSS-Protection para evitar ataques XSS en IE y Chrome

Header set X-XSS-Protection "1; mode=block"

## Cabecera X-Content-Type-Options para evitar que se carguen hojas de estilo o scripts maliciosos

Header set X-Content-Type-Options "nosniff"

# Disable server signature

Header set ServerSignature "Off"

Header set ServerTokens "Prod"

# Control Cross-Domain Policies

Header set X-Permitted-Cross-Domain-Policies "master-only"

## Charset UTF-8

Header set Content-Type "text/html; charset=UTF-8"

 

Pero sigue pasando lo mismo, no me muestra los anuncios.

Alfons

ResponderCitar
Respondido : 12/10/2021 3:32 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola ALfons,

Desde nuestros dispositivos vemos que is esta solventado el problema, te comparto una captura:

image
image
image
image
image

Como puedes ver se muestran todas en el lateral del sitio, recuerda que si tienes algún adblock estas publicidades no se van a ver al menos que desactives dicho adblock en tu sitio.

Pero ya eso es configuracion de tu explorador, no del cms.

Un saludo 🖐️ 

ResponderCitar
Respondido : 12/10/2021 3:45 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alfons
 Alfons
Usuario activo

@argenis no pero estos no son, estos los tengo yo añadidos, quizás si sale uno, pero el de amazon, el de autoeurope y vueling son fijos.

Si miras ese post te aparece una cantidad de espacios en blanco que es en teoria donde van los anuncios. 

 

ResponderCitar
Respondido : 12/10/2021 3:48 pm
Alfons
 Alfons
Usuario activo

Es que no puedo añadir caputras de pantalla, pero como he dicho al principio, es en los posts que me aparecen un montón de espacios en blanco donde antes aparecian anuncios. Los anuncios desde que he hecho la migración a Webempresa han dejado de mostrarse. Me sale uno a veces en el lateral, pero nada más. Y antes generaba 7 o 8 euros al dia y ahora un dia con mucha suerte llega a 0,7 o 0,8€. Algo se ha modificado desde que hemos pasado a Webempresa i no se que puede ser.

ResponderCitar
Respondido : 12/10/2021 3:53 pm

Cursos Gratuitos WordPress

Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Alfons,

Para agregar las imagenes puedes copiarlas y pegarlas directamente aquí donde escribes, en este caso agrega el último código que se muestra en la guia:

## Cabecera Content Security Policy
Header always set Content-Security-Policy "upgrade-insecure-requests;"

Sin embargo antes de agregar este, crea una copia de seguridad de tu sitio, https://www.webempresa.com/blog/copias-de-seguridad-desde-el-panel-de-hosting-cpanel.html luego de esto si agregas este codigo al final del todo y nos comentas nuevamente, si es posible con las captura de donde debe ir para poder ir a la sección en especifico y validar.

Un saludo 🖐️ 

ResponderCitar
Respondido : 12/10/2021 3:59 pm
Alfons
 Alfons
Usuario activo

@argenis hola de nuevo,

He puesto esa linea al final del archivo y sigue pasando lo mismo. A ver si lo estoy poniendo en el archivo incorrecto.

image

Lo he puesto en el .htaccess pero tengo 3 con un nombre parecido. El texto que he añadido es el siguiente:

 

## Cabecera X-Frame-Options para mejorar la seguridad

Header always append X-Frame-Options SAMEORIGIN

# Tell the browser to attempt the HTTPS version first

Header add Strict-Transport-Security "max-age=157680000"

## Cabecera X-XSS-Protection para evitar ataques XSS en IE y Chrome

Header set X-XSS-Protection "1; mode=block"

## Cabecera X-Content-Type-Options para evitar que se carguen hojas de estilo o scripts maliciosos

Header set X-Content-Type-Options "nosniff"

# Disable server signature

Header set ServerSignature "Off"

Header set ServerTokens "Prod"

# Control Cross-Domain Policies

Header set X-Permitted-Cross-Domain-Policies "master-only"

## Charset UTF-8

Header set Content-Type "text/html; charset=UTF-8"

## Cabecera Content Security Policy
Header always set Content-Security-Policy "upgrade-insecure-requests;"

ResponderCitar
Respondido : 12/10/2021 4:34 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Alfons,

En este caso entonces verifica el cambiar lo que agregaste al final del todo:

Respondido por: @lamochilaenlaespaldagmail-com

## Cabecera Content Security Policy
Header always set Content-Security-Policy "upgrade-insecure-requests;"

y sustituyelo por el siguiente:

## Cabecera Content Security Policy 2
Content-Security-Policy: frame-ancestors 'self';

En caso de que no funcione tendrías que contactar con adsense ya que directamente en la consola de tu sitio no hay un error como se mostraba en un inicio:

Refused to frame 'URL' because it violated the following content security policy directive: "frame-src cm.g.doubleclick.net googleads.g.doubleclick.net <URL> accounts.google.com

Por lo que ya seria un tema a tratar con adsense.

Un saludo 🖐️ 

ResponderCitar
Respondido : 12/10/2021 4:50 pm
Página 1 / 2