Avisos
Vaciar todo

No se muestran anuncios Adsense  

Página 2 / 2
 
Alfons
 Alfons
Usuario activo

Hola, 

Desde que he hecho la migración a webempresa me han dejado de aparecer los anuncios de Adsense en mi web. En todos los posts me salen huecos en blanco donde se supone que tiene que ir el anuncio pero no se ve nada. A veces aparece uno, pero todos los demás me salen en blanco. Es un problema, porque tenemos unas 4000 páginas visitadas al día y ingresos de 7 o 8 euros y desde que hemos hecho la migración solo tenemos 0,80 céntimos. 

Hable con soporte técnico de webempresa y me hizo hacer algunas comprobaciones de DNS y estaba todo correcto, así que no se que puede ser, pero me gustaría saber si me pueden ayudar. 

En soporte técnico me hicieron una captura de pantalla de unos posible errores que salían:

Refused to frame 'URL' because it violated the following content security policy directive: "frame-src cm.g.doubleclick.net googleads.g.doubleclick.net <URL> accounts.google.com

Espero vuestra ayuda para poder solventar este error,

Muchas gracias, 

  • Alfons

Contenido solo visible a usuarios registrados

Citar
Respondido : 12/10/2021 8:33 am
Alfons
 Alfons
Usuario activo

@argenis Hola,

Si pongo este código último, cuando voy a abrir mi pagina me sale un Internal Server Error y no puedo acceder al blog. Así que no se si he escrito algo mal o no funciona.

Alfons

ResponderCitar
Respondido : 12/10/2021 5:05 pm

Cursos Gratuitos WordPress

Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Alfons,

En este caso eliminalo entonces y vuelve a colocar el que estaba previamente y como te comento verifica con soporte de adsense ya que no hay error ya en tu consola relacionado a las content security policy.

Un saludo 🖐️ 

ResponderCitar
Respondido : 12/10/2021 5:11 pm
Alfons
 Alfons
Usuario activo

Lo que me resulta muy extraño es que en la home si salen, y en algunos posts me sale un anuncio antes del primer parrafo, pero despues todos son huecos en blanco, como si estubiera el hueco para el anuncio, pero sin anuncio. Y no entiendo que ha podido pasar.

ResponderCitar
Respondido : 12/10/2021 5:11 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Alfonso, 

En este caso como te menciona Argenis vemos que las opciones están configuradas de forma correcta con las políticas de seguridad en tu cabecera, una opción que puedes verificar es si se ha modificado algo del código que añades para añadir AdSense en tu sitio web. 

Verifica esto y nos comentas como ha ido todo

Un Saludo 

ResponderCitar
Respondido : 12/10/2021 5:25 pm
Alfons
 Alfons
Usuario activo

@karen hola,

Ya he enviado un correo a google adsense a ver si me contestan. Pero por sorpresa, cuando he ido a escribir un post que tenía a medias, me ha salido esto:

image

Y no puedo hacer nada, he quitado todo lo que he añadido en el archivo .htacsess y ya me va perfecto. Entonces no se si vuelvo a tener los errores de content security policy porque no he modificado nada finalmente.

Saludos,

Alfons

ResponderCitar
Respondido : 12/10/2021 6:23 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Alfons,

Esto tiene que ver con otro error diferente, activa lo que habían ingresado en el htaccess y verifica agregar esto a tu archivo wp-config:

https://www.webempresa.com/blog/dashboard-wordpress-estilos-css-solucionalo.html

Sigue esta guia, o si lo deseas puedes seguir la guia primero para solventar el error de que no carguen los css y posterior a esto activa nuevamente los htaccess.

Un saludo 🖐️ 

ResponderCitar
Respondido : 12/10/2021 6:37 pm
Alfons
 Alfons
Usuario activo

@argenis hola,

Ya lo he probado, ahora se me ve bien, lo único que ahora en la Biblioteca de Medios no me aparece nada, se pasa más de 10 minutos cargando y no muestra nada. Estoy empezando a desesperarme, se arregla una cosa y se estropea otra. Yo ya no se que hacer pero esto no puede ser. Nunca un cambio de servidor me había costado tanto.

ResponderCitar
Respondido : 12/10/2021 7:58 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alfons
 Alfons
Usuario activo

Lo he vuelto a quitar, solo lo del archivo htaccess y vuelve a funcionar correctamente. Así que esto del archivo este no me acaba de ir muy bien

Saludos,

Alfons

ResponderCitar
Respondido : 12/10/2021 8:01 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Mantén el .htaccess sólo con el código que te crea WordPress para las urls amigables, el resto de código que agregues más bien esta que te restringe.

Con respecto a que no te aparecen los anuncios veo que se generan errores javascript en esta página por ejemplo:

Contenido solo visible a usuarios registrados

adsbygoogle.push() error: Only one AdSense head tag supported per page. The second tag is ignored.

Indica que es posible que el código de adsense se este tratando de insertar cuando ya existe.

Verifica la configuración de tu plugin, si usas plugins de cache y optimización prueba desactivarlos temporalmente.

Si sigues con problemas prueba incluso eliminar completamente el plugin y reinstalarlo nuevamente.

Saludos.

ResponderCitar
Respondido : 12/10/2021 8:54 pm

Cursos Gratuitos WordPress

Página 2 / 2