Avisos
Vaciar todo

Hosting WordPress 70% dto Dominios promo

[Resuelto] No se puede reproducir iframe de youtube  

 
Anna Betlem
 Anna Betlem
Nuevo usuario

Hola, 

He insertado un video de youtube (en la Home) en la home y muestra un error: "Este contenido está bloqueado. Para solucionar el problema, ponte en contacto con el propietario del sitio web."

El vídeo no está bloqueado. Lo he comprado y además he probado a insertarlo en otros sitios web y carga sin problema.

 

Gracias.

Contenido solo visible a usuarios registrados

Respondido : 24/04/2023 3:53 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Anna Betlem

Puedes indicarnos el video que quieres compartir y si puedes una URL donde lo tengas insertado para que podamos revisarlo ?

 

Un Saludo

 

Respondido : 24/04/2023 4:01 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Anna Betlem
 Anna Betlem
Nuevo usuario

Hola, 

Si, el vídeo es este: https://www.youtube.com/watch?v=DZG0h9SmZ4g

Y en la Home, en la parte de abajo puedes ver el fallo.

Respondido : 24/04/2023 4:36 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Anna, 

En este caso lo que puedo ver es que tienes una directiva en el header.php de tu tema que no permite añadir video en tu sitio web, esto parece aplicar para vimeo, pero puede que genere algun conflicto con Elementor

image

Para verificarlo ingresa a tu cuenta de hosting, administrador de archivos →  public_html, dentro de este ingresa a la carpeta donde tienes los archivos de tu sitio web y luego a la ruta wp-content/themes/tu_tema y edita el archivo header.php

Dentro de este archivo elimina la línea de código que indica

<meta http-equiv="Content-Security-Policy" content="frame-src  https://player.vimeo.com ;">

Y Guarda los cambios, verifica si con ello tus videos se reproducen de forma correcta

Un Saludo 

Respondido : 24/04/2023 6:09 pm
Anna Betlem me gusta

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Anna Betlem
 Anna Betlem
Nuevo usuario

Hola Karen,

Gracias por tu respuesta. Ya habíamos visto esta directiva y hemos probando a cambiarla y quitarla y no se soluciona el problema. La he quitado, por si quieres verificar que el error sigue ahí.

Un saludo

Respondido : 25/04/2023 8:40 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Anna Betlem.

Lo acabo de probar en una instalación nueva y veo que carga bien:

screenshot masquecms.es 2023.04.25 11 57 57

Creo que tienes la cabecera de seguridad añadida en el plugin Code Snippets, desactiva el plugin o desactiva el código de la cabecera de seguridad.

 

Un saludo

Respondido : 25/04/2023 11:32 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Anna Betlem
 Anna Betlem
Nuevo usuario

Hola Pepe,

He estado hablando con soporte de Elementor y me han comentado que el plugin de "Element Pack" para Elementor puede hacer que no funciona el widget predeterminado porque incluye uno más avanzado. He probado el widget del plugin y funciona; así que he decidido quitarlo y también he desactivado el código de cabecera que me indicas y ahora carga correctamente.

Así que sería una de las dos cosas o ambas. 

Muchas gracias. 

 

 

Respondido : 25/04/2023 12:41 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Anna Betlem

Lo bueno es que se soluciono 😀 

Cualquier consulta que tengas no dudes en comunicarlo.

 

Un Saludo

Respondido : 25/04/2023 12:44 pm
Anna Betlem me gusta

Cursos Gratuitos WordPress