Problema Código Analytics  

 
Jorge
 Jorge
Usuario eminente

Buenos días:

Tengo el siguiente código implementado en el functions.php para Google Analytics (Supuestamente siempre ha funcionado), pero al implementarlo, por no utilizar más Plug-In, me doy cuenta que no carga bién. Os dejo el código a ver si veis el error que tenga:


  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src="g;m.parentNode.insertBefore(a,m)"
  })(window,document,'script','https://www.webempresa.com/foro/wp-content/cache/busting/google-tracking/ga-46d5133aa597565448fb056c07bff769.js','ga');

  ga('create', 'UA-XXXXXXXXX-1', 'auto');
  ga('send', 'pageview');


  

Saludos !

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 21/02/2017 2:39 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Jorge.

En el código no veo que tengas añadido la ID que te proporciona Analytics.
Tienes que modificar ga('create', 'UA-XXXXXXXXX-1', 'auto'); por el ID de tu cuenta de Analytics

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 21/02/2017 3:18 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jorge
 Jorge
Usuario eminente

Las Xxxxx las puse yo, manías de quitar Id en público, el caso es que si entras en la web ahora mismo esta el código puesto pero no lo veo, por eso digo.

ResponderCitar
Respondido : 21/02/2017 3:21 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Podría ser por la versión de PHP, lo que sucede es que estas usando una declaración de una función anónima en tu código. Puedes cambiar tu código y evitar definir una función anónima.

La otra opción es cambiar a la versión de PHP 7, revisa:
https://www.webempresa.com/blog/version-php-cpanel-como-cambiarla.html

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/02/2017 5:44 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jorge
 Jorge
Usuario eminente

Pues no, active la versión PHP 7 en el Hosting y nada. Alguna otra idea de como poder incluirlo por código y que este lo rastree correctamente ?

Saludos y gracias !!!!

ResponderCitar
Respondido : 21/02/2017 6:01 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Observando más detenidamente tu código veo que hay algo raro, todo esta comentado, es decir
no hay cuando cierres comentario.

Quita todas las líneas que tienen /* , y verifica

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/02/2017 8:37 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jorge
 Jorge
Usuario eminente

Madre mía !!! Muchas gracias, es lo que tiene llevar tantas horas uno solo escribiendo... Vaya fallo, muchas gracias, ya funciona correctamente 😉

ResponderCitar
Respondido : 21/02/2017 8:42 pm

Por favor Iniciar Sesión o Registro