Problema con link  

 
Urko
 Urko
Usuario experto

Hola, llevo sufriendo este problema desde hace muchos meses, y he lo he dejado de lado por que siempre le he quitado importancia.

El caso es que tiene un tema de pago, y en el servicio técnico de dicho tema no han sabido solucionarme mi problema. El caso es que no se por que motivo, los links de uno de los widgets de mi web no funciona correctamente. Es el widget que lleva por título "Publicaciones Recientes", que consiste en mostrar las últimas 6 entradas con una imagen pequeña y el título de dicha entrada debajo. Ese widget, está dirigido por la paginación de debajo, la cual no funciona. Es igual en la página que pinches, que el widget no cambia y siempre muestra las últimas 6 entradas de forma permanente.

Pensé que quizás actualizando el tema se solucionaría el problema, pero hace unos días actualicé el tema con la última versión, y el problema sigue.

He visto otras web que usan el mismo tema y cuyo widget funciona correctamente

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 23/01/2016 10:37 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Urko,

¿Puedes marcar en una captura a que widget te refieres (frontal) porque no encuentro el widget "Publicaciones Recientes" por ninguna parte 🙂

Gracias

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/01/2016 1:38 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Urko
 Urko
Usuario experto

Claro, disculpa.

Te dejo la captura, y te pongo claramente que es lo que no funciona, que son los links de la paginación, el resto funciona bien, es decir, cuando pasas el ratón sobre una de las 6 noticias del widget y pinchas, te lleva a la noticia sin problemas. Lo que no funciona es que siempre se me presenta la primera página, y por mucho que pinche en los links de otras páginas, el link siempre me redirige a la primera:

ResponderCitar
Respondido : 24/01/2016 8:16 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Prueba desactivando el plugin de cookies que se encuentra en la parte inferior.

Haz probado a instalar solamente la plantilla en otro directorio de pruebas y revisar si solo falla dicha sección?

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/01/2016 4:21 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Urko
 Urko
Usuario experto

Si que he probado a probarlo en un directorio de prueba, y funciona sin problema, pero en mi web luego no. He probado a desinstalar el plugin de los cookies peo por lo que parece eso tampoco soluciona nada...

ResponderCitar
Respondido : 24/01/2016 6:00 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Si la web original funciona es posible que algun plugin este ocasionando conflictos. Prueba a desactivar uno a uno los widgets de la derecha y verifica si llega a funcionar.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/01/2016 6:17 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Urko
 Urko
Usuario experto

He ido desactivando uno a uno de los plugins, y nada... :unsure:

ResponderCitar
Respondido : 25/01/2016 8:37 am
Rafael
 Rafael
Miembro Moderator

Hola Urko,

He revisado tu caso y tengo la sospecha que el problema de la paginación está relacionado con este bug de WordPress reportado:

https://core.trac.wordpress.org/ticket/35344#comment:28

Te recomiendo hacer lo siguiente:

1º Ve a tu cPanel > Bloque Archivos > Administrador de Archivos

2º Pulsa en la carpeta wp-includes

3º Dentro de ella, busca el archivo canonical.php y botón derecho > Rename > y coloca canonical_old.php (para tener una copia por lo que pueda pasar)

4º Descarga a tu ordenador el zip que te adjunto y subelo dentro de wp-includes con el botón "Cargar"

5º Una vez subido el archivo zip, tan solo tienes que darle a botón derecho > Extract

Te generará el archivo canonical.php con el bug corregido según el hilo oficial que te facilité al principio.

Con ello, debería de funcionar sin problemas la paginación del frontal, no olvides de vaciar la caché de la página web y de tu navegador (ya que de lo contrario puedes visualizar una copia de tu web anterior al cambio).

Te será útil -> http://wiki.webempresa.com/Limpiar_la_cach%C3%A9_del_navegador

También revisa que todo el resto de tu página web sigue funcionando correctamente.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/01/2016 10:17 am

Cursos Gratuitos WordPress

Urko
 Urko
Usuario experto

Mil gracias Rafael!! Problema solucionado, me estaba volviendo loco!! Un millón de gracias :blush: :blush: :laugh: 😉

ResponderCitar
Respondido : 25/01/2016 4:23 pm

Por favor Iniciar Sesión o Registro