Avisos
Vaciar todo

Problemas con El script «wp-editor»  

 
Emilio
 Emilio
Usuario activo

Tengo el siguiente problema : 

La función wp_enqueue_script() ha sido llamada de forma incorrecta. El script «wp-editor» no debe ponerse en cola junto con el nuevo editor de widgets (wp-edit-widgets o wp-customize-widgets). Por favor, ve depuración en WordPress para más información. (Este mensaje fue añadido en la versión 5.8.0).

 

He leído que podía ser de la versión de php pero dudo que sea de eso, recientemente hemos cambiado el tema después de haber trasladado la web de un dominio a otro. Es un problema que me esta impidiendo progresar en la configuración del wordpress

Contenido solo visible a usuarios registrados

Citar
Respondido : 20/04/2023 7:30 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Emilio, 

En este caso puedes indicarnos cuando se muestra el error que nos comentas? de esta forma podemos verificar con mayor detalle lo que nos mencionas. 

De manera general veo tienes la versión 8.0 de PHP, la cual como mencionas es posible genere el error en este caso prueba bajarla a 7.4  y comprueba como funciona. Ten en cuenta que aun cuando ya salió la versión 8.1 muchos plugins o complementos no son compatibles a estas versiones de PHP y pueden generar algun conflicto.

Algo adicional que puedes probar es ver si tienes actualizaciones pendientes de plugin o tema, si es así actualizarlo y revisa como funciona el sitio web. 

Un Saludo

ResponderCitar
Respondido : 20/04/2023 8:42 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Emilio
 Emilio
Usuario activo

@karen  

El problema persiste después de haber bajado a la versión de php 7.4, 

El problema aparece en apariencia/widgets   ,  

 

ResponderCitar
Respondido : 21/04/2023 7:58 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Emilio.

El error suele venir por algún plugin.

Si puedes adjunta una captura del aviso para que podamos ver exactamente el aviso que te indica.

 

Puedes ir desactivando los plugins hasta encontrar el que te esta causando ese problema.

Revisa también que lo tengas todo actualizado.

 

Un Saludo

 

ResponderCitar
Respondido : 21/04/2023 9:44 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Emilio
 Emilio
Usuario activo

@pepes

Captura
Captura2

 

os facilito captura

ResponderCitar
Respondido : 21/04/2023 10:05 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Emilio.

La primera captura son unos errores del día 20 y a fecha de hoy ya no salen por lo que tiene que estar solucionado, el tema es que muestra lo que hay en el archivo error_log que tienes en la carpeta public_html -> Contenido solo visible a usuarios registrados -> wp-admin

Si vacías el contenido de esos dos archivos ya no tendría que mostrase ese aviso.

 

La segunda captura es un Aviso que no tiene que impedirte poder trabajar en la sección de Widget ¿ que problema tienes ? ¿ no puedes añadir algún Widget ?

 

Un saludo

 

 

 

 

ResponderCitar
Respondido : 21/04/2023 10:55 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Emilio
 Emilio
Usuario activo

He borrado el contenido de los archivos, sigue apareciendo un error

 

Captura

 

 

ResponderCitar
Respondido : 21/04/2023 11:19 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Emilio.

Ok, ese es el segundo aviso que te indique, lo que no me comentaste es si no puedes añadir Widgets o cual es el problema.

Ese aviso es por que algún complemento, plugins o la propia plantilla no es compatible con la nueva vista de Widgets de WordPress ( Bloques de Gutenberg )

Puedes utilizar el plugin Classic Widgets para volver a la vista clasica de los Widgets de WordPress:

-> https://es.wordpress.org/plugins/classic-widgets/

 

Un saludo

 

 

ResponderCitar
Respondido : 21/04/2023 11:59 am

Emilio
 Emilio
Usuario activo

Solucionado, ahora me ha surgido otro problema

Captura
ResponderCitar
Respondido : 21/04/2023 12:18 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Emilio.

Deprecated: ¡La función WC_Cart->tax_display_cart ha sido llamada con un argumento que está obsoleto desde la versión 4.4! 

Lo que te indica es que esta llamando a una función que esta obsoleta, es decir desde la version 4.4 esa funciona ya no se utiliza.

Lo mas seguro es que tengas una carpeta con el nombre woocommerce dentro de la carpeta de tu plantilla wp-content -> themes -> Tu_plantilla, si la tienes la renombras por ejemplo woocommerce_old

 

Un Saludo

 

 

ResponderCitar
Respondido : 21/04/2023 2:56 pm

Cursos Gratuitos WordPress