[Cerrado] Sin servicio tras actualizar el tema de DIVI  

 
Fernando
 Fernando
Usuario eminente

Muy buenas, 

Mi web está fuera de servicio tras actualizar el tema de DIVI. 

Llevo dos días tratando de resolver otros problemas. Indico las cuestiones que creo más importantes: 

- Hoy he actualizado el tema de DIVI. Después de esto mi web se ha ido al traste, y por otro lado, observo que la versión de PHP de mi web ha pasado de 7 y pico, a 5.6.40. Estoy absolutamente seguro de este cambio en la versión de PHP pues esta mañana lo comentaba con el soporte técnico de WPML. 

- Esta mañana también cambié, vía ticket, la API REST de Worpress (la habilité). Cosa curiosa, tras este fallo en mi web se visualiza la web pero puedo acceder a mi panel de control) vuelve a aparecer deshabilitada. 

- El motivo para cambiar la API REST y actualizar el tema de DIVI es porque hay un fallo que no consigo resolver, y es no puedo traducir mis nuevos productos Add-on de Woocommerce. En WPML string translation, solo me aparecen los add-on anteriores, no los nuevos. El soporte técnico de WPML me indicó que hiciera lo de la API Rest, que hice a través de un ticket. 

Por otro lado, indicar que no sé si hay algo raro en mis plugins. Llevaba bastante sin actualizar mi web, y recordaba que tenía un plugin de Divi y el tema de DIVI. Sin embargo, estos días he comprobado que no tenía el plugin de DIVI, solo un plugin desactivado DIVI Builder, que según las explicaciones en wordpress no se necesita cuando se tiene el tema, si recuerdo bien. ¿Esto es correcto, necesito solo el tema DIVI?

Finalmente, si estos problemas se resuelven, presupongo que seguiré sin poder traducir los productos Add-on. WPML me ha indicado que haga este test de compatibilidad: 

Could you try a compatibility test?
- backup your site
- disable all plugin except WooCommerce, WooCommerce Product Add-ons, WPML and its addons
- switch to a default theme like TwentySeventeen
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again
- lastly, reactivate your theme

¿Me recomiendáis hacer esto?

Por favor, ¿qué pasa, y qué hago? 

Muchas gracias, 

Fernando 

Respondido : 07/02/2020 4:31 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Fernando.

El constructor divi hace falta para poder trabajar con plantillas DIVI, es necesario

Lo que tienes que hacer es restaurar la web, paar tenerla activa lo mas pronto posible.

Tienes una guia en este enlace:

-> https://guias.webempresa.com/preguntas-frecuentes/gestionar-copias-de-seguridad-con-superbackup-en-cpanel/

Una vez restaurada la web, lo indicas y vemos todo lo que dices de los plugins.

 

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

Respondido : 07/02/2020 5:16 pm
Fernando me gusta

Cursos Gratuitos WordPress

Fernando
 Fernando
Usuario eminente

@pepesoler

Gracias Pepe. Web restaurada. 

¿Vemos lo de los plugins? 

Comentar mis problemas: 

1) No puedo traducir los "add-ons" de los productos de Woocommerce porque en WPML string translations, las wp_products_addons_strings no se actualizan. Aparecen los add-ons antiguos, que ya no uso. 

2) Al parecer, no puedo actualizar el tema DIVI. Lo hice antes y perdí la web, cambió la versión de PHP, y la REST API (que pasó de Enabled a disabled). 

3) En plugins instalados, no me aparece DIVI. Solo tengo el tema DIVI Builider, y desactivado (aparece una descripción que dice: Already included and not needed when using the Divi or Extra theme). Puedo utilizar DIVI y modificarlo sin ningún problema "a pesar" de ello. Es decir, que no sé si necesito tener además del tema DIVI un plugin DIVI activo. 

Comentar que la versión de PHP ha vuelto a la correcta, pero que la modificación que se efectuó esta mañana no se conserva (REST API disabled). Según WPML esto puede ser fruto de errores en WPML (sin embargo esta mañana corregí esto abriendo un ticket pero seguía sin poder traducir los add-ons). Pongo otro ticket para que habiliten la REST API?

Gracias, 

Fernando 

Respondido : 07/02/2020 5:47 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Qué versión de Divi tienes?, en Divi 4 no requiere de plugins constructor ya que viene como parte del tema, por lo que si estas actualizando a Divi 4 no necesitas activar ese plugin.

Antes de actualizar lo que puedes probar es ir desactivando otros plugins ya que es posible que haya algún conflicto, también cambiar la versión de PHP a la 7.2 antes de actualizar y verifica si tras la actualización de Divi te sucede lo mismo.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

Respondido : 07/02/2020 7:33 pm
Fernando me gusta

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Fernando
 Fernando
Usuario eminente

@jmarreros

Hola Jhon, gracias por tu respuesta. 

Cómo actualizo el PHP? Abro un ticket en webempresa para que se realice desde allí?

Y una pregunta, si desactivo un plugin, cuando la activo, vuelve todo a estar como antes? Por ejemplo, si desactivo WPML o Woocommerce, al activarlo volveré a tener la página en doble idioma o los productos como estaban? 

Gracias

Respondido : 07/02/2020 9:34 pm
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@fernanfangmail-com

Hola Fernando,

Para actualizar la versión de php revisa la siguiente guía, por favor -> cambiar-la-version-php

Respecto a tu segunda consulta, generalmente al desactivar una plugin no se eliminan los datos almacenados en la base de datos de WordPress, incluso puedes eliminar el plugin (no solo desactivarlo) y después instalar y activar de nuevo y los datos anteriores seguirán apareciendo. En cualquier caso nuestro consejo es siempre crear una copia de seguridad de la base de datos si se tiene información en gran cantidad o de considerada relevancia. 

Para realizar y gestionar copias de seguridad de la base de datos revisa la siguiente guía, por favor -> guias.webempresa.com › Hosting › Copias de seguridadCopias de seguridad - Preguntas Frecuentes webempresa.com

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

Respondido : 07/02/2020 11:33 pm
Fernando me gusta

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Fernando
 Fernando
Usuario eminente

@bulmaro-webempresa

Hola Bulmaro, 

Muchas gracias por tu respuesta. He realizado ya la actualización de PHP. ¡Qué fácil ha sido! 

Ahora a ver si WPML consigue resolver mis problemas con los products addon, aunque probablemente abra un tema nuevo aquí con algo que he visto al respecto. 

Gracias y buen finde!

Respondido : 08/02/2020 11:02 am
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@fernanfangmail-com

Hola Fernando, 

Me alegra que pudieras realizar el cambio. 

Descuida, puedes consultaros siempre que lo consideres necesario, en el foro estamos para servirte. 

Nos leemos pronto, saludos y buen fin de semana 🙂

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

Respondido : 08/02/2020 9:05 pm
Fernando me gusta

wpdoctor-revisa-la-salud-de-tu-wordpress

Fernando
 Fernando
Usuario eminente

@bulmaro-webempresa

Muchas gracias e igualmente!!!

Respondido : 08/02/2020 9:34 pm

Por favor Iniciar Sesión o Registro