Avisos
Vaciar todo

[Resuelto] Google no indexa mi web  

 
Miguel
 Miguel
Estimable Member

Buenos días:

Ayer publicamos nuestar tienda, diseñada con WpFacil Woo.

He seguido los siguientes pasos:

  1. Crear y verificar la propiedad en Google Search Console (con https:// y www.)
  2. Desmarcar la casilla " Disuadir a los motores de búsqueda de indexar este sitio" en Ajustes/Lectura/ en WP
  3. Configurar el sitemaps y el archivo robots.txt con Yoast SEO (os dejo el contenido de ambos más abajo) 
  4. Subir todos los sitemaps a Google Search Console.

Pasadas 24 horas, al ver que aún habiendo seguido todos estos pasos Google seguía sin idexar la tienda, he vuelto a entrar de nuevo a Google Search Console y en Índice/Cobertura he ido solicitando la indexación de todas las páginas de mi sitemap...Tampoco obtengo resultado.

Dándole vueltas y vuestas, he descubierto que en Herrramientas/Salud del sitio de mi WP, me aparecía un mensaje crítico de Yoast SEO

"An error ocurred while checking whether your site can be found by search engines SEO: Error details: cURL error 28: Operation timed out after 5000 milliseconds with 0 bytes received (http_request_failed)", con este enlace de más información pra el problema: https://yoast.com/yoast-seo-ryte/

... no sé, desde mi ignorancia, me suena a querer vender una solución para el problema... después de seguir trasteando un rato, he vuelto a mirar y el error había desaparecido, pero mi página sigue sin estar indexada.

Todo parece indicar que algo está bloqueando la indexación de mi sitio...

Anteriormente hemos diseñado otras webs corporativas con Joomla y jamás he tenido este problema. Por lo general las webs se indexaron en cuestión de horas. No entiendo nada. Espero que sea una chorrada que no veo en este momento.

¿Qué puede estar pasando? 😱 😱

¡¡Please, help!!

Sitemaps
Inspección de URLs
Inspección de URLs(1)

robots.txt:

User-agent: *
Disallow: /cgi-bin
Disallow: /wp-content/plugins/   
Disallow: /wp-content/themes/   
Disallow: /wp-includes/ 
Disallow: /wp-admin/
Allow: /wp-admin/admin-ajax.php
Allow: /*.js$
Allow: /*.css$
User-agent: MSIECrawler
Disallow: /
User-agent: WebCopier
Disallow: /
User-agent: HTTrack
Disallow: /
User-agent: Microsoft.URL.Control
Disallow: /
User-agent: libwww
Disallow: /
User-agent: Baiduspider
Disallow: /
User-agent: GurujiBot
Disallow: /
User-agent: hl_ftien_spider
Disallow: /
User-agent: sogou spider
Disallow: /
User-agent: Yeti
Disallow: /
User-agent: YodaoBot
Disallow: /
User-agent: Googlebot-Image
Allow: /wp-content/uploads/
User-agent: Adsbot-Google
Allow: /
User-agent: Googlebot-Mobile
Allow: /
Disallow: /test/
sitemap:  https://www.nuestratienda.es/sitemap_index.xml 
sitemap:  https://www.nuestratienda.es/page-sitemap.xml 	
sitemap:  https://www.nuestratienda.es/product-sitemap.xml 	
sitemap:  https://www.nuestratienda.es/product_cat-sitemap.xml 
htaccess:
# BEGIN WordPress
# Las directivas (líneas) entre `BEGIN WordPress` y `END WordPress` se generan dinámicamente
# , y solo se deberían modificar mediante filtros de WordPress.
# Cualquier cambio en las directivas que hay entre esos marcadores se sobreescribirán.
RewriteEngine On
RewriteCond %{ENV:HTTPS} !on [NC]
RewriteCond %{QUERY_STRING} !wc-api [NC]
RewriteCond %{HTTP_HOST} ^(www\.)?
RewriteRule ^(.*)$ https://w$1 [R=301,L,NE]
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
<IfModule mod_expires.c>
ExpiresActive On
# Images
ExpiresByType image/jpeg "access plus 1 year"
ExpiresByType image/gif "access plus 1 year"
ExpiresByType image/png "access plus 1 year"
ExpiresByType image/webp "access plus 1 year"
ExpiresByType image/svg+xml "access plus 1 year"
ExpiresByType image/x-icon "access plus 1 year"
# Video
ExpiresByType video/mp4 "access plus 1 year"
ExpiresByType video/mpeg "access plus 1 year"
# CSS, JavaScript
ExpiresByType text/css "access plus 1 month"
ExpiresByType text/javascript "access plus 1 month"
ExpiresByType application/javascript "access plus 1 month"
# Others
ExpiresByType application/pdf "access plus 1 month"
ExpiresByType application/x-shockwave-flash "access plus 1 month"
</IfModule>
# END WordPress
# Wordfence WAF
<IfModule LiteSpeed>
php_value auto_prepend_file ''
</IfModule>
<IfModule lsapi_module>
php_value auto_prepend_file ''
</IfModule>
<Files ".user.ini">
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
<IfModule !mod_authz_core.c>
Order deny,allow
Deny from all
</IfModule>
</Files>
# END Wordfence WAF

¡Gracias por vuesta ayuda!

Respondido : 29/05/2020 12:46 pm
Miguel
 Miguel
Estimable Member

Con el follón, se me ha escapado varias veces la url de nuestra tienda en el código. Por favor, editadlas para que no aparezcan. Si es más rápido para vosotros borrar la entrada, hacedlo y la vuelvo a crear de nuevo (tengo la consulta copiada).

Gracias y perdonad 🙂

Respondido : 29/05/2020 12:53 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Miguel.

indice/Cobertura he ido solicitando la indexación de todas las páginas de mi sitemap...Tampoco obtengo resultado.

Google no indexa las paginas al instante aunque pidas que indexe una URL y hay que esperar a que el robot de google pase por la web para indexar contenido, esto puede variar incluso pueden pasar semanas.

-> https://www.posicionamientoeficaz.com/blog/cuanto-tiempo-tarda-google-en-indexar-una-pagina-web

En al primera captura veo que los sitemaps están enviados correctamente y que no hay ningún problema.

he descubierto que en Herrramientas/Salud del sitio de mi WP, me aparecía un mensaje crítico de Yoast SEO

Sobre el aviso de Curl comentarte que el aviso se debe a que esa comprobación se basa solo en el número de versión de cURL sin tener en cuenta el Sistema Operativo.

Nosotros utilizamos un Sistema Operativo que intenta combinar seguridad y estabilidad, para ello tiene versiones actualizadas por ellos mismos https://www.redhat.com/es/blog/package-versions-why-our-package-versions-are-almost-never-bumped

De esta forma no hay problema de compatibilidad, no nos vemos afectados por errores de versiones no probadas lo suficiente y se añaden los parches necesarios para que tenga todas las funcionalidades y no tenga vulnerabilidades.

En resumen, es un falso positivo por lo que eso no afectaría al funcionamiento del plugin.

 

En el archivo robot.txt tampoco vemos nada que pueda estar afectando a si que toca esperar a que google revise tu dominio y empiece a indexar paginas, incluso es posible que no las indexe todas de golpe ya que el Robot tiene un tiempo para cada dominio y no indexa todo de Golpe.

 

Un saludo

Respondido : 29/05/2020 2:15 pm
Miguel
 Miguel
Estimable Member

@pepesoler

Muchas gracias por tu respuesta, Pepe.

Me tranquiliza que veas que todo está correctamente configurado y que lo del aviso de Curl del sea un falso positivo, también.

Jamás me había pasado esto y ya llevo unas pocas de páginas web ¡Vaya faena!... con que me indexara la de inicio me valdría para poder lanzar la tienda, pero así es un fastidio, todavía hay mucha gente que en lugar de escribir la dirección web en el navegador, lo hace en el buscador... 😥

Cruzaré los dedos para que sea una cuestión de "tranquilidad" de Google en cuanto a idexar mis páginas y que en unos días comiencen a aparecer, pero me preocupa que algo esté bloqueando el tema y vayamos perdiendo días... ¿no habrá nada incorrecto en el htacces...? ¿estará bloqueando algo el Wordfence...?

Respondido por: @mdominguezathair-es

Con el follón, se me ha escapado varias veces la url de nuestra tienda en el código. Por favor, editadlas para que no aparezcan. Si es más rápido para vosotros borrar la entrada, hacedlo y la vuelvo a crear de nuevo (tengo la consulta copiada).

Gracias y perdonad 🙂

Por cierto, por favor, editad las webs del código del primer post para que no Google no las indexe.

Gracias y buen finde!!

 

Respondido : 29/05/2020 2:33 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Miguel.

ya estan eliminadas, de todas formas lo que tienes añadido dentro de una sección de código no se indexa, digamos que está como oculto.

 ¿no habrá nada incorrecto en el htacces...? ¿estará bloqueando algo el Wordfence...?

En principio no es mas en una de las capturas hay un aviso de google indicando que los Sitemap se cargaron sin problemas y esta correcto, si hubiera algún fallo Google te mostrará el aviso en al consola.

 

Un saludo

Respondido : 29/05/2020 2:44 pm
Miguel me gusta
Miguel
 Miguel
Estimable Member

@pepesoler

No me queda otra que tener paciencia.

¡Gracias, Pepe!

Respondido : 29/05/2020 2:46 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Miguel,

Genial, con esto podemos dar el tema como solucionado

Un Saludo

Respondido : 29/05/2020 2:52 pm
Miguel me gusta