Poner puntos y comas al editar atributos de productos  

 
Juan
 Juan
Noble Member

Hola, Quisiera saber si existe alguna forma de que cuando se editen los atributos de un producto, se puedan añadir comas o puntos, actualmente cuando pongo un atributo y por ejempo pongo una medida de 18,5" y un precio añadido de + 20,5 da error, en primer lugar por la coma y en segundo por ".

Existe alguna forma de evitar éstos errores???

Muchas gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 23/01/2013 8:03 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Juan,

Puedes mostrarnos el error?. Realice una prueba y se muestra correctamente:

Saludos.

ResponderCitar
Respondido : 24/01/2013 3:12 am

Cursos Gratuitos WordPress

Juan
 Juan
Noble Member

Hola , aquí adjunto las capturas.

Captura de como pongo los atributos.

captura de como una vez guardado, cambia de forma automática los atributos.

Captura de como se visualiza en el sitio la captura.

Error (no indica ningún error, pero por distintas pruebas que he hecho si pongo / " ' , tengo que quitar éstos caracteres para que funcione bien)

Saludos

ResponderCitar
Respondido : 24/01/2013 8:57 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Juan,

Revisa http://forum.virtuemart.net/index.php?topic=82649.0

Saludos

ResponderCitar
Respondido : 24/01/2013 9:35 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan
 Juan
Noble Member

Hola, muy buenas

He intentado seguir distintos pasos de http://forum.virtuemart.net/index.php?topic=82649.0, pero no he conseguido corregir el problema que tengo con los puntos, comas y demás en los atributos de los producto.

He indroducido éste código en la line 993 $pagevar=addslashes($pagevar) y haciendo ésto, el producto no carga.

Tambien he editado la linea 181 administratorcomponentscom_virtuemartclassesps_product.php
pero tampoco me carga el producto.

Ayuda porfa!

Saludos!

ResponderCitar
Respondido : 28/01/2013 8:57 am
Hicham
 Hicham
Miembro Admin

Hola Juan,

Como indican en el foro de Virtuemart, la solución sería, en la línea 181 en el fichero :

administratorcomponentscom_virtuemartclassesps_product.php

Debes comentar esta línea :

// strpos( $property, "." ) or

Saludos

ResponderCitar
Respondido : 28/01/2013 10:08 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan
 Juan
Noble Member

Ok muchas gracias! resuelto!!!

ResponderCitar
Respondido : 28/01/2013 10:34 am