Avisos
Vaciar todo

Activo configuración SEO y hay dos cosas que no funcionan  

 
Pilar
 Pilar
Reputable Member

Buenos días.
Tengo un problema en mi tinenda Virtuemart, cuando activo la configuración SEO en Joomla, no me funciona el añadir producto al carrito y además de las imágenes solo aparece una y suele haber más de una. Adjunto pantallazos.
Mi versión de Joomla es: 2.5.14 y la de Virtuemart es: 2.0.24
En estos momentos está desactivada la configuración SEO.
También tengo correctamente creado y renombrado el archivo htaccess.txt a .htaccess.
Estoy perdida....
Gracias por vuestra colaboración.
Pilar.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 22/11/2013 11:15 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

En primer lugar te recomiendo que, previa copia de seguridad, actualices tu Joomla a la versión 1.5.16 que ya está disponible.

También existe una versión 2.0.24b de Virtuemart que también puedes actualizar en el mismo proceso.

He realizado pruebas con Joomla 2.5.16 y Virtuemart 2.0.24 usando la misma plantilla que tú usas y veo que me funciona correctamente el botón de añadir al carro. También se muestran todas las imágenes.

Tendríamos que ver tu web con el SEO activado para ver si notamos algo raro.

También tendrías que indicarnos si has realizado algún cambio en la configuración de Virtuemart o has instalado extensiones adicionales.

ResponderCitar
Respondido : 22/11/2013 1:51 pm

Cursos Gratuitos WordPress

Pilar
 Pilar
Reputable Member

Hola Pablo.

No he cambiado la configuración de Virtuemart.
Si he instalado la extensión Artio VM Invoice.

Como me recomiendas voy a actualizar tanto Joomla como Virtuemart, te iré informando.

Gracias.

ResponderCitar
Respondido : 22/11/2013 4:23 pm
Pilar
 Pilar
Reputable Member

Hola Pablo.
Ya he actualizado con éxito Joomla a la versión 2.5.16, pero tengo un problema y es que para actualizar Virtuemart 2.0.24b preciso PHP 5.3 o superior. Y dispongo del PHP 5.2.
Debería realizar un ticket a soporte técnico?

Al actualizar Joomla, no ha habido cambios, sigo con el mismo problema.

Saludos

ResponderCitar
Respondido : 22/11/2013 5:13 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Pilar

Si deseas actualizar a PHP 5.3 debes enviar un ticket a soporte

Saludos.

ResponderCitar
Respondido : 22/11/2013 6:40 pm
Pilar
 Pilar
Reputable Member

Bueno no es que lo desee, es que no tengo más alternativa, si quiero solucionar mis problemas.

Gracias Jhon.

ResponderCitar
Respondido : 22/11/2013 6:46 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Pilar

Antes de actualizar no te olvides de hacer una copia de seguridad de tu sitio web

Saludos.

ResponderCitar
Respondido : 22/11/2013 9:00 pm
Pilar
 Pilar
Reputable Member

Buenos días.

Después de haber realizado los cambios que me indicabais, sigo igual.
Actualicé Joomla a la última versión 2.5.16.
Actualicé Virtuemart (con el consiguiente desembolso de un nuevo hosting configurado para PHP 5.3), a 2.0.24b y al ver que seguía igual actualicé a 2.0.24c.

Y no solo no me funciona el AÑADIR AL CARRITO, ni tampoco me salen todas las fotos de miniatura, si no que ahora me sale un aviso en el que pone:
The chosen template couldnt find on the filesystem: 122

Adjunto pantallazo, he dejado la web con el SEO configurado para que veáis lo que comento.

Necesito ayuda...

Gracias.

ResponderCitar
Respondido : 25/11/2013 12:47 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pilar
 Pilar
Reputable Member

Buenas tardes.

He podido solucionar lo del aviso:
The chosen template couldnt find on the filesystem: 122. Una vez en Virtuemart, parece ser que me faltaba realizar la actualización desde aquí. Una vez hecho, el aviso desapareció.

Pero lo del tema de AÑADIR AL CARRITO y lo de las imágenes miniaturas sigue igual..

Por favor necesito ayuda...

Gracias.

ResponderCitar
Respondido : 25/11/2013 4:45 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Pilar,

Parece que el modulo de la parte superior esta causando conflictos. Desactivalo o solo publicalo en la pagina de inicio para hacer la prueba, el siguiente articulo de Blog te sera de utilidad:

Detectar conflictos de jQuery, Javascript, Mootools mediante la herramienta Firebug

Saludos.

ResponderCitar
Respondido : 25/11/2013 7:55 pm

Cursos Gratuitos WordPress

Pilar
 Pilar
Reputable Member

Hola Johnny.
Has dado en el clavo.
He cambiado la publicación del módulo solo para la página de inicio, y esa era la solución.

Después de la movida que he realizado (cambiar la web de hosting para que éste estuviera configurado en PHP 5.3), y resulta que con despublicar el módulo de marras era suficiente....

Vaya fin de semanita que he pasado...

Gracias Johnny.

ResponderCitar
Respondido : 26/11/2013 12:21 pm